Solved: Smtube on mint 7-xfce and mint 13-xfce

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Solved: Smtube on mint 7-xfce and mint 13-xfce

Postby josip on Wed Jan 15, 2014 4:41 am

Since I'm not satisfied with non smooth viewing of youtube with Firefox I tried to install smtube. Non smooth is also MP4 movie with Mplayer.
PC is an old one: x86, 1200 Mhz, RAM 512 MB, Asus, S3 Graphics ProSavage 8A26, linux mint 7-xfce

Tried to install smtube on linux mint 7-xfce using the commands proposed on web page of smtube:

When I type into terminal:
sudo add-apt-repository ppa:rvm/smplayer
got the message:
sudo: add-apt-repository: command not found

Why?

If I go on with:
sudo apt-get update
sudo apt-get install smtube
got the message:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package smtube


If somebody knows the answer how to install smtube? Thanks.
Last edited by josip on Wed Jan 22, 2014 5:59 am, edited 2 times in total.
josip
Level 1
Level 1
 
Posts: 11
Joined: Wed Jan 15, 2014 4:00 am

Linux Mint is funded by ads and donations.
 

Re: Smtube on mint 7-xfce

Postby kc1di on Wed Jan 15, 2014 7:03 am

Hello josip,

Mint 7 has been Obsolete since October 2010. That means the repositories are no long available and you will not be able to use them.
You would be better off updating to a newer version say 13. Mint is at version 16 now.

I would go to a distro like lxle that would run on an older machine like that but the video card may be too old to give you good video also.
your can find lxle here:
http://lxle.net/
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1211
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Smtube on mint 7-xfce

Postby josip on Wed Jan 15, 2014 5:19 pm

Thanks, I see now.
All the day trying to upgrade my Mint 7 with DVD to:
- Mint 16 - at the end got the unreadable rectangles on the display and cannot do anything
- Mint 13 - after two hours got the message Kernel panic - Attempting to kill init
Will try more tomorrow...
josip
Level 1
Level 1
 
Posts: 11
Joined: Wed Jan 15, 2014 4:00 am

Re: Smtube on mint 7-xfce

Postby josip on Fri Jan 17, 2014 5:09 pm

The mint 13 installation problem solved in:
viewtopic.php?f=46&t=156435
Last edited by josip on Tue Jan 21, 2014 3:53 pm, edited 1 time in total.
josip
Level 1
Level 1
 
Posts: 11
Joined: Wed Jan 15, 2014 4:00 am

Re: Smtube on mint 7-xfce

Postby josip on Tue Jan 21, 2014 10:29 am

My previous post is about succesfull installation and update of Mint 13 xfce on my old PC.
I still cannot install Smtube from terminal, got the message: E: Couldn't find package smtube.
Then:
- I've installed Smplayer from Software manager. It is installed and can find it in menu but when I try to play the mp4 video got the message: Mplayer has crashed. Why Mplayer?
- I tried to install Snappy from Software manager, but after installation I cannot find it in Mint 13 menu.
- I've installed Minitube: with it I can find the videos in youtube but cannot run them.

Where could be my problem of installing the applications on Mint 13?
josip
Level 1
Level 1
 
Posts: 11
Joined: Wed Jan 15, 2014 4:00 am

Re: Smtube on mint 7-xfce

Postby josip on Tue Jan 21, 2014 3:51 pm

After commands from
http://www.noobslab.com/2013/07/minitub ... buntu.html
sudo add-apt-repository ppa:noobslab/apps
sudo apt-get update
sudo apt-get install minitube

I can run Minitube on Mint 13, but the quality of video is the same as in Firefox/Youtube (non smoothly).
josip
Level 1
Level 1
 
Posts: 11
Joined: Wed Jan 15, 2014 4:00 am

Re: Smtube on mint 7-xfce and mint 13-xfce

Postby gold_finger on Tue Jan 21, 2014 9:59 pm

josip wrote:I still cannot install Smtube from terminal, got the message: E: Couldn't find package smtube.

Did you follow same steps as before, starting with adding the ppa first? Steps you listed in first post are correct -- they are same as described here: http://smplayer.sourceforge.net/en/smtube.

That should work now that you are using Mint 13. I just did it with one of my VirtualBox distros and it worked. Try again by copy/pasting commands from that page just to be sure you don't make a typo. If still won't work, report back and I'll install Mint 13 to VBox and try to figure out what's wrong for you.
Add "Solved" to title of thread if solution is found. (Go to your first post and hit "Edit" button.) This helps make it easier for others to find solutions that work.

Try Linux Beginner Search Engine for Linux questions.
gold_finger
Level 6
Level 6
 
Posts: 1072
Joined: Mon Mar 11, 2013 11:39 pm

Re: Smtube on mint 7-xfce and mint 13-xfce

Postby josip on Wed Jan 22, 2014 5:58 am

Thanks! Many times have done these commands, now with success. Smtube now plays the videos from youtube smoothly (some of them cannot open - but this would be the next research).
Now I'm going to find a player for mp4 videos on old PC running smoothly...
josip
Level 1
Level 1
 
Posts: 11
Joined: Wed Jan 15, 2014 4:00 am

Re: Solved: Smtube on mint 7-xfce and mint 13-xfce

Postby gold_finger on Wed Jan 22, 2014 4:00 pm

josip wrote:Now I'm going to find a player for mp4 videos on old PC running smoothly...


If you don't already have it on the computer, install VLC Media Player. It plays just about any format with no problem. Can install from Software Center or by using the terminal:
Code: Select all
sudo apt-get install vlc
Add "Solved" to title of thread if solution is found. (Go to your first post and hit "Edit" button.) This helps make it easier for others to find solutions that work.

Try Linux Beginner Search Engine for Linux questions.
gold_finger
Level 6
Level 6
 
Posts: 1072
Joined: Mon Mar 11, 2013 11:39 pm

Re: Solved: Smtube on mint 7-xfce and mint 13-xfce

Postby josip on Wed Jan 22, 2014 5:22 pm

VLC doesn't run smoothly, also all others Mplayer, Xnoise etc.
I tried Xine. After nice running 30 seconds of mp4 it says 'too many lost packets, try to optimize system', lost audio ...
Xine-check says there is problem with kernel, cannot find xine-lib etc. May be Xine is not available for Mint 13.
josip
Level 1
Level 1
 
Posts: 11
Joined: Wed Jan 15, 2014 4:00 am

Re: Solved: Smtube on mint 7-xfce and mint 13-xfce

Postby josip on Fri Feb 14, 2014 3:58 pm

Here are my additional efforts about SMplayer, SMtube and Mplayer running mp4 and youtube smoothly:

http://forum.smplayer.info/viewtopic.php?f=2&t=7115
josip
Level 1
Level 1
 
Posts: 11
Joined: Wed Jan 15, 2014 4:00 am

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 3 guests