No sound coming out from a Macbook 5,2 headphones

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

No sound coming out from a Macbook 5,2 headphones

Postby canhoto on Thu Jan 16, 2014 10:58 pm

:( Can anyone help solving a problem on a Macbook 5,2 running Linux Mint 16, in which no sound comes out from the headphones nor external loudspeakers? I tried to change things in Alsa Mixer and Sound settings, but with no luck. It does mute the built-in speakers and it recognizes the phones (in the sound settings), but no sound comes out from it.

I tried lots of possibilities of changing /etc/modprobe.d/alsa-base.conf , namely those suggested in this thread, which should work:

http://ubuntuforums.org/showthread.php?t=1370252

But the result is always the same:
- when I plug in the headphones/earphones, the built-in speakers are muted, but there's no sound from the headphones
- in alsamixer the Headphones column is automatically unmuted and put to a high volume; but nothing comes out; I tried to unmute and increase the volume level of all the sliders (speakers, PCM, master, etc.) but no success: still no sound from the speakers

The chipset is a Realtek ALC889A.

BTW, I have another Macbook (2,1) running Elementary OS Luna and it runs out of the box


Any help, please?
canhoto
Level 1
Level 1
 
Posts: 3
Joined: Thu Aug 16, 2012 6:37 am

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 8 guests