Linux MINT 16 and ALSA support - remove PulseAudio

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Linux MINT 16 and ALSA support - remove PulseAudio

Postby Koninator on Sat Jan 18, 2014 7:09 pm

Hi,
I have found a great tutorial for MINT 10
How To: Completely remove PulseAudio & replace it with ALSA (viewtopic.php?f=197&t=60485&start=40)

But sadly this tutorial don't work in MINT 16 MATE.
I have followed all the steps:
A. Menu > Preferences > Startup Applications > uncheck "PulseAudio Sound System", PulseAudio Sound System KDE Routing Policy" and "Volume Control"
B. Menu > Administration > Services > uncheck "pulseaudio"
C. Remove pulseaudio, related packages and configuration files
Code: Select all
killall pulseaudio
sudo killall pulseaudio
sudo apt-get purge pulseaudio pulseaudio-utils gstreamer0.10-pulseaudio libpulse-browse0 paman pavumeter pavucontrol
sudo mv /etc/asound.conf /etc/asound.conf-bak
rm ~/.pulse-cookie
rm -r ~/.pulse

D. Install libalsaplayer0 package
Code: Select all
sudo apt-get install libalsaplayer0

E. Restart your computer
F. Right click Panel, select "Add to Panel" and add "Volume Control" to Panel

But for mixser I had used Qasmixer
Code: Select all
sudo apt-get install qasmixer

And added to "Menu > Preferences > Startup Applications" new entry:
Code: Select all
qasmixer --tray


Tray icon works fine but sound don't work - no sound. Any advice how to enable ALSA?

Code: Select all
user@pc ~ $ lspci | grep -i audio
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Trinity HDMI Audio Controller
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
user@pc ~ $ cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel
user@pc ~ $ cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xf0444000 irq 54
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xf0440000 irq 16
user@pc ~ $ cat /proc/asound/card0/pcm3p/info
card: 0
device: 3
subdevice: 0
stream: PLAYBACK
id: HDMI 0
name: HDMI 0
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1
user@pc ~ $ cat /proc/asound/card1/pcm0p/info
card: 1
device: 0
subdevice: 0
stream: PLAYBACK
id: 92HD87B2/4 Analog
name: 92HD87B2/4 Analog
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1
Koninator
Level 3
Level 3
 
Posts: 131
Joined: Sat Mar 14, 2009 9:57 am

Linux Mint is funded by ads and donations.
 

[SOLVED]Linux MINT 16 and ALSA support - remove PulseAudio

Postby Koninator on Sat Jan 18, 2014 9:20 pm

In AntiX forum somone had same problem. (http://antix.freeforums.org/viewtopic.p ... view=print)
Which led me to Mail Arhive (http://www.mail-archive.com/alsa-user@l ... 29155.html)

Code: Select all
cat /proc/asound/cards
lspci | egrep -i audio

This two commands show that I have 2 sound cards. I want to enable the second one.
This problem is because of AMD APU CPU integrated graphic card and HDMI output.

Code: Select all
gedit mpd.conf

audio_output {
type "alsa"
name "My ALSA Device"
device "hw:1,0"
# mixer_type "software"
# mixer_device "default"
# mixer_control "PCM"
}
Code: Select all
sudo gedit /etc/asound.conf

pcm.!default {
type plug
slave {
pcm "hw:1,0" #delete the first hash for sound over analog
# pcm "hw:1,1" #delete the first hash for sound over optical
# pcm "hw:0,3" #delete the first hash for sound over hdmi
rate 48000
}
}
Code: Select all
gedit .asoundrc

pcm.mpd {
type hw
card 1
}

But there is one problem, I can't use two sound streams/applications at same time.
(If I using flash on youtube then I can't use vlc, or Banshee. Or if I'm using vlc I can't use Banshee or flash video.)
So problem is partially solved. Still looking for better solution.
Koninator
Level 3
Level 3
 
Posts: 131
Joined: Sat Mar 14, 2009 9:57 am


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 7 guests