New ..Toshiba Satellite L300 .. sound problems

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

New ..Toshiba Satellite L300 .. sound problems

Postby daka on Fri Aug 29, 2008 12:00 pm

Hi

I can play Mp3, wav etc. but the sound card (alsa mixer) only shows "Master, PDM and Digital" ... no recording possible.

Does anyone know if there might be a driver necessary? I tried different selections other than alsa (OSS ... Realtek etc. but no luck).

Thanks

Daka
daka
Level 1
Level 1
 
Posts: 46
Joined: Tue Jan 09, 2007 6:57 am
Location: sometimes spain sometimes ireland

Linux Mint is funded by ads and donations.
 

Re: New ..Toshiba Satellite L300 .. sound problems

Postby Husse on Fri Aug 29, 2008 3:16 pm

no recording possible.

You mean no microphone setting?
Double click the volume applet next to the clock
In the mixer that opens > Edit > Preferences > Mark what you want to be visible
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: New ..Toshiba Satellite L300 .. sound problems

Postby daka on Fri Aug 29, 2008 3:35 pm

Hi Husse

Thanks for answering

The mixer only shows Master PCM and Digital. There is something missing with the alsa configuration. I found the following info:

http://forum.ubuntu-fr.org/viewtopic.php?id=228341 )in french)
Il faut désactiver le lan dans le bios pour pouvoir l'installer à partir du cd d'installation. Il faut ensuite se débrouiller pour pouvoir faire une mise à jour du noyau pour pouvoir réactiver le lan. Pour faire fonctionner le wifi aller voir ici. Pour pouvoir se connecter avec du WPA: utiliser wicd et choisir "ipw" dans les preferences comme wpa supplicant driver.
pour le micro: Installez linux-backports-modules et éditez le fichier /etc/modprobe.d/alsa-base en rajoutant options snd-hda-intel model=test à la fin

but here is the translation by Alta Vista:

It is necessary to decontaminate the lan in the bios to be able l' to install starting from Cd d' installation. It is then necessary to manage to be able to make an update of the core to be able to reactivate the lan. To make function the wifi to go to see here. To be able to connect itself with WPA: to use wicd and choose " ipw" in the preferences like wpa supplicant driver. for the microphone: Install linux-backports-modules and publish the /etc/modprobe.d/alsa-base file by adding options snd-hda-INTEL model=test at the end

So far I have installed the linux-backports-modules and now I need to see if I can follow the instructions re: editing the "alsa-base" file ....... NO LUCK ... Can't find directory "modprobe.d" in /etc so I can find "alsa-base" file ....

I am running Daryna.... any suggestions where I might find that file?

Looks like I will have a bit of tweaking with the wifi.... for now I am connecting by mobile modem (Vodafone USB)

Daka
daka
Level 1
Level 1
 
Posts: 46
Joined: Tue Jan 09, 2007 6:57 am
Location: sometimes spain sometimes ireland

Re: New ..Toshiba Satellite L300 .. sound problems

Postby Husse on Sat Aug 30, 2008 7:19 am

Can't find directory "modprobe.d

In that case there's a risk that your system is completely dead :)
Must be there....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: New ..Toshiba Satellite L300 .. sound problems

Postby daka on Sat Aug 30, 2008 9:16 am

I finally found it ... changed the file as per instructions..the alsa mixer now shows all the options, including mic ... BUt I still don't have it working.... maybe fiddling a bit with alsa settings will solve it. Also I have seen other suggestions for the modifications to "alsa-base" file in other threads so I can try them. I will let you know how I get on. Thanks for your patient help.

Daka
daka
Level 1
Level 1
 
Posts: 46
Joined: Tue Jan 09, 2007 6:57 am
Location: sometimes spain sometimes ireland

Re: New ..Toshiba Satellite L300 .. sound problems

Postby daka on Sat Aug 30, 2008 10:00 am

I sent this to Ubuntu forum but I think I should also put it here.

Hi

I have been struggling to get the recording working (mic) on this soundcard for a few days. Some threads have indicated that one has to change the /etc/modconf.d/alsa-base file ... at the end where it says "model= _____"

I have tried all the suggested options with no luck. Does anyone have any suggestions?

Options suggested in one thread are... 6stack 3stack laptop laptopeapd and ultra

Here is my alsa-base file if it helps anyone with a suggestion:

daka@daka-TB:/etc$ sudo vim alsa-base
daka@daka-TB:/etc$ cd modprobe.d
daka@daka-TB:/etc/modprobe.d$ vim alsa-base
daka@daka-TB:/etc/modprobe.d$ vim alsa-base
daka@daka-TB:/etc/modprobe.d$ vim alsa-base
daka@daka-TB:/etc/modprobe.d$ vim alsa-base
daka@daka-TB:/etc/modprobe.d$ vim alsa-base
daka@daka-TB:/etc/modprobe.d$ cat alsa-base
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
# Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
# non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388 snd-hda-intel model=ultra



Thanks

Daka
daka
Level 1
Level 1
 
Posts: 46
Joined: Tue Jan 09, 2007 6:57 am
Location: sometimes spain sometimes ireland


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 8 guests