Audio - too many options - what to recommend?

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Audio - too many options - what to recommend?

Postby Oceanwatcher on Wed Sep 24, 2008 8:02 pm

When I am looking at the drop-down menu in my sound preferences, I now have a long list of things to choose from.

I have Autodetect - would probably work fine if I only had one soundcard with one input/output...

I have C-Media - this is the on-board sound. Not using that for any heavy stuff, but will add a loudspeaker to it just for the system beeps.

I have RME Digi9652 (Rev 1.5). This is a very nice soundcard that I have connected to an audiomixer via optical cables.

ALSA - ESD - OSS - Pulse Audio Sound Server - These options need some explanations.

I also would like to run Ardour, and that needs Jack, yet another audio system. I have read quite a bit about Jack and have a fair understanding of it. But can this be used for all applications? Will Rythmbox Music Player be fine with it? Will Skype be ok with Jack? Basically, I am looking for the golden solution so I can disable as many of the others as possible. And it is very important that it accepts audio from several sources at the same time. I need to be able to play music in the background and hear the sounds from Pidgin and from Skype. Today, I was playing music in Rythmbox and no sound from Pidgin and Skype.

It would actually be good to have the different audio options for Linux explained, pro's and con's and a recommendation about what to use. Maybe this should be a sticky.

For PulseAudio, I found some good info here, but this is waaaay over what you can expect a normal user to go into.
Regards,

Oceanwatcher
My blog - http://www.wisnaes.com/
My photo page - http://www.oceanwatcher.com/
New page for Norwegian readers - http://www.datahverdag.com/
User avatar
Oceanwatcher
Level 2
Level 2
 
Posts: 93
Joined: Sat Aug 16, 2008 11:00 am
Location: Delfim Moreira, Brazil

Linux Mint is funded by ads and donations.
 

Re: Audio - too many options - what to recommend?

Postby Oceanwatcher on Fri Sep 26, 2008 10:25 pm

So - I caved in and disabled the onboard sound in BIOS. Seemed like things were working for a few seconds. Then I started playing with settings. Tried to choose other things than the RME card. Nothing works. Getting an error message:

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not open audio device for playback. Device is being used by another application.

Now I get this no matter what solution I try. This should not be necessary. I need a solution that can be used from all programs on my pc at the same time if I so choose. As it is now, I do not get anything...

Logging out and back in fixed that problem. As long as I choose the RME card and not ALSA, Pulseaudio or any of the other systems, I can hear sound from Skype and Pidgin. But after testing that Rythmbox works, Pidgin sounds are gone. Testing Skype shows it is fine. Opening Sounds in control center and trying a test sound. That one plays fine. And now sounds from Pidgin works again.

I am pulling my hair out here. Do anyone know what the problem might be? One thing is sure - waaaaay too many options. Here it would be nice to have one or two. That worked.
Regards,

Oceanwatcher
My blog - http://www.wisnaes.com/
My photo page - http://www.oceanwatcher.com/
New page for Norwegian readers - http://www.datahverdag.com/
User avatar
Oceanwatcher
Level 2
Level 2
 
Posts: 93
Joined: Sat Aug 16, 2008 11:00 am
Location: Delfim Moreira, Brazil

Re: Audio - too many options - what to recommend?

Postby infamous on Wed Oct 01, 2008 8:08 pm

It might help if you give more information about what version of Mint you are running. For me the gnome editions work pretty good without changing any settings, the kde editions need some messing with setting to do what I need to do. Some programs work good with one sound server and bad with another. Pulse Audio for example is a really nice server used by default in Mint main edition and several others I think. But some programs wont work with it so you may need to use ALSA or something else to get them working. There is no golden fix all solution to make sound work perfect for every application on every setup. If there was Mint would already come configured that way.
This is kinda the nature of GNU/Linux in my opinion. Its a chaotic world where many people are taking their projects in different directions and only time will tell what projects are successes and which ones will fail. I feel your pain as I too have spent a lot of time configuring sound servers and haven't really learned anything that would be too helpful to you. All I could suggest would be to keep at it and hopefully you can find a workable solution. Someone hear may be able to help you and to increase the chance of that happen be as specific as you can about what you are running and what you want to do.
infamous
Level 2
Level 2
 
Posts: 73
Joined: Mon Aug 04, 2008 4:21 pm

Re: Audio - too many options - what to recommend?

Postby Oceanwatcher on Thu Oct 02, 2008 9:32 am

Sorry - running Mint5.

Yes, too many options definitely seem to be the problem of Linux and will prohibit it to become more widely adopted. People do not want options in general. They want it to work. Every time. Predictability is the main concern.

I suspect my main problem is the soundcard I am using. I am not using on board audio.
Regards,

Oceanwatcher
My blog - http://www.wisnaes.com/
My photo page - http://www.oceanwatcher.com/
New page for Norwegian readers - http://www.datahverdag.com/
User avatar
Oceanwatcher
Level 2
Level 2
 
Posts: 93
Joined: Sat Aug 16, 2008 11:00 am
Location: Delfim Moreira, Brazil

Re: Audio - too many options - what to recommend?

Postby Oceanwatcher on Mon Oct 06, 2008 10:31 am

Right now, the only sound I can get from my PC is the system beep.

This is one of the messages I get when I am trying to play a test sound:

RME Digi9652 (Rev1.5) as Sound Playback:

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not open audio device for playback. Device is being used by another application.

Same for ALSA and OSS. ESD gives this:

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not establish connection to sound server

And PulseAudio gives this:

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Failed to connect: Connection refused

I have sync coming in on ADAT1 from external sync source. This gives a 44.1 KHz sync and has been working for a while.

The problem I have had before was that although Skype, Pidgin, Thunderbird and Twhirl seemed to be able to use the same audiocard, as soon as I fired up Rythmbox, the audio gets messed up. No sound from the other programs, and if I am really unlucky, no sound from Rythmbox either. I am getting real tired of this. I just want audio to work!
Regards,

Oceanwatcher
My blog - http://www.wisnaes.com/
My photo page - http://www.oceanwatcher.com/
New page for Norwegian readers - http://www.datahverdag.com/
User avatar
Oceanwatcher
Level 2
Level 2
 
Posts: 93
Joined: Sat Aug 16, 2008 11:00 am
Location: Delfim Moreira, Brazil

Re: Audio - too many options - what to recommend?

Postby Oceanwatcher on Sat Oct 11, 2008 4:01 pm

Please - someone here must be able to take me by the hand and help me figure out the mystery of Linux audio?
Regards,

Oceanwatcher
My blog - http://www.wisnaes.com/
My photo page - http://www.oceanwatcher.com/
New page for Norwegian readers - http://www.datahverdag.com/
User avatar
Oceanwatcher
Level 2
Level 2
 
Posts: 93
Joined: Sat Aug 16, 2008 11:00 am
Location: Delfim Moreira, Brazil

Re: Audio - too many options - what to recommend?

Postby shane on Sun Oct 26, 2008 5:25 am

I have to admit that audio in Linux is a real big mess.

My suggestion to you would be to reinstall your system and use just one sound server... ALSA or PulseAudio. I like ALSA more but PulseAudio seems to be the future of audio on Linux.

To use ALSA try this. Purge all other sound system packages and reinstall alsa packages (alsa, alsa-base, alsa-utils). Then create a file /etc/asound.conf and have its contents be

Code: Select all
# the sound card
pcm.real {
  type hw
  card 0
  device 0
}

# the ipc stuff is needed for permissions, etc.
pcm.dmixer {
  type dmix
  ipc_key 1024
  ipc_perm 0666
  slave.pcm "real"
  slave {
    period_time 0
    period_size 1024
    buffer_size 8192
    rate 44100 
  }
  bindings {
    0 0
    1 1
  }
}

ctl.dmixer {
  type hw
  card 0
  }

# software volume
pcm.softvol {
  type softvol
  slave.pcm "dmixer"
  control {
    name "Software"
    card 0
  }
}

# input
pcm.input {
        type dsnoop
        ipc_key 3129398
        ipc_key_add_uid false
        ipc_perm 0660
        slave.pcm "810"
}

# duplex device
pcm.duplex {
        type asym
        playback.pcm "softvol"
        capture.pcm "input"
}

# default devices
pcm.!default {
  type plug
  slave.pcm "duplex"
}

# for oss devices
pcm.dsp0 {
  type plug
  slave.pcm "duplex"
}


You may have to change it to suit your hardware especially since you have two sound cards you want to use. Maybe this guide will be helpful http://www.linuxjournal.com/article/8234. So basically get it to work well excluding the Jack apps... rythmbox, pidgin etc...

Then for your Jack apps, install qjackctl. This will let you start/stop Jack as you require without having to mess with ALSA. In my limited use of this approach, it has worked well. I only use this for Creox. I am not sure how well qjackctl+Jack play with PulseAudio.
User avatar
shane
Level 6
Level 6
 
Posts: 1300
Joined: Sun Feb 25, 2007 11:15 pm

Spam Alert!

Postby Elantra on Thu Nov 20, 2008 4:02 pm

Spammers are starting to pollute this forum. What's happened to people these days.
Elantra
 

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 7 guests