MIDI playback on Mint 17 - SOLVED

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

MIDI playback on Mint 17 - SOLVED

Postby gingertom5005 on Thu Jul 03, 2014 2:15 pm

I have just installed Mint 17 Mate 64 bit on my system having running Mint 13 32 bit very satisfactorily.

My problem is that I can't now play MIDI files. I have installed Timidity but to no avail. When I try to play MIDI files all get is a message that says first that the system is trying to find multimedia plugins and then says it needs gstreamer1.0-plugins-bad (i386). Any ideas how I can get my MIDI files to play?
Last edited by gingertom5005 on Thu Jul 03, 2014 6:14 pm, edited 1 time in total.
gingertom5005
Level 1
Level 1
 
Posts: 12
Joined: Sun Sep 23, 2012 4:52 pm

Linux Mint is funded by ads and donations.
 

Re: MIDI playback on Mint 17

Postby gtsfer on Thu Jul 03, 2014 2:34 pm

If I remember this correctly Timidity runs from the command line. See this link... http://blog.thameera.com/playing-midi-files-in-ubuntu/. There are other midi players that should be available right through Synaptic Package Manager. Playmidi is one that I saw, you can search in SPM and see what's easily available for your distro.
There's no Windows in my house. And it's a brighter and happier place now.
LMDE 64-bit MATE Edition. Please edit your first post and add SOLVED to the Subject if you get it resolved.
User avatar
gtsfer
Level 6
Level 6
 
Posts: 1438
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: MIDI playback on Mint 17

Postby gingertom5005 on Thu Jul 03, 2014 4:45 pm

Thanks for this but it hasn't solved the problem.
gingertom5005
Level 1
Level 1
 
Posts: 12
Joined: Sun Sep 23, 2012 4:52 pm

Re: MIDI playback on Mint 17

Postby gtsfer on Thu Jul 03, 2014 5:24 pm

You'd probably be ok installing gstreamer1.0-plugins-bad from Synaptic Package Manager (if it shows up in your Cinnamon 17 64-bit). The name is misleading a little, the description (in Synaptic or via a Google search) says...

"GStreamer Bad Plug-ins is a set of plug-ins that aren't up to par compared
to the rest. They might be close to being good quality, but they're missing
something - be it a good code review, some documentation, a set of tests, a
real live maintainer, or some actual wide use."

As it turns out I have it installed myself in LMDE so it's not going to break your system. :) Just thought I'd suggest something else as this isn't the best plugin, but it's what Timidity uses. I forget why I needed to installed it myself (it wasn't for Timidity) but it's being used in one of my audio applications or other.
There's no Windows in my house. And it's a brighter and happier place now.
LMDE 64-bit MATE Edition. Please edit your first post and add SOLVED to the Subject if you get it resolved.
User avatar
gtsfer
Level 6
Level 6
 
Posts: 1438
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: MIDI playback on Mint 17

Postby kyphi on Thu Jul 03, 2014 5:59 pm

You have 2 options:

1. See my previous post: http://forum.linuxmint.com/viewtopic.php?f=48&t=154394 regarding the requirements for Timidity.

2. Install the plugin for VLC
Code: Select all
sudo apt-get install vlc-plugin-fluidsynth
Then you can get midi playback via VLC
User avatar
kyphi
Level 5
Level 5
 
Posts: 878
Joined: Sat Jul 09, 2011 1:14 am
Location: Australia

Re: MIDI playback on Mint 17

Postby gingertom5005 on Thu Jul 03, 2014 6:12 pm

Wow - works fine, thanks. VLC is fine for the MIDI files now.
gingertom5005
Level 1
Level 1
 
Posts: 12
Joined: Sun Sep 23, 2012 4:52 pm

Re: MIDI playback on Mint 17 - SOLVED

Postby kyphi on Fri Jul 04, 2014 2:48 am

Timidity and its interfaces coupled with freepats work well too, you know.

Anyway, I am glad that you can enjoy your midi files. Have you looked at Warren Trachtman's site: http://www.trachtman.org/ragtime/
User avatar
kyphi
Level 5
Level 5
 
Posts: 878
Joined: Sat Jul 09, 2011 1:14 am
Location: Australia

Re: MIDI playback on Mint 17 - SOLVED

Postby gtsfer on Fri Jul 04, 2014 7:44 am

kyphi wrote:Timidity and its interfaces coupled with freepats work well too, you know.

Kyphi, that's an excellent and easy fix. I had no idea that this VLC plugin worked for midi. Bookmarked for future reference. :)
There's no Windows in my house. And it's a brighter and happier place now.
LMDE 64-bit MATE Edition. Please edit your first post and add SOLVED to the Subject if you get it resolved.
User avatar
gtsfer
Level 6
Level 6
 
Posts: 1438
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 7 guests