A/V playback at a faster speed - Choppy sound - <SOLVED>

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

A/V playback at a faster speed - Choppy sound - <SOLVED>

Postby Errlyriser on Wed Jul 09, 2014 9:46 pm

I've searched through about 8 pages in this forum trying to find a solution. What I've found hasn't helped, so I'm posting.
When I play a video through either Banshee or VLC or another media, the playback is fast, sometimes jerky. It's almost as if the video is in fastforward and play at the same time. I've read that other distros don't have this problem, but I don't want to switch - I really like the one I'm using.
Can anyone help?

LM 17 MATE 64-bit
MSI Z97 Gaming 3 mobo
Sound: utilizing onboard sound
Video: EVGA GeForce GTX 660
Intel iCore 7-4770
Ram: G.Skill Ripsaw 4GB
Seagate 1TB SSD/HDD

Edit:
I switched from MATE to XFCE, thinking that this would be different - it didn't resolve the issue. HOWEVER, I did find a fix for the choppy/static sound.
Intel chipset Z97
You have to make a modification to alsa-base.conf
From your terminal, type:
sudo gedit " /etc/modprobe.d/alsa-base.conf"

when the file opens, scroll down until you see a list of "options snd ...."
At the end of the list, add in:
options snd-hda-intel vid=8086 pid=8ca0 snoop=0

That's it! I'm playing YouTube right now with crystal clear sound!

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1321421 #28

http://www.linuxforums.org/forum/ubuntu-linux/119390-cannot-edit-alsa-base.html #4 for sudo gedit

https://bbs.archlinux.org/viewtopic.php?id=181764&p=2 #44
Errlyriser
Level 1
Level 1
 
Posts: 3
Joined: Sun Jul 06, 2014 8:41 pm

Linux Mint is funded by ads and donations.
 

Re: A/V playback at a faster speed - Choppy sound - <SOLVED>

Postby nich on Mon Oct 06, 2014 1:29 am

Awesome thanks for sharing. this worked for me too after a restart.
nich
Level 1
Level 1
 
Posts: 1
Joined: Mon Oct 06, 2014 1:22 am

Re: A/V playback at a faster speed - Choppy sound - <SOLVED>

Postby tinca on Tue Oct 07, 2014 12:21 pm

errlyriser

thanks for your post. I too have a Z97 chipset, and my sound has been awful. It sounds like loud static.

I followed your advice, re-booted and everything is fine. Great post

Best Regards Keith
Case Corsair Graphite 600T White | Motherboard Gigabyte Z97X-UD5H-BK | CPU Core i7 4790K | PSU Corsair 1000w RM Fully Modular | Graphic Card Radeon R7 250 | Cooler Corsair H100i Extreme | Ram Corsair 2 x 8 gb Vengeance Pro |
tinca
Level 4
Level 4
 
Posts: 335
Joined: Sun Jan 11, 2009 9:23 am
Location: England U.K.

Re: A/V playback at a faster speed - Choppy sound - <SOLVED>

Postby lmintfernvale on Mon Nov 10, 2014 10:22 am

Thanks for posting this, Errlyriser. Fixed the same problem on my H97 after a few days of hard digging. :)
lmintfernvale
Level 1
Level 1
 
Posts: 1
Joined: Mon Nov 10, 2014 10:18 am


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: Google Adsense [Bot] and 9 guests