Stuttering/crackling almost all the time <SOLVED>

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Stuttering/crackling almost all the time <SOLVED>

Postby phoenixairs on Mon Jul 14, 2014 1:11 pm

Hello,

I'm running Linux Mint 17 / Cinnamon on a self-built machine. My audio stutters and crackles for everything: computer startup sound, Youtube, Pandora, VLC playing mp3... I've noticed that it sometimes gets worse when my CPU usage goes up, but it's also pretty bad when nothing intensive is running.

One interesting thing is when playing a game in the foreground and streaming music in the background, the music streaming in the background sounds fine, while the game music is choppy and of lesser quality.

I've tried this: viewtopic.php?f=48&t=145419&p=780169&hilit=stutter#p780169 with no luck.

Can someone help me figure out what's going on? Thanks! My hardware is listed underneath. The NVIDIA audio device uses the same kernel driver (snd_hda_intel) as the other one. I don't know if that's relevant.

Code: Select all
lspci -v
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
   Subsystem: ASUSTeK Computer Inc. Device 8534
   Flags: bus master, fast devsel, latency 0
   Capabilities: <access denied>

00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
   I/O behind bridge: 0000e000-0000efff
   Memory behind bridge: f6000000-f70fffff
   Prefetchable memory behind bridge: 00000000e0000000-00000000f1ffffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport

00:14.0 USB controller: Intel Corporation 9 Series Chipset Family USB xHCI Controller (prog-if 30 [XHCI])
   Subsystem: ASUSTeK Computer Inc. Device 8534
   Flags: bus master, medium devsel, latency 0, IRQ 41
   Memory at f7220000 (64-bit, non-prefetchable) [size=64K]
   Capabilities: <access denied>
   Kernel driver in use: xhci_hcd

00:16.0 Communication controller: Intel Corporation 9 Series Chipset Family ME Interface #1
   Subsystem: ASUSTeK Computer Inc. Device 8534
   Flags: bus master, fast devsel, latency 0, IRQ 44
   Memory at f723a000 (64-bit, non-prefetchable) [size=16]
   Capabilities: <access denied>
   Kernel driver in use: mei_me

00:19.0 Ethernet controller: Intel Corporation Ethernet Connection (2) I218-V
   Subsystem: ASUSTeK Computer Inc. Device 85c4
   Flags: bus master, fast devsel, latency 0, IRQ 43
   Memory at f7200000 (32-bit, non-prefetchable) [size=128K]
   Memory at f7238000 (32-bit, non-prefetchable) [size=4K]
   I/O ports at f040 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: e1000e

00:1a.0 USB controller: Intel Corporation 9 Series Chipset Family USB EHCI Controller #2 (prog-if 20 [EHCI])
   Subsystem: ASUSTeK Computer Inc. Device 8534
   Flags: bus master, medium devsel, latency 0, IRQ 16
   Memory at f7237000 (32-bit, non-prefetchable) [size=1K]
   Capabilities: <access denied>
   Kernel driver in use: ehci-pci

00:1b.0 Audio device: Intel Corporation 9 Series Chipset Family HD Audio Controller
   Subsystem: ASUSTeK Computer Inc. Device 8630
   Flags: bus master, fast devsel, latency 0, IRQ 45
   Memory at f7230000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: snd_hda_intel

00:1c.0 PCI bridge: Intel Corporation 9 Series Chipset Family PCI Express Root Port 1 (rev d0) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
   Capabilities: <access denied>
   Kernel driver in use: pcieport

00:1c.3 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d0) (prog-if 01 [Subtractive decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=03, subordinate=04, sec-latency=0
   Capabilities: <access denied>

00:1c.4 PCI bridge: Intel Corporation 9 Series Chipset Family PCI Express Root Port 5 (rev d0) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=05, subordinate=05, sec-latency=0
   I/O behind bridge: 0000d000-0000dfff
   Memory behind bridge: f7100000-f71fffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport

00:1d.0 USB controller: Intel Corporation 9 Series Chipset Family USB EHCI Controller #1 (prog-if 20 [EHCI])
   Subsystem: ASUSTeK Computer Inc. Device 8534
   Flags: bus master, medium devsel, latency 0, IRQ 23
   Memory at f7236000 (32-bit, non-prefetchable) [size=1K]
   Capabilities: <access denied>
   Kernel driver in use: ehci-pci

00:1f.0 ISA bridge: Intel Corporation 9 Series Chipset Family Z97 LPC Controller
   Subsystem: ASUSTeK Computer Inc. Device 8534
   Flags: bus master, medium devsel, latency 0
   Capabilities: <access denied>

00:1f.2 SATA controller: Intel Corporation 9 Series Chipset Family SATA Controller [AHCI Mode] (prog-if 01 [AHCI 1.0])
   Subsystem: ASUSTeK Computer Inc. Device 8534
   Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 42
   I/O ports at f090 [size=8]
   I/O ports at f080 [size=4]
   I/O ports at f070 [size=8]
   I/O ports at f060 [size=4]
   I/O ports at f020 [size=32]
   Memory at f7235000 (32-bit, non-prefetchable) [size=2K]
   Capabilities: <access denied>
   Kernel driver in use: ahci

00:1f.3 SMBus: Intel Corporation 9 Series Chipset Family SMBus Controller
   Subsystem: ASUSTeK Computer Inc. Device 8534
   Flags: medium devsel, IRQ 11
   Memory at f7234000 (64-bit, non-prefetchable) [size=256]
   I/O ports at f000 [size=32]

01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device 84bb
   Flags: bus master, fast devsel, latency 0, IRQ 46
   Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
   Memory at e0000000 (64-bit, prefetchable) [size=256M]
   Memory at f0000000 (64-bit, prefetchable) [size=32M]
   I/O ports at e000 [size=128]
   [virtual] Expansion ROM at f7000000 [disabled] [size=512K]
   Capabilities: <access denied>
   Kernel driver in use: nvidia

01:00.1 Audio device: NVIDIA Corporation Device 0fbc (rev a1)
   Subsystem: ASUSTeK Computer Inc. Device 84bb
   Flags: bus master, fast devsel, latency 0, IRQ 17
   Memory at f7080000 (32-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: snd_hda_intel

03:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 04) (prog-if 01 [Subtractive decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=03, secondary=04, subordinate=04, sec-latency=32
   Capabilities: <access denied>

05:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter (rev 01)
   Subsystem: ASUSTeK Computer Inc. Device 85e3
   Flags: bus master, fast devsel, latency 0, IRQ 16
   I/O ports at d000 [size=256]
   Memory at f7100000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: rtl8192ce
Last edited by phoenixairs on Thu Jul 17, 2014 8:57 pm, edited 1 time in total.
phoenixairs
Level 1
Level 1
 
Posts: 2
Joined: Mon Jul 14, 2014 10:56 am

Linux Mint is funded by ads and donations.
 

Re: Stuttering/crackling almost all the time

Postby xenopeek on Mon Jul 14, 2014 3:33 pm

At least the crackling sounds like poorly isolated connectors to me. When I attach headphones or speakers on the front audio port of my computer, I crackles all the time--and gets worse with heavy computer tasks or when I move the mouse. So electrical noise of other components of the computer leaks through to the audio port and causes crackling audio. Switching to connecting everything to the rear audio port fixed it for me. Do you have option to test something like that?
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14823
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Stuttering/crackling almost all the time

Postby DrHu on Mon Jul 14, 2014 3:50 pm

People are always suggesting not using Pulseaudio..
http://community.linuxmint.com/hardware/view/394
http://wiki.xbmc.org/index.php?title=In ... r_HD_Audio

Pulseaudio for device ..
http://unix.stackexchange.com/questions ... pulseaudio
https://wiki.archlinux.org/index.php/PulseAudio
https://wiki.archlinux.org/index.php/Pu ... ound_setup
    Last link above ref: choppy sound
    --arch Linux, usually good advice testing methodolgies..

I also will initailly suspect connection (continuity/good electrical connection(s)); and additionally would suspect audio levels --when too high crackling may result..
--also the actual settings for the various parts (audio modules or components available within the device via the software control program (Pulseaudio or other)).
User avatar
DrHu
Level 16
Level 16
 
Posts: 6792
Joined: Wed Jun 17, 2009 8:20 pm

Re: Stuttering/crackling almost all the time

Postby phoenixairs on Mon Jul 14, 2014 4:00 pm

Connecting my headphones to the rear port also has the same sounds. I could try moving the wires inside around; what components should I pay particular attention to? Are there insulation solutions I can find?

Given that it seems somehow related to hardware activity, I'll let Pulseaudio sit for now...

EDIT: Fixed using viewtopic.php?f=48&t=172747 ! :) might be of note for Z97, snd_hda_intel?
phoenixairs
Level 1
Level 1
 
Posts: 2
Joined: Mon Jul 14, 2014 10:56 am


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 6 guests