Video playback

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

Video playback

Postby vize84 on Thu Mar 22, 2007 1:13 pm

I've just installed Linux Mint 2.2 and everything is fine and works very well but I have a problem when playing DivX.

My pc a Sony VAIO laptop (Pentium M 1.73 GHz, 1 GB RAM, GeForce 6400)

DivX and DVD playback isn't smooth... I discovered, using VLC, that I loose about 3 frames per second or more... I also installed the latest NVIDIA drivers (97.55) but the nothing changed an the problem is still there...
Since my laptop never had problems playing videos in windows xp (I can play HD video 1920x1080 smoothly with the PureVideo feature of my GeForce) I think the problem could be in the codecs (perhaps some video playback acceleration is disabled or something similar) can anyone help me? Thanks
vize84
Level 1
Level 1
 
Posts: 3
Joined: Thu Mar 22, 2007 12:51 pm

Linux Mint is funded by ads and donations.
 

Video playback

Postby nick on Thu Mar 22, 2007 2:13 pm

Hi
Have you enabled DMA on your DVD?

Assuming you are playing from DVD, also is dma on, on harddisc

How to speed up CD/DVD-ROM

e.g. Assumed that /dev/cdrom is the location of CD/DVD-ROM

sudo hdparm -d1 /dev/cdrom
sudo cp /etc/hdparm.conf /etc/hdparm.conf_backup
gksudo gedit /etc/hdparm.conf

* Append the following lines at the end of file

/dev/cdrom {
dma = on
}

* Save the edited file
http://ubuntuguide.org/wiki/Ubuntu_Edgy ... .2FDVD-ROM

Also have you tried Mplayer, does it drop frames?
Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby vize84 on Thu Mar 22, 2007 2:54 pm

Hi, thanks for the advice but DMA was already enabled in hda and in cdrom :(
I was wondering if there's a way to configure codecs or to install new codec that could work better :roll: I read about ffmpeg but I don't know if this codec is already included in Linux Mint... any ideas to solve my playblack issue in dvd and divx :?:
vize84
Level 1
Level 1
 
Posts: 3
Joined: Thu Mar 22, 2007 12:51 pm

Video playback

Postby nick on Thu Mar 22, 2007 3:55 pm

Hi
I do have ffmpeg installed, but I always install it.
I had your trouble with Etch, (dropped
frames) and found I had the refresh
rate on monitor set wrongly.
Have you tried any other media
players, Mplayer, Xine ?
I have used
most types of Linux distros and found
some players work better than others
on all distros, depending on distro.

In case you ask :) ( have answered this
question "many" times :) ), to configure
Mplayer, right click on screen, preferences,
video x11, audio alsa,
You might have to do the same again,
if you attempt to watch streaming video
in it

Worth trying to change video settings
to other than x11 if you are having
problems
Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby vize84 on Thu Mar 22, 2007 4:11 pm

Well, I've just installed gxine and is the player that works better... video is quite smooth, perhaps some frame are dropped too, but it feels like they're fewer...
If I use mplayer, unfortunately, I have the worst playback (X11 & alsa).
I also installed divx 6.1.1 codec but I have NO IDEA to see if some player uses it and I don't know how to configure it... the only player that show me the decoder used is gxine (and for divx/xvid files is always ffmpeg)...
vize84
Level 1
Level 1
 
Posts: 3
Joined: Thu Mar 22, 2007 12:51 pm

Video playback

Postby nick on Thu Mar 22, 2007 4:39 pm

Hi
Well thats as far as I can help you, we have had long discussions on this on our Local Linux user group, where everybody knows more than me (not difficult) and nobody seems to come up with a definitive answer.

BTW I use Totem. I rememeber that I installed
ffmpeg because one site I watch in Mplayer does not work without it.

Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 6 guests