CD playback with Sound Juicer is choppy

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

CD playback with Sound Juicer is choppy

Postby tinny on Mon Apr 02, 2007 5:12 pm

I am experiencing intermittent breaks in sound, 1-second dropouts every 5 seconds, when playing commercial CDs with Sound Juicer. I have installed XMMS Player (Debian), but I dont know how to force it to play a CD.

Usually, I can get a CD to play with XMMS if I select Play Location and enter /mnt/cdrom, but this is not doing anything in Mint 2.2

Why am I getting these dropouts with Sound Juicer?

Please advise me how to force a CD to play with XMMS Player (Debian).
User avatar
tinny
Level 3
Level 3
 
Posts: 100
Joined: Thu Feb 22, 2007 2:35 pm
Location: USA

Linux Mint is funded by ads and donations.
 

CD playback with Sound Juicer is choppy

Postby nick on Tue Apr 03, 2007 4:16 am

Hi
Not sure about dropouts, have you installed XMMS-Cdread,(input plugin for XMMS that reads audio data from CDs
XMMS Input plugin which will read an audio CD as data and play it in
realtime.

This plugin works on many CD drives where the default CD plugin
shipped with XMMS may fail.)
To configure XMMS right click on on top letter on
LHS of panel , bit hard to see, Options/Preferences

Kaffeine does a good job as well
They are in Synaptic
Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby tinny on Tue Apr 03, 2007 6:23 pm

Kaffeine does the same thing, an audio dropout every 7 seconds. :(
User avatar
tinny
Level 3
Level 3
 
Posts: 100
Joined: Thu Feb 22, 2007 2:35 pm
Location: USA

CD playback with Sound Juicer is choppy

Postby nick on Wed Apr 04, 2007 4:18 am

Hi
Could you post the specifications of your computer, and spec of cdrom?
Does this happen in windows or other Linux, depending on what you have used?
Does this happen with home burnt cd's or bought ones?
Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby tinny on Wed Apr 04, 2007 11:02 am

Here are the specs for this computer:

ASUS A7A266 motherboard
Athlon 1400 processor
30 GB WD hdd
512 MB pc133 ram (2 DDR slots available)
nVidia GeForce2 MX-400
Toshiba DVD-ROM SDM1212
Yamaha YMF-724F snd card
ALi MAGiK 1 M1647 chipset

I get better playback by changing the Format in SJ's Preferences:

Sound Juicer: Edit > Preferences > Format

Current Format setting is "Voice, Lossy (Ogg multimedia)"

But I still get choppiness, especially in the first 20 seconds of a song. When I have a graphical representation of sound, the visual image freezes when there is silence (dropout).
User avatar
tinny
Level 3
Level 3
 
Posts: 100
Joined: Thu Feb 22, 2007 2:35 pm
Location: USA

CD playback with Sound Juicer is choppy

Postby nick on Wed Apr 04, 2007 12:48 pm

Hi
Not too sure.
You could try:

Fix jumpy/skipping/choppy/stuttering CD/DVD playback:

http://www.cs.cornell.edu/~djm/ubuntu/#fix-dma

Is audio ok with mp3's and other sounds?

It may sound silly, but you do have a swap partion?

Also some thing obvious, such as use
head cleaner.

Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby tinny on Wed Apr 04, 2007 1:39 pm

I installed VLC and it plays CDs flawlessly. VLC also plays DVDs passably, with some sync error, which is almost unnoticeable. MPlayer does a good job playing DVDs. Totem, on the other hand, had major sync problems playing DVDs, and the buggy xine engine will probably not be upgraded to xinelib 1.1.4 until Feisty Fawn comes out.

So: not Sound Juicer, not Kaffeine, not Totem, not but, yes, VLC is the solution to this problem. I am very impressed with VLC.

Still trying to get XMMS to play a CD....

Code: Select all
$ sudo hdparm -d /dev/cdrom

/dev/cdrom:
 using_dma    =  1 (on)


To get Sound Juicer to play CDs, maybe I should turn DMA off. What do you think?

Code: Select all
$ free
             total       used       free     shared    buffers     cached
Mem:        515860     305264     210596          0       8820     113148
-/+ buffers/cache:     183296     332564
Swap:      1220900      16956    1203944
$ df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda1              27G  2.7G   23G  11% /
varrun                252M   96K  252M   1% /var/run
varlock               252M     0  252M   0% /var/lock
procbususb             10M   88K   10M   1% /proc/bus/usb
udev                   10M   88K   10M   1% /dev
devshm                252M     0  252M   0% /dev/shm
lrm                   252M   18M  235M   7% /lib/modules/2.6.17-11-generic/volatile
User avatar
tinny
Level 3
Level 3
 
Posts: 100
Joined: Thu Feb 22, 2007 2:35 pm
Location: USA

Postby tinny on Wed Apr 04, 2007 2:37 pm

If I am gonna be limited to using VLC, maybe I should be asking how to set VLC to the default CD player. Cuz right now, Sound Juicer comes up by default, and SJ doesnt work. I still cant get XMMS (Debian) to play a CD.

How do I set VLC to be the default CD player?
User avatar
tinny
Level 3
Level 3
 
Posts: 100
Joined: Thu Feb 22, 2007 2:35 pm
Location: USA

CD playback with Sound Juicer is choppy

Postby nick on Wed Apr 04, 2007 2:39 pm

Hi
In every variation of Linux distro/motherboard/soundcard I have tried, one
media player always seems to work better than any other.

For my set up Kaffiene seems the best, but VLC seems to work best for you, so
if you are happy with it stay with it.

Unless you specifically want Soundjuicer for playing CD's, stick with VLC

I see you have swap.

If you need to rip you can always use
Grip, Kaudiocreator, or K3B will rip.
Don't forget to install lame

If VLC works fine I would leave dma on.
you might have trouble with DVD's without

Just tried Xmms on my setup, no it does not seem to play CD's, but it may need
audio cable from CD/DVD, some read data cable, some read audio.

Glad you are getting something to play CD's
Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby tinny on Wed Apr 04, 2007 3:04 pm

I just got XMMS to make a sound. If I could find the actual location of the CD in the file system, I am certain I could play it, reaching XMMS with the selection of "Open with other application"...

but I cant find the cd, or cdrom, in the file system!

BTW, you can set XMMS to play Digital Audio Extraction if you have no analog cable.
User avatar
tinny
Level 3
Level 3
 
Posts: 100
Joined: Thu Feb 22, 2007 2:35 pm
Location: USA

CD playback with Sound Juicer is choppy

Postby nick on Wed Apr 04, 2007 4:52 pm

Hi
Bit of a rush!
Xmms - CD
Try http://facilities.cs.utexas.edu/htdoc/f ... media.html
And to set default VLC to open CD- I am afraid I have used KDE for 10 years, not gnome :)
But try
Re: How to set XMMS as default music/cd player?
http://ubuntuforums.org/showthread.php?t=368533
Should work for VLC????
Nick
nick
Level 5
Level 5
 
Posts: 686
Joined: Sat Dec 02, 2006 8:04 am

Postby tinny on Thu Apr 05, 2007 5:09 pm

I changed out the DVDrom drive from that sorry Toshiba SDM1212 to a LiteON JLMS XJ-HD166S. The reviews I read dont have much good to say about the LiteON, but it's playing CDs with Sound Juicer, and anything else I throw at it. So now I have the defaults set to play CD with Sound Juicer, and DVD with VLC.

I erased the original default setting in System>Preferences>Removable Drives and Media for CD playback. The locations of apps read something like:

Sound Juicer %M

Totem %D

Can someone check their original default settings to confirm this. Is there a simple location to "Browse" to find all the multimedia apps?
User avatar
tinny
Level 3
Level 3
 
Posts: 100
Joined: Thu Feb 22, 2007 2:35 pm
Location: USA

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: ridingdirty and 3 guests