Sound stuttering badly

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Sound stuttering badly

Postby Old Marcus on Wed Feb 18, 2009 10:35 am

Hi, on this Toshiba Satellite Pro A100 laptop, I've installed Linux Mint Felicia in a dual boot alongside XP home, and everything, including wifi, works great. Except sound. Every 2 0r 3 logins, the sound stutters horribly and doesn't stop, even when I mute the system sound, so I have to turn off the laptop sound to be kind to my ears.

I've tried playing around with the sound settings, but so far, nothing is making a difference. Any help or knowledge on this matter? It's not crucial, but it would be nice to listen to music etc. Without having to boot into windows.
Linux Mint 8 RC1 = Nice
'apt install' can be used on Linux Mint as a shortcut for 'sudo apt-get install'. 'apt x' can be used for various other apt commands as well.
When a problem is solved, please add [SOLVED] to your thread title.
User avatar
Old Marcus
Level 4
Level 4
 
Posts: 395
Joined: Sun Jun 08, 2008 4:51 pm
Location: Exeter, UK

Linux Mint is funded by ads and donations.
 

Re: Sound stuttering badly

Postby Husse on Thu Feb 19, 2009 7:54 am

Post the result of lspci
We need to know a bit about your hardware
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Sound stuttering badly

Postby Old Marcus on Thu Feb 19, 2009 4:30 pm

Here you go:

Code: Select all
00:00.0 Host bridge: ATI Technologies Inc Device 5a31 (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:12.0 IDE interface: ATI Technologies Inc IXP SB400 Serial ATA Controller (rev 80)
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 82)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller (rev 80)
00:14.2 Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200M]
02:04.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
02:06.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
02:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:0a.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link)
Linux Mint 8 RC1 = Nice
'apt install' can be used on Linux Mint as a shortcut for 'sudo apt-get install'. 'apt x' can be used for various other apt commands as well.
When a problem is solved, please add [SOLVED] to your thread title.
User avatar
Old Marcus
Level 4
Level 4
 
Posts: 395
Joined: Sun Jun 08, 2008 4:51 pm
Location: Exeter, UK

Re: Sound stuttering badly

Postby Husse on Fri Feb 20, 2009 8:25 am

You might not believe it but your
IXP SB4x0 High Definition Audio
is really an Intel HDA
A quick search confirmed my suspicions - the general solution for HDA8 will probably work
http://www.linuxmint.com/forum/viewtopi ... sa#p107982
Of course you use model=toshiba
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Sound stuttering badly

Postby Old Marcus on Fri Feb 20, 2009 1:31 pm

I added that line, but now there is now sound at all. Looking in the ubuntu forums, but haven't found a suitable solution yet.
Linux Mint 8 RC1 = Nice
'apt install' can be used on Linux Mint as a shortcut for 'sudo apt-get install'. 'apt x' can be used for various other apt commands as well.
When a problem is solved, please add [SOLVED] to your thread title.
User avatar
Old Marcus
Level 4
Level 4
 
Posts: 395
Joined: Sun Jun 08, 2008 4:51 pm
Location: Exeter, UK

Re: Sound stuttering badly

Postby Husse on Fri Feb 20, 2009 7:22 pm

That's bad and surprising
Test with another index number - index=1 and so on - possibly 2 is the most probable
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Sound stuttering badly

Postby Old Marcus on Mon Apr 13, 2009 9:15 am

Having looked for various solutions, apart from this, nothing to be found. It seems to work for a while then 'echoes', making sound unusable. The solutions in the Intel ICH thread only seem to succeed in disabling sound completely. Any more ideas would be helpful, thanks. :)
Linux Mint 8 RC1 = Nice
'apt install' can be used on Linux Mint as a shortcut for 'sudo apt-get install'. 'apt x' can be used for various other apt commands as well.
When a problem is solved, please add [SOLVED] to your thread title.
User avatar
Old Marcus
Level 4
Level 4
 
Posts: 395
Joined: Sun Jun 08, 2008 4:51 pm
Location: Exeter, UK

Re: Sound stuttering badly

Postby Husse on Mon Apr 13, 2009 3:42 pm

Hmm - I don't have any ideas, will add you to my list
We can't have every possible hardware, which makes it hard to test out a solution
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Sound stuttering badly

Postby Old Marcus on Mon Apr 13, 2009 4:08 pm

Hi. The Intel ICH solution appears to have worked, I just kept the model set to auto, rather than toshiba. I tried using model=toshiba but then sound just vanished. Now on auto, and no echoing so far. If I never post in this topic again it has remained working. Thanks for your help Husse. :)
Linux Mint 8 RC1 = Nice
'apt install' can be used on Linux Mint as a shortcut for 'sudo apt-get install'. 'apt x' can be used for various other apt commands as well.
When a problem is solved, please add [SOLVED] to your thread title.
User avatar
Old Marcus
Level 4
Level 4
 
Posts: 395
Joined: Sun Jun 08, 2008 4:51 pm
Location: Exeter, UK

Re: Sound stuttering badly

Postby Old Marcus on Tue Apr 14, 2009 7:29 am

With each bubble of hope an anvil comes and crushes it... :(

Still echoing, looks like an unsolvable incompatibility between ALSA and this laptop. Maybe 2.6.28/9 will have answers?
Linux Mint 8 RC1 = Nice
'apt install' can be used on Linux Mint as a shortcut for 'sudo apt-get install'. 'apt x' can be used for various other apt commands as well.
When a problem is solved, please add [SOLVED] to your thread title.
User avatar
Old Marcus
Level 4
Level 4
 
Posts: 395
Joined: Sun Jun 08, 2008 4:51 pm
Location: Exeter, UK

Re: Sound stuttering badly

Postby gool7890 on Wed Apr 15, 2009 11:26 pm

thanks http://goonlinetv.com
gool7890
Level 1
Level 1
 
Posts: 1
Joined: Wed Apr 15, 2009 11:24 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 6 guests