Firefox not working correctly with flash in fullscreen

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Firefox not working correctly with flash in fullscreen

Postby hanl on Mon Jun 01, 2009 12:55 pm

Hi.

I'm a newcomer to Mint, everything works well except for flash when in full screen in firefox.
Previously used Ubuntu 8.10 and everything worked okay with firefox and flash.

The problem is that when it goes into fullscreen, the video stops every few seconds and the sound stops working too, I think it's because it's using up too much memory as I can't even exit out of fullscreen for about 2 seconds when the video starts playing again and the sound comes back.

It works great in Opera, but just not in Firefox for some odd reason.
Playing videos works fine too in all players (Totem, VLC, SMPlayer, and so on).

I've uninstalled it, and removed both Firefox and then deleted it from from /home/user/.mozilla as well as removing the flash plugin and deleting all of /usr/lib/firefox-3.0.10 including the directory for the plugin, and /usr/lib/firefox-addons and then installing everything again.

I've tried installing flash from the adobe site too and it still doesn't work properly.

Not really sure if it's a problem with firefox or flash.

Running Linux Mint 7 (32bit) on an Acer Aspire 7730 with 4gb ram and Intel Duo Processor T5800 2.0 GHz.
It's Firefox 3 and Adobe Flash 10.

Output of lspci:

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
06:00.0 System peripheral: JMicron Technologies, Inc. SD/MMC Host Controller
06:00.2 SD Host controller: JMicron Technologies, Inc. Standard SD Host Controller
06:00.3 System peripheral: JMicron Technologies, Inc. MS Host Controller
06:00.4 System peripheral: JMicron Technologies, Inc. xD Host Controller
07:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5764M Gigabit Ethernet PCIe (rev 10)


Output of lshw (put on pastebin as it's quite large):
http://pastebin.com/f6d498654


Any help on this would be very much appreciated.
If you need me to give any other info just let me know.

Thanks!
hanl
Level 1
Level 1
 
Posts: 2
Joined: Mon Jun 01, 2009 12:33 pm

Linux Mint is funded by ads and donations.
 

Re: Firefox not working correctly with flash in fullscreen

Postby exploder on Mon Jun 01, 2009 3:06 pm

You are suffering from the Intel issue. I used the safe method found here to fix the very same problem on my system.

http://ubuntuforums.org/showthread.php?t=1130582
exploder
Level 15
Level 15
 
Posts: 5872
Joined: Tue Feb 13, 2007 10:50 am
Location: HartfordCity, Indiana USA

Re: Firefox not working correctly with flash in fullscreen

Postby hanl on Mon Jun 01, 2009 5:24 pm

Worked perfectly.
I'm so happy.

Thank you so much!
Mint is fantastic. Since everything else was working perfectly, that made that one thing annoy the hell out of me.

Thanks again! :D
hanl
Level 1
Level 1
 
Posts: 2
Joined: Mon Jun 01, 2009 12:33 pm


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 5 guests