Wow... No Sound All Of A Sudden!

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Wow... No Sound All Of A Sudden!

Postby Ronny49 on Tue Jul 21, 2009 4:54 pm

What the heck??

I was watching the Simpsons on Hulu.com and wasn't even touching my laptop
and BAM! No sound!

I went through all of the volumes to make sure nothing muted and all is ON.

What the heck would do that?? It crackled a bit and it was gone.

And another weird thing is the clock keeps changing times on me. I have to keep
resetting it.

Linux STILL is simply NOT ready for prime time.

Man... enough is enough!!

:roll:
Ronny49
 

Linux Mint is funded by ads and donations.
 

Re: Wow... No Sound All Of A Sudden!

Postby lagagnon on Tue Jul 21, 2009 6:30 pm

OK then goodbye. On the other hand, rather than an unproductive rant perhaps you could supply us with some information so we could help you with your problems. But if you don't want help then don't bother posting to the forums....

Here is what we need to see to help you with your sound problem (these commands run in a terminal):

inxi -a
aplay -l

As for your clock problem:

date (does the time zone correspond with your actual time zone).

IMHO, the fact that sound was working perfectly, then crackled and was gone suggests a hardware fault -rather than anything to do with Linux. The clock thing could be hardware also, but more likely you have not set your time zone up properly when you installed Mint.
User avatar
lagagnon
Level 7
Level 7
 
Posts: 1888
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: Wow... No Sound All Of A Sudden!

Postby Ronny49 on Tue Jul 21, 2009 10:18 pm

My laptop is 2 months new and when I reboot into Vista, sound works perfectly.
So NO hardware issues. and YES, I did set my time zone and time THREE
different times and I gave up. My rule of thumb is strike three, time to move on.

Thing is, I have a friend who has never used Linux before and I am suppose to
be going over to their house tomorrow to install a distro. I chose XFCE MINT
because it is basically SO easy to use! But I cannot bare to have them calling
me all the time to come over and fix it due to all the problems.

On another note, I downloaded Mandriva 2009 64 bit and tried installing it on my
laptop three separate times with three new DL's and it failed to boot every time!
I thought that one would have been a great choice for me and them. But if it
won't even boot... what can I do?

Personally, I am not a techie guru, nor do I care to be one. I just want to be able
to install, set it up the way I like it and then get the work done I need to get done!
Too much to do without having to play around with all this bug stuff.

But I will give it one more shot... Here is the data you requested: First run ERROR.

mint@mint ~ $ inxi -a
/usr/bin/inxi: illegal option -- a
Error 7: One of the options you entered in your script parameters: -a
Is not supported. For supported options, check the help menu: inxi -h
mint@mint ~ $
-----------------------------------------------------------------------------------------------------
mint@mint ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC268 Digital [ALC268 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
mint@mint ~ $

EDIT: I should let you know though, that I reinstalled and sound is once again working.
Ronny49
 

Re: Wow... No Sound All Of A Sudden!

Postby DrHu on Tue Jul 21, 2009 10:59 pm

Ronny49 wrote:EDIT: I should let you know though, that I reinstalled and sound is once again working.

A standard windows-like solution, well at least the installation will be quicker with Linux mint..

That command was supposed to be
    inxi -A
    Audio: Card Creative Labs SB Audigy driver EMU10K1_Audigy
    Sound: Advanced Linux Sound Architecture Version 1.0.18rc3
    inxi
    --by itself will give you a short hardware list of your machine
    inxi -F
    --will give you a Fuller hardware list for your machine
    inxi -h
    --will give you a help list, how to use the command
    http://techpatterns.com/forums/about1133.html
    search the Internet for inxi linux
Any of those methods would have gotten you a more complete answer, display
Last edited by DrHu on Tue Jul 21, 2009 11:10 pm, edited 2 times in total.
User avatar
DrHu
Level 16
Level 16
 
Posts: 6710
Joined: Wed Jun 17, 2009 8:20 pm

Re: Wow... No Sound All Of A Sudden!

Postby Ronny49 on Tue Jul 21, 2009 11:03 pm

I simply copied and pasted to the terminal.

Here is the new entry:

mint@mint ~ $ inxi -A
Audio: Card Intel 82801I (ICH9 Family) HD Audio Controller driver HDA Intel
Sound: Advanced Linux Sound Architecture Version 1.0.18rc3
mint@mint ~ $
Ronny49
 

Re: Wow... No Sound All Of A Sudden!

Postby DrHu on Tue Jul 21, 2009 11:15 pm

Ronny49 wrote:Here is the new entry:
mint@mint ~ $ inxi -A
Audio: Card Intel 82801I (ICH9 Family) HD Audio Controller driver HDA Intel
Sound: Advanced Linux Sound Architecture Version 1.0.18rc3
mint@mint ~ $

Well, since it works after your reinstall, it is only for your own curiosity or interest to check the driver issues HDA Intel linux, or a specific distribution, same query..
viewtopic.php?f=49&t=28789

Apparently this is the standard method..
viewtopic.php?f=49&t=23139
User avatar
DrHu
Level 16
Level 16
 
Posts: 6710
Joined: Wed Jun 17, 2009 8:20 pm

Re: Wow... No Sound All Of A Sudden!

Postby Ronny49 on Wed Jul 22, 2009 11:59 pm

DrHu wrote:
Ronny49 wrote:Here is the new entry:
mint@mint ~ $ inxi -A
Audio: Card Intel 82801I (ICH9 Family) HD Audio Controller driver HDA Intel
Sound: Advanced Linux Sound Architecture Version 1.0.18rc3
mint@mint ~ $

Well, since it works after your reinstall, it is only for your own curiosity or interest to check the driver issues HDA Intel linux, or a specific distribution, same query..
viewtopic.php?f=49&t=28789

Apparently this is the standard method..
viewtopic.php?f=49&t=23139



Thanks! But I really hope that the MINT guys see this and fix it so it will simply work in the final release!

I will say that after I did a re-install, it did do it again and then a little bit later the sound returned. So, now I know it is a coding problem.
Ronny49
 

Re: Wow... No Sound All Of A Sudden!

Postby Atlantic-Aurora on Sat Jul 25, 2009 1:55 pm

Hi, I am new to Linux Mint, having installed the Gloria main edition yesterday.
I have had the same problem. My sound while logged in suddenly disappeared. When I rebooted, the login screen ready sound, and the login successful sound played, but after that silence. I can't get it back by fiddling with the mixer controls.
I followed the instructions given here: http://forums.linuxmint.com/viewtopic.php?f=49&t=23139 but it made no difference.

Here is the output of inxi -A
Audio: Card Intel 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller driver Intel ICH
Sound: Advanced Linux Sound Architecture Version 1.0.18rc3

And here is the output of aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ICH5 [Intel ICH5], device 0: Intel ICH [Intel ICH5]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ICH5 [Intel ICH5], device 4: Intel ICH - IEC958 [Intel ICH5 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0

I hope someone can help, as I am loathe to reinstall, having customised LM a bit already.
Thanks in advance.
Atlantic-Aurora
Level 1
Level 1
 
Posts: 8
Joined: Sat Jul 25, 2009 1:37 pm

Re: Wow... No Sound All Of A Sudden!

Postby Atlantic-Aurora on Sat Jul 25, 2009 4:46 pm

I have removed the entries put in /etc/modprobe.d/alsa-base.conf
and in /etc/rc.local
I can get OSS to work for music file playback but there is no sound on flash-video.
This is very frustrating. I wonder why Ubuntu and its derivatives have to complicate the sound architecture with OSS, Alsa and Pulse. Does anyone understand how they all sync together? I certainly don't. Why not just use alsa and get that working perfectly? Chuck the rest out.

Anyway, I was wondering if the entry in /etc/modprobe.d/alsa-base.conf should reference the fact that I am working on the slave hard drive, hdb.
viewtopic.php?f=49&t=23139 suggests that:-

"............this should work for ICH7 to at least ICH10
Edit the "/etc/modprobe.d/alsa-base" file
Note in Gloria and later the file is /etc/modprobe.d/alsa-base.conf
add at the very end:
options snd-hda-intel index=0 model=auto"


Adding that line did not work, because, presumably, my sound card is ICH5. I was wondering if I should write something like:
options snd-hdb-intel index=0 model=auto
or does the 'hda' in the second section of the options line not refer to the hard-drive but to something else?
I feel that line is crucial, but I don't know how it should read. Any ideas, anyone?

With every installation of Linux, bar one, (PCLinuxOS), that I have made on each of the 3 CPUs I've owned, I have had trouble after the initial install getting sounds working properly.
Windows on hda plays sounds perfectly, folks, and always has since I started with Windows 95. I say this in sorrow, not in anger, to make the point that Windows users who drop in on these forums must marvel that in 2009 there are many of us still struggling in Linux to get dependable sounds.
Atlantic-Aurora
Level 1
Level 1
 
Posts: 8
Joined: Sat Jul 25, 2009 1:37 pm

Re: Wow... No Sound All Of A Sudden!

Postby Atlantic-Aurora on Sat Jul 25, 2009 5:23 pm

I think I have found the source of the problem.
I remembered that I had used the control centre to give a pleasing sound on login ready and another on login success, although I didn't notice straight away that the sounds were not available. I disabled those and hey presto, when I rebooted the sounds were back. So those login time sounds must somehow disable the alsa sound server and it is not available afterwards.
It was not a question in my case of editing: /etc/modprobe.d/alsa-base.conf
I would like to have the login ready/successful/failed sounds enabled however. It is much more agreeable than a system beep. How can I do this without disabling the alsa sound-server? Why should those sounds be turning the alsa module off?
Atlantic-Aurora
Level 1
Level 1
 
Posts: 8
Joined: Sat Jul 25, 2009 1:37 pm

Re: Wow... No Sound All Of A Sudden!

Postby lagagnon on Sat Jul 25, 2009 8:31 pm

Were they anything other than a .wav file?
User avatar
lagagnon
Level 7
Level 7
 
Posts: 1888
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: Wow... No Sound All Of A Sudden!

Postby Atlantic-Aurora on Sun Jul 26, 2009 5:45 am

Yes they were all .wav files.
Now here is a strange thing. If I just enable one sound for the login window, the sound for login window ready, and disable the sound for login successful, the system proceeds normally to the desktop environment, sounds are not disabled, and you get the nice welcoming tinkling sound as the desktop appears, and thereafter music can be played.
If I enable a login successful sound as well, then the sound system is disabled, you get no welcoming tinkling sound and no music can be played.
Why should this be?
I will do some more tests.
I will code: lsmod | grep snd
to see what sound modules are loaded in the two scenarios, and compare the results.
Atlantic-Aurora
Level 1
Level 1
 
Posts: 8
Joined: Sat Jul 25, 2009 1:37 pm

Re: Wow... No Sound All Of A Sudden!

Postby Atlantic-Aurora on Sun Jul 26, 2009 7:17 am

Coding: lsmod | grep snd
returned exactly the same result in the two scenarios.
viz:
snd_intel8x0 37532 3
snd_ac97_codec 112292 1 snd_intel8x0
ac97_bus 9856 1 snd_ac97_codec
snd_pcm_oss 46336 0
snd_mixer_oss 22656 1 snd_pcm_oss
snd_pcm 82948 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy 10756 0
snd_seq_oss 37760 0
snd_seq_midi 14336 0
snd_rawmidi 29696 1 snd_seq_midi
snd_seq_midi_event 15104 2 snd_seq_oss,snd_seq_midi
snd_seq 56880 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 29704 2 snd_pcm,snd_seq
snd_seq_device 14988 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 62628 16 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 15200 1 snd
snd_page_alloc 16904 2 snd_intel8x0,snd_pcm

It is not a kernel sound module being dropped, so running the script /etc/rc.local and adding modprobe [any sound module] before the exit 0 command is not going to make any difference.
It must be alsa which is being dropped somehow, and this doesn't seem to be a kernel module,
because coding: lsmod | grep alsa
returns nothing.

So in the boot up script, somewhere, there needs to be a command to restart alsa after the login window is dropped, if a login successful sound is used. Any ideas?
If I knew where my login sound preferences were being saved, presumably somewhere in the /etc folder, I might be able to see what is going wrong.
Atlantic-Aurora
Level 1
Level 1
 
Posts: 8
Joined: Sat Jul 25, 2009 1:37 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 9 guests