[solved] can't get 5.1 surround to work

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

[solved] can't get 5.1 surround to work

Postby TacoMe on Wed Jul 29, 2009 2:11 pm

Greetings,

the whole day now I'm trying to get my surround sound to work. I've spent five hours now, by searching google and the forum and testing every possible setting in the ALSA mixer, but nothing seems to be working.

Device Information:
- onboard controller of an ASRock K7VT4A+
- VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)

please help, I need BASS in my life :(
Last edited by TacoMe on Thu Jul 30, 2009 10:43 am, edited 1 time in total.
Topics I still need help with:
gampad/joystick HOW?
TacoMe
Level 1
Level 1
 
Posts: 19
Joined: Fri Jul 17, 2009 7:38 pm
Location: Oldenburg, Germany

Linux Mint is funded by ads and donations.
 

Re: can't get 5.1 surround to work

Postby lagagnon on Wed Jul 29, 2009 2:21 pm

I would start by using "aplay" and a test file (see here: http://alsa.opensrc.org/index.php/SurroundSound ) and follow the suggestions at that page. It looks a bit complicated but if you go through step by step slowly you should manage.
User avatar
lagagnon
Level 7
Level 7
 
Posts: 1888
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: can't get 5.1 surround to work

Postby TacoMe on Thu Jul 30, 2009 10:43 am

yea right, that's a big bang. especially for someone who doesn't speak perfect English.
I've noticed that my 5.1 is working correctly, the applications just don't know how to access the channels.

SOLUTION

But I've finally found a solution! here is what I've done:

- Set all Outputs to ALSA
- Set The .asoundrc file to the following
Code: Select all
pcm.!default {
type plug
slave.pcm "softvol"
}

pcm.softvol {
type softvol
slave {
pcm "ch51dup"
}
control {
name "All"
card 0
}
}

pcm.ch51dup {
type plug
slave.pcm surround51
slave.channels 6
route_policy duplicate
}


Thanks for the help. Finally I have BASS again. :)
Topics I still need help with:
gampad/joystick HOW?
TacoMe
Level 1
Level 1
 
Posts: 19
Joined: Fri Jul 17, 2009 7:38 pm
Location: Oldenburg, Germany


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 8 guests