[SOLVED] Banshee Frozen on Startup

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

[SOLVED] Banshee Frozen on Startup

Postby The_Weaver on Mon Aug 03, 2009 2:05 am

I've been using Banshee 1.4.3 on Mint 6 (Intrepid) for a while without trouble, but today its started to freeze on start-up. I've un-installed and reinstalled without any benefit.

The System Monitor shows the process as running, and its using 50% of my CPU, with a waiting channel as 0.

Here's the Debug log

[Info 16:34:28.633] Running Banshee 1.4.3: [Ubuntu 8.10 (linux-gnu, i486) @ 2009-04-21 13:16:22 UTC]
[Debug 16:34:30.293] Bus.Session.RequestName ('org.bansheeproject.Banshee') replied with PrimaryOwner
[Debug 16:34:30.304] Core service started (DBusServiceManager, 0.002412s)
[Debug 16:34:30.308] Registering remote object /org/bansheeproject/Banshee/DBusCommandService (Banshee.ServiceStack.DBusCommandService) on org.bansheeproject.Banshee
[Debug 16:34:30.324] Core service started (DBusCommandService, 0.018704s)
[Debug 16:34:30.424] Opened SQLite connection to /home/keith/.config/banshee-1/banshee.db
[Debug 16:34:30.424] Core service started (DbConnection, 0.09985s)
[Debug 16:34:30.443] Database version 22 is up to date
[Debug 16:34:30.489] Core service started (PreferenceService, 0.044283s)
[Debug 16:34:30.491] Registering remote object /org/bansheeproject/Banshee/SourceManager (Banshee.Sources.SourceManager) on org.bansheeproject.Banshee
[Debug 16:34:30.491] Core service started (SourceManager, 0.002019s)
[Debug 16:34:30.735] Core service started (MediaProfileManager, 0.243679s)
[Debug 16:34:30.737] Registering remote object /org/bansheeproject/Banshee/PlayerEngine (Banshee.MediaEngine.PlayerEngineService) on org.bansheeproject.Banshee
[Debug 16:34:30.739] Core service started (PlayerEngine, 0.004273s)
[Debug 16:34:30.747] Configuration client extension loaded (Banshee.GnomeBackend.GConfConfigurationClient)
[Debug 16:34:30.821] IO provider extension loaded (Banshee.IO.Unix.Provider)
[Debug 16:34:30.840] Core service started (TranscoderService, 0.023016s)
[Debug 16:34:30.842] Registering remote object /org/bansheeproject/Banshee/PlaybackController (Banshee.PlaybackController.PlaybackControllerServ ice) on org.bansheeproject.Banshee
[Debug 16:34:30.843] Core service started (PlaybackController, 0.003118s)
[Debug 16:34:30.845] Core service started (ImportSourceManager, 0.002408s)
[Debug 16:34:30.853] Core service started (LibraryImportManager, 0.00753s)
[Debug 16:34:30.854] Core service started (UserJobManager, 0.000873s)
[Debug 16:34:30.877] Core service started (HardwareManager, 0.0234s)
[Debug 16:34:30.881] Bus.Session.RequestName ('org.bansheeproject.CollectionIndexer') replied with PrimaryOwner
[Debug 16:34:30.882] Registering remote object /org/bansheeproject/Banshee/CollectionIndexerService (Banshee.Collection.Indexer.CollectionIndexerServi ce) on org.bansheeproject.CollectionIndexer
[Debug 16:34:30.884] Core service started (CollectionIndexerService, 0.006145s)
[Debug 16:34:30.984] Adding icon theme search path: /usr/share/banshee-1/icons
[Debug 16:34:30.986] Core service started (GtkElementsService, 0.102325s)
[Debug 16:34:31.061] Core service started (InterfaceActionService, 0.074358s)
[Debug 16:34:31.064] Album artwork path set to /home/keith/.cache/album-art
[Debug 16:34:31.064] Core service started (ArtworkManager, 0.002478s)
[Debug 16:34:31.665] Registering remote object /org/bansheeproject/Banshee/ClientWindow (Nereid.PlayerInterface) on org.bansheeproject.Banshee
[Debug 16:34:31.665] Core service started (NereidPlayerInterface, 0.601283s)
[Debug 16:34:31.672] Using GNOME 2.22 API for Multimedia Keys
[Debug 16:34:31.673] Extension service started (MultimediaKeysService, 0.006781s)
[Debug 16:34:31.675] Extension service started (DaapService, 0.001335s)
[Debug 16:34:31.815] GStreamer pipeline does not run: audioconvert ! xingenc bitrate=128 ! id3v2mux
[Debug 16:34:31.914] GStreamer pipeline does not run: audioconvert ! fluwmaenc bitrate=64000 vbr=false ! fluasfmux
[Debug 16:34:31.914] Extension service started (GStreamerCoreService, 0.239739s)
[Debug 16:34:31.942] Player state change: NotReady -> Ready
[Debug 16:34:31.965] Enabling equalizer preset: New Preset
[Debug 16:34:31.979] Player state change: Ready -> Idle
[Debug 16:34:31.988] (libbansheelayer) Enabled ReplayGain
[Debug 16:34:31.988] (libbansheelayer) scaled volume: 1.000000 (ReplayGain) * 0.550000 (User) = 0.550000
[Debug 16:34:31.989] Extension service started (DapService, 0.000748s)
[Debug 16:34:32.239] Extension service started (PodcastService, 0.250344s)
[Debug 16:34:32.259] Extension service started (BookmarksService, 0.019076s)
[Debug 16:34:32.261] Extension service started (CoverArtService, 0.002177s)
[Debug 16:34:32.266] Extension service started (GnomeService, 0.004195s)
[Debug 16:34:32.328] Extension service started (AudioCdService, 0.062036s)
[Debug 16:34:32.512] Extension service started (NotificationAreaService, 0.184141s)
[Debug 16:34:32.548] Extension service started (LastfmRecommendationService, 0.036062s)
[Debug 16:34:32.568] Core service started (Network, 0.004767s)
[Debug 16:34:32.569] Audioscrobbler state: connected
[Debug 16:34:32.571] Extension service started (AudioscrobblerService, 0.022332s)
[Info 16:34:32.572] All services are started 2.277794s

Any advice will be appreciated since I can't change the songs on my, or my wife's Ipod!

Thanks.


EDIT - Upgraded to the Beta 1.5, and this solved it!
Last edited by The_Weaver on Thu Oct 08, 2009 1:32 pm, edited 1 time in total.
The_Weaver
Level 1
Level 1
 
Posts: 24
Joined: Mon Aug 03, 2009 2:01 am

Linux Mint is funded by ads and donations.
 

Re: Banshee Frozen on Startup

Postby Husse on Wed Aug 05, 2009 5:32 am

I found that to delete the banshe folders in the hidden folder .config in home seems to help
There is probably both ~/.config/banshee and ~/.config/banshee-1 or maybe just the one
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Banshee Frozen on Startup

Postby The_Weaver on Wed Aug 05, 2009 4:00 pm

Thanks, I guess I just copy my .db filesome where else, before deletion, then copy it back in after ?

Thanks
The_Weaver
Level 1
Level 1
 
Posts: 24
Joined: Mon Aug 03, 2009 2:01 am

Re: Banshee Frozen on Startup

Postby Husse on Wed Aug 05, 2009 6:11 pm

The .db file is that music only?
Because then I don't think there's a problem, but if it contains settings it might be one of those that brings it down in the worst case
Just try - and don't delete rather rename so you have it in case all goes wrong
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Banshee Frozen on Startup

Postby The_Weaver on Thu Aug 06, 2009 1:46 am

Thanks, gave this a go but no change, same thing happens.

Thanks
The_Weaver
Level 1
Level 1
 
Posts: 24
Joined: Mon Aug 03, 2009 2:01 am

Re: Banshee Frozen on Startup

Postby The_Weaver on Sun Aug 09, 2009 4:54 pm

Any other suggestions, my IPOD needs refilling! Thanks.
The_Weaver
Level 1
Level 1
 
Posts: 24
Joined: Mon Aug 03, 2009 2:01 am

Re: Banshee Frozen on Startup

Postby The_Weaver on Wed Aug 12, 2009 5:39 pm

ran an other command and got this debug output. nay thoughts ?

exec -a banshee-1 mono /usr/lib/banshee-1/Banshee.exe --redirect-log --play-enqueued

[Info 06:37:57.875] Running Banshee 1.4.2: [Ubuntu 8.10 (linux-gnu, i486) @ 2009-03-03 15:49:43 UTC]
[Info 06:38:01.687] All services are started 3.39101s
[Info 06:38:03.139] nereid Client Started

(Banshee:5908): Gdk-CRITICAL **: gdk_window_get_parent: assertion `GDK_IS_WINDOW (window)' failed

(Banshee:5908): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed

(Banshee:5908): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed

(Banshee:5908): Gtk-CRITICAL **: gtk_widget_event: assertion `WIDGET_REALIZED_FOR_EVENT (widget, event)' failed
[Error 06:42:50.106] GStreamer resource error: NotFound
[Error 06:42:52.319] GStreamer resource error: NotFound
[Error 06:43:07.047] GStreamer resource error: NotFound
[Error 06:43:11.328] GStreamer resource error: NotFound
[Error 06:43:23.327] GStreamer resource error: NotFound
[Error 06:44:09.038] GStreamer resource error: NotFound
[Warn 06:45:26.216] Caught an exception - The request timed out (in `System')
at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00000]
at System.Net.HttpWebRequest.GetResponse () [0x00000]
at Banshee.Metadata.MetadataServiceJob.GetHttpStream (System.Uri uri, System.String[] ignoreMimeTypes) [0x00000]
at Banshee.Metadata.MetadataServiceJob.GetHttpStream (System.Uri uri) [0x00000]
at Banshee.Metadata.Rhapsody.RhapsodyQueryJob.Run () [0x00000]
at Banshee.Metadata.MetadataServiceJob.Run () [0x00000]
[Warn 06:47:23.208] Caught an exception - The request timed out (in `System')
at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00000]
at System.Net.HttpWebRequest.GetResponse () [0x00000]
at Banshee.Metadata.MetadataServiceJob.GetHttpStream (System.Uri uri, System.String[] ignoreMimeTypes) [0x00000]
at Banshee.Metadata.MetadataServiceJob.GetHttpStream (System.Uri uri) [0x00000]
at Banshee.Metadata.Rhapsody.RhapsodyQueryJob.Run () [0x00000]
at Banshee.Metadata.MetadataServiceJob.Run () [0x00000]
[Warn 06:49:26.476] Caught an exception - The remote server returned an error: (404) Not Found. (in `System')
at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000]
at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000]
[Warn 06:49:51.383] Caught an exception - The remote server returned an error: (503) Service Temporarily Unavailable. (in `System')
at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000]
at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000]
[Warn 06:50:27.393] Caught an exception - The request timed out (in `System')
at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00000]
at System.Net.HttpWebRequest.GetResponse () [0x00000]
at Banshee.Metadata.MetadataServiceJob.GetHttpStream (System.Uri uri, System.String[] ignoreMimeTypes) [0x00000]
at Banshee.Metadata.MetadataServiceJob.GetHttpStream (System.Uri uri) [0x00000]
at Banshee.Metadata.MusicBrainz.MusicBrainzQueryJob.FindAsin () [0x00000]
at Banshee.Metadata.MusicBrainz.MusicBrainzQueryJob.Lookup () [0x00000]
at Banshee.Metadata.MusicBrainz.MusicBrainzQueryJob.Run () [0x00000]
at Banshee.Metadata.MetadataServiceJob.Run () [0x00000]
[Warn 06:50:46.233] Caught an exception - The remote server returned an error: (404) Not Found. (in `System')
at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000]
at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000]

(Banshee:5908): GStreamer-CRITICAL **:
Trying to dispose element test, but it is not in the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.

[Warn 06:51:34.955] Caught an exception - The remote server returned an error: (404) Not Found. (in `System')
at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000]
at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000]
[Warn 06:52:14.177] Caught an exception - The remote server returned an error: (503) Service Temporarily Unavailable. (in `System')
at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000]
at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000]
[Warn 06:53:36.076] Caught an exception - The request timed out (in `System')
at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00000]
at System.Net.HttpWebRequest.GetResponse () [0x00000]
at Banshee.Metadata.MetadataServiceJob.GetHttpStream (System.Uri uri, System.String[] ignoreMimeTypes) [0x00000]
at Banshee.Metadata.MetadataServiceJob.GetHttpStream (System.Uri uri) [0x00000]
at Banshee.Metadata.Rhapsody.RhapsodyQueryJob.Run () [0x00000]
at Banshee.Metadata.MetadataServiceJob.Run () [0x00000]
[Warn 06:53:42.478] Caught an exception - The remote server returned an error: (404) Not Found. (in `System')
at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000]
at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000]
[Warn 07:28:26.453] Audioscrobbler sign-on failed - Temporary server failure: Invalid/Missing Parameter(s)
[Warn 07:28:27.545] Failed to log into Last.fm - Either your username or password is invalid.
[Error 07:40:39.021] GStreamer resource error: NotFound
[Warn 07:57:27.512] Caught an exception - Object reference not set to an instance of an object (in `Banshee.CoverArt')
at Banshee.CoverArt.CoverArtJob.RunQuery () [0x00000]
at Banshee.CoverArt.CoverArtJob.Run () [0x00000]
The_Weaver
Level 1
Level 1
 
Posts: 24
Joined: Mon Aug 03, 2009 2:01 am

Re: Banshee Frozen on Startup

Postby Husse on Thu Aug 13, 2009 6:23 am

Banshee:5908): Gtk-CRITICAL **: gtk_widget_event: assertion `WIDGET_REALIZED_FOR_EVENT (widget, event)' failed
[Error 06:42:50.106] GStreamer resource error: NotFound

This is indicative of the error - it's the GUI that has problems possibly leading to a GStreamer error
I found something but not the solution so I have to come back to you when I have more time
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Banshee Frozen on Startup

Postby The_Weaver on Fri Aug 28, 2009 3:44 am

Husse, did you manage to find anything else about this problem ? Thanks.
The_Weaver
Level 1
Level 1
 
Posts: 24
Joined: Mon Aug 03, 2009 2:01 am

Re: Banshee Frozen on Startup

Postby Husse on Fri Aug 28, 2009 7:10 am

I has fallen off my list - have to research again when I have more time
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Banshee Frozen on Startup

Postby Husse on Sat Aug 29, 2009 1:08 pm

Banshee or a theme may have added the file gtkrc
In that file change the line gtk-menu-popup-delay = 0 to gtk-menu-popup-delay = 1
I found this as a remedy for a right clicking problem - but your problem may be similar
I see that you have been active
I've also seen that deleting the database and reimporting fixes it
It can also be a permissions problem - run banshee shortly as root (I suppose sudo banshee)
If that works it defintely is a permissions problem or a problem with your home folder and in this case deleting the hidden banshee folder(s) in home will most likely fix it
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Banshee Frozen on Startup

Postby The_Weaver on Sun Aug 30, 2009 9:02 am

Which GTKRC file do I need to look in, I've run a search and its found 23 instances of the file.

Also when I run sudo Banshee it does not open and I get the following :

Unhandled Exception: System.Exception: Unable to open the session message bus. ---> System.ArgumentNullException: Argument cannot be null.
Parameter name: address
at NDesk.DBus.Bus.Open (System.String address) [0x00000]
at NDesk.DBus.Bus.get_Session () [0x00000] --- End of inner exception stack trace ---

at NDesk.DBus.Bus.get_Session () [0x00000]
at Banshee.ServiceStack.DBusConnection.get_ApplicationInstanceAlreadyRunning () [0x00000]
at Booter.Booter.Main () [0x00000]

Thanks again.
The_Weaver
Level 1
Level 1
 
Posts: 24
Joined: Mon Aug 03, 2009 2:01 am

Re: Banshee Frozen on Startup

Postby Husse on Sun Aug 30, 2009 4:35 pm

Now I am confused .....
But this indicates a problem with permissions/user accounts as you get a completely different error as root (with sudo)
This needs more thinking...
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Banshee Frozen on Startup

Postby Husse on Mon Aug 31, 2009 5:50 am

It all comes back to GStreamer
What if you reinstalled gstreamer0.10-alsa ?
Code: Select all
apt install --reinstall gstreamer0.10-alsa
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Banshee Frozen on Startup

Postby The_Weaver on Mon Aug 31, 2009 5:14 pm

Ran the command but it still hangs on start-up.
The_Weaver
Level 1
Level 1
 
Posts: 24
Joined: Mon Aug 03, 2009 2:01 am

Re: Banshee Frozen on Startup

Postby Husse on Thu Sep 03, 2009 7:20 am

I see
GStreamer pipeline does not run: audioconvert ! fluwmaenc bitrate=64000 vbr=false ! fluasfmux

That error shows that gstreamer is not happy with 64,000 sampling which is not a common sampling rate.
Can you change it to 40,000 or 96,000 which if my memory serves me right are more common
I don't know if you can make any settings, but I guess that your settings are kept in the hidden banshee folder in home so it should be possible to manually edit a file
I don't have banshee installed - time to install Gloria in virtualbox perhaps
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Banshee Frozen on Startup

Postby The_Weaver on Thu Sep 03, 2009 5:38 pm

Not sure how to change the settings will do some searching.

Just upgraded to Mint 7, and still the same problem with Banshee!!
The_Weaver
Level 1
Level 1
 
Posts: 24
Joined: Mon Aug 03, 2009 2:01 am

Re: Banshee Frozen on Startup

Postby Husse on Fri Sep 04, 2009 5:42 am

Just upgraded to Mint 7

Did you make a clean install or did you follow the upgrade path?
If the latter we can surely say it's something in home (something in .gconf or so) and if you have a separate home partition it is probably the same in a fresh install
I doubt hardware plays a role here
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Banshee Frozen on Startup

Postby The_Weaver on Fri Sep 04, 2009 2:39 pm

I followed the upgrade path. I'm tempted to do a clean install, since a couple of minor issues such as graphic drivers not loaded see post viewtopic.php?f=46&t=32277. However, not sure when I'll find the time!
The_Weaver
Level 1
Level 1
 
Posts: 24
Joined: Mon Aug 03, 2009 2:01 am

Re: Banshee Frozen on Startup

Postby Husse on Fri Sep 04, 2009 3:03 pm

Then I'm convinced there is something in your home that configures banshee the wrong way
Make a folder in home somewhere in home and move anything that has the slightest connection to banshee into it and see what happens
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 
Next

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 8 guests