no sound on HP Compaq Presario laptop

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

no sound on HP Compaq Presario laptop

Postby jake066 on Mon Aug 24, 2009 3:02 am

I have been a Linux user for a couple of years, first with Fedora 8, and subsequently with Linux Mint Felicia and Gloria, as well as trying out a host of other distros. Linux Mint Gloria works fine on my ancient desktop and did on the old Dell laptop too (before the laptop died), using the same CD to load the OS.

A couple of months ago I purchased a Compaq Presario CQ60 laptop. I kept the pre-loaded V*sta on it but reconfigured my partitions and loaded Linux Mint Gloria as a dual boot. The sound under V*sta works fine. I cannot get any sound out of the Linux Mint Gloria.

Linux Mint is by far my favourite distro and Linux is my operating system of choice. I do wish to get it fully going on my new laptop, the only thing missing being the sound.

I have searched the forums and tried out all the suggestions I could find that seemed appropriate but none seem to work for this laptop. I can find no specific reference to this laptop either.

I have had no success with the "standard solution for Intel HDA sound". I have also tried the suggested solution at <https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/61903>, changing the commands to refer to the "alsa-base.conf" (not "alsa-base") and the "sound" (not "options") files. I am not an IT person, but a reasonably experienced user of computers for many years.



It appears to me that my computer is not playing back a digital device. On running the following commands, I get:

$ aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0


$ lspci

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)


$ lspci -nv

00:00.0 0600: 8086:2a40 (rev 07)
Subsystem: 103c:3069
Flags: bus master, fast devsel, latency 0
Capabilities: <access denied>
Kernel driver in use: agpgart-intel
Kernel modules: intel-agp

00:02.0 0300: 8086:2a42 (rev 07)
Subsystem: 103c:3069
Flags: bus master, fast devsel, latency 0, IRQ 2299
Memory at d0000000 (64-bit, non-prefetchable) [size=4M]
Memory at c0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 4110 [size=8]
Capabilities: <access denied>

00:02.1 0380: 8086:2a43 (rev 07)
Subsystem: 103c:3069
Flags: bus master, fast devsel, latency 0
Memory at d2400000 (64-bit, non-prefetchable) [size=1M]
Capabilities: <access denied>

00:1a.0 0c03: 8086:2937 (rev 03)
Subsystem: 103c:3069
Flags: bus master, medium devsel, latency 0, IRQ 16
I/O ports at 40e0 [size=32]
Capabilities: <access denied>
Kernel driver in use: uhci_hcd

00:1a.1 0c03: 8086:2938 (rev 03)
Subsystem: 103c:3069
Flags: bus master, medium devsel, latency 0, IRQ 21
I/O ports at 40c0 [size=32]
Capabilities: <access denied>
Kernel driver in use: uhci_hcd

00:1a.7 0c03: 8086:293c (rev 03) (prog-if 20)
Subsystem: 103c:3069
Flags: bus master, medium devsel, latency 0, IRQ 19
Memory at d4505c00 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>
Kernel driver in use: ehci_hcd

00:1b.0 0403: 8086:293e (rev 03)
Subsystem: 103c:3069
Flags: bus master, fast devsel, latency 0, IRQ 22
Memory at d4500000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

00:1c.0 0604: 8086:2940 (rev 03)
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
I/O behind bridge: 00003000-00003fff
Memory behind bridge: d3500000-d44fffff
Prefetchable memory behind bridge: 00000000d0400000-00000000d13fffff
Capabilities: <access denied>
Kernel driver in use: pcieport-driver
Kernel modules: shpchp

00:1c.1 0604: 8086:2942 (rev 03)
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
I/O behind bridge: 00002000-00002fff
Memory behind bridge: d2500000-d34fffff
Prefetchable memory behind bridge: 00000000d1400000-00000000d23fffff
Capabilities: <access denied>
Kernel driver in use: pcieport-driver
Kernel modules: shpchp

00:1d.0 0c03: 8086:2934 (rev 03)
Subsystem: 103c:3069
Flags: bus master, medium devsel, latency 0, IRQ 20
I/O ports at 40a0 [size=32]
Capabilities: <access denied>
Kernel driver in use: uhci_hcd

00:1d.1 0c03: 8086:2935 (rev 03)
Subsystem: 103c:3069
Flags: bus master, medium devsel, latency 0, IRQ 19
I/O ports at 4080 [size=32]
Capabilities: <access denied>
Kernel driver in use: uhci_hcd

00:1d.2 0c03: 8086:2936 (rev 03)
Subsystem: 103c:3069
Flags: bus master, medium devsel, latency 0, IRQ 16
I/O ports at 4060 [size=32]
Capabilities: <access denied>
Kernel driver in use: uhci_hcd

00:1d.3 0c03: 8086:2939 (rev 03)
Subsystem: 103c:3069
Flags: bus master, medium devsel, latency 0, IRQ 18
I/O ports at 4040 [size=32]
Capabilities: <access denied>
Kernel driver in use: uhci_hcd

00:1d.7 0c03: 8086:293a (rev 03) (prog-if 20)
Subsystem: 103c:3069
Flags: bus master, medium devsel, latency 0, IRQ 20
Memory at d4505800 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>
Kernel driver in use: ehci_hcd

00:1e.0 0604: 8086:2448 (rev 93) (prog-if 01)
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=04, subordinate=04, sec-latency=32
Capabilities: <access denied>

00:1f.0 0601: 8086:2919 (rev 03)
Subsystem: 103c:3069
Flags: bus master, medium devsel, latency 0
Capabilities: <access denied>
Kernel modules: iTCO_wdt

00:1f.2 0106: 8086:2929 (rev 03) (prog-if 01)
Subsystem: 103c:3069
Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 2301
I/O ports at 4108 [size=8]
I/O ports at 411c [size=4]
I/O ports at 4100 [size=8]
I/O ports at 4118 [size=4]
I/O ports at 4020 [size=32]
Memory at d4505000 (32-bit, non-prefetchable) [size=2K]
Capabilities: <access denied>
Kernel driver in use: ahci

00:1f.3 0c05: 8086:2930 (rev 03)
Subsystem: 103c:3069
Flags: medium devsel, IRQ 11
Memory at d4506000 (64-bit, non-prefetchable) [size=256]
I/O ports at 4000 [size=32]
Kernel modules: i2c-i801

00:1f.6 1180: 8086:2932 (rev 03)
Subsystem: 103c:3069
Flags: fast devsel, IRQ 11
Memory at d4504000 (64-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>

02:00.0 0200: 168c:001c (rev 01)
Subsystem: 103c:137b
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at d3500000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: ath5k_pci
Kernel modules: ath_pci, ath5k

03:00.0 0200: 10ec:8136 (rev 02)
Subsystem: 103c:3069
Flags: bus master, fast devsel, latency 0, IRQ 2300
I/O ports at 2000 [size=256]
Memory at d1410000 (64-bit, prefetchable) [size=4K]
Memory at d1400000 (64-bit, prefetchable) [size=64K]
Expansion ROM at d1420000 [disabled] [size=64K]
Capabilities: <access denied>
Kernel driver in use: r8169
Kernel modules: r8169

Most of the above means very little to me. I'm hoping it means a lot more to someone else out there, who might be able to set me on the right track, please.
jake066
Level 1
Level 1
 
Posts: 2
Joined: Wed Jul 08, 2009 3:11 am

Linux Mint is funded by ads and donations.
 

Re: no sound on HP Compaq Presario laptop

Postby Husse on Wed Aug 26, 2009 6:16 pm

Thank you for searching before you post
The standard solution is unfortunately what I have up my sleeve in the first (and second and third... ) round
The thing is that model sometimes have to be set to something seemingly odd
Look at the topic in the Ubuntu forum linked to in that standard solution
One of the "-stack-" models may do it
You get
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]

Not the Digital? - that's what you normally find
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: no sound on HP Compaq Presario laptop

Postby Kaye on Thu Aug 27, 2009 1:35 am

This should work for you:
Building OSS from source
Basically, it'll compile a stable release of OSS into your kernel, which will take over ALSA, and should work with your sound card.

I would recommend using this download, and follow the guide starting from "Change to the source directory." Restart when you're all done and you should be good to go.
"In somnis veritas"
Antivirus or defragging?
Image
User avatar
Kaye
Level 5
Level 5
 
Posts: 942
Joined: Fri Feb 06, 2009 5:05 pm
Location: Boston College

Re: no sound on HP Compaq Presario laptop

Postby jake066 on Sat Aug 29, 2009 11:31 pm

Thank you Husse and Kaye for your help. I've been in hospital for several days and unable to access a computer, so please pardon my tardiness in responding.

I'll check out the various ways suggested and see if I can rectify the problem pronto (within the limitations of my recovery) and report back.
jake066
Level 1
Level 1
 
Posts: 2
Joined: Wed Jul 08, 2009 3:11 am

Re: no sound on HP Compaq Presario laptop

Postby Husse on Sun Aug 30, 2009 7:19 am

Go slow - your health is much more important than a computer
And I hope you recover
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: no sound on HP Compaq Presario laptop

Postby igorzwx on Sat Sep 05, 2009 4:39 pm

QUOTE:
This should work for you:
Building OSS from source
End of Quote

I would propose to compile OSS4 from Mercurial following this howto:
https://help.ubuntu.com/community/OpenSound

The list of supported devices is here:
http://mercurial.opensound.com/?file/6b ... ists/Linux
73 oss_hdaudio pci8086,293f Intel High Definition Audio (ICH9)

You may need this info too:
http://martinbaselier.wordpress.com/
7.1 Troubleshooting HDAudio devices
http://wiki.archlinux.org/index.php/OSS ... io_devices
igorzwx
Level 5
Level 5
 
Posts: 599
Joined: Sat Sep 05, 2009 3:13 pm

Re: no sound on HP Compaq Presario laptop

Postby Husse on Sat Sep 05, 2009 4:43 pm

Yo failed in your quote
I think you referred to one of the solutions found from this topic
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: no sound on HP Compaq Presario laptop

Postby igorzwx on Sat Sep 05, 2009 5:37 pm

Hi Husse!

I quoted post by Kaye in this thread:
Re: no sound on HP Compaq Presario laptop

Postby Kaye on Thu Aug 27, 2009 6:35 am
This should work for you:
Building OSS from source

What is wrong?
igorzwx
Level 5
Level 5
 
Posts: 599
Joined: Sat Sep 05, 2009 3:13 pm

Re: no sound on HP Compaq Presario laptop

Postby Husse on Sat Sep 05, 2009 5:47 pm

What is wrong?

Missing link :)
Here it is
viewtopic.php?f=49&t=31966
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 4 guests