No sound on my Dell 1440

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

No sound on my Dell 1440

Postby garysbasem3nt on Tue Sep 29, 2009 3:50 pm

Somewhat of a noob here - I've ran Linux Ubuntu before (on a custom made desktop - dual boot - but was usually running XP) - I wanted to give Linux Mint a shot when I bought my new notebook (a Dell 1440). Almost everything is great, but I can't get the speakers to work on my machine.

I have headphone sound, albeit very low - but no speaker sound.

I have tried the solutions listed here (to no avail) -

http://ubuntuforums.org/showthread.php?t=1259593

viewtopic.php?f=49&t=23139

And I've seen recent threads of users having the same issues (posting on the Ubuntu forums) - http://ubuntuforums.org/showthread.php?t=1258374

I don't want to stick with this convoluted Windows Vista - it is not enjoyable at all - and frankly, I don't want to start installing useful software on this OS when I have every intention of being on Linux the majority of the time (I would like for it to be this distro, but if I can't get sound, I'm going to try others).

Any ideas/advice/help would be greatly appreciated.

(This is a cross post from the Noobie category - viewtopic.php?f=90&t=33312 )
Last edited by garysbasem3nt on Tue Sep 29, 2009 4:43 pm, edited 1 time in total.
garysbasem3nt
Level 1
Level 1
 
Posts: 11
Joined: Tue Sep 22, 2009 9:58 pm

Linux Mint is funded by ads and donations.
 

Re: No sound on my Dell 1440

Postby igorzwx on Tue Sep 29, 2009 4:08 pm

O.K. Let us try.

Could you please post here the output of these commands?

aplay -l

sudo lshw -C multimedia

lspci -v
igorzwx
Level 5
Level 5
 
Posts: 599
Joined: Sat Sep 05, 2009 3:13 pm

Re: No sound on my Dell 1440

Postby garysbasem3nt on Tue Sep 29, 2009 4:25 pm

Thanks for the quick response. Here's the outputs -

Code: Select all
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0


Code: Select all
  *-multimedia           
       description: Audio device
       product: 82801I (ICH9 Family) HD Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=HDA Intel latency=0 module=snd_hda_intel


Code: Select all
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
   Subsystem: Dell Device 02cf
   Flags: bus master, fast devsel, latency 0
   Capabilities: <access denied>
   Kernel driver in use: agpgart-intel
   Kernel modules: intel-agp

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
   Subsystem: Dell Device 02cf
   Flags: bus master, fast devsel, latency 0, IRQ 2297
   Memory at f6c00000 (64-bit, non-prefetchable) [size=4M]
   Memory at e0000000 (64-bit, prefetchable) [size=256M]
   I/O ports at efe8 [size=8]
   Capabilities: <access denied>

00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
   Subsystem: Dell Device 02cf
   Flags: bus master, fast devsel, latency 0
   Memory at f6b00000 (64-bit, non-prefetchable) [size=1M]
   Capabilities: <access denied>

00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
   Subsystem: Dell Device 02cf
   Flags: bus master, medium devsel, latency 0, IRQ 20
   I/O ports at 6f60 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
   Subsystem: Dell Device 02cf
   Flags: bus master, medium devsel, latency 0, IRQ 21
   I/O ports at 6f80 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
   Subsystem: Dell Device 02cf
   Flags: bus master, medium devsel, latency 0, IRQ 22
   I/O ports at 6fa0 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03) (prog-if 20)
   Subsystem: Dell Device 02cf
   Flags: bus master, medium devsel, latency 0, IRQ 22
   Memory at fed1c400 (32-bit, non-prefetchable) [size=1K]
   Capabilities: <access denied>
   Kernel driver in use: ehci_hcd

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
   Subsystem: Dell Device 02cf
   Flags: bus master, fast devsel, latency 0, IRQ 21
   Memory at f6afc000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: HDA Intel
   Kernel modules: snd-hda-intel

00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=0b, subordinate=0b, sec-latency=0
   Capabilities: <access denied>
   Kernel driver in use: pcieport-driver
   Kernel modules: shpchp

00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=0c, subordinate=0c, sec-latency=0
   Memory behind bridge: f6900000-f69fffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport-driver
   Kernel modules: shpchp

00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=09, subordinate=09, sec-latency=0
   I/O behind bridge: 0000d000-0000dfff
   Memory behind bridge: f6800000-f68fffff
   Prefetchable memory behind bridge: 00000000f0000000-00000000f00fffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport-driver
   Kernel modules: shpchp

00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=0d, subordinate=0e, sec-latency=0
   I/O behind bridge: 0000c000-0000cfff
   Memory behind bridge: f6600000-f67fffff
   Prefetchable memory behind bridge: 00000000f0100000-00000000f03fffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport-driver
   Kernel modules: shpchp

00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
   Subsystem: Dell Device 02cf
   Flags: bus master, medium devsel, latency 0, IRQ 20
   I/O ports at 6f00 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
   Subsystem: Dell Device 02cf
   Flags: bus master, medium devsel, latency 0, IRQ 21
   I/O ports at 6f20 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
   Subsystem: Dell Device 02cf
   Flags: bus master, medium devsel, latency 0, IRQ 22
   I/O ports at 6f40 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03) (prog-if 20)
   Subsystem: Dell Device 02cf
   Flags: bus master, medium devsel, latency 0, IRQ 20
   Memory at fed1c000 (32-bit, non-prefetchable) [size=1K]
   Capabilities: <access denied>
   Kernel driver in use: ehci_hcd

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93) (prog-if 01)
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=03, subordinate=03, sec-latency=32
   Capabilities: <access denied>

00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
   Subsystem: Dell Device 02cf
   Flags: bus master, medium devsel, latency 0
   Capabilities: <access denied>
   Kernel modules: iTCO_wdt

00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03) (prog-if 01)
   Subsystem: Dell Device 02cf
   Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 2299
   I/O ports at 6e70 [size=8]
   I/O ports at 6e78 [size=4]
   I/O ports at 6e80 [size=8]
   I/O ports at 6e88 [size=4]
   I/O ports at 6ea0 [size=32]
   Memory at fed1c800 (32-bit, non-prefetchable) [size=2K]
   Capabilities: <access denied>
   Kernel driver in use: ahci

00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
   Subsystem: Dell Device 02cf
   Flags: medium devsel, IRQ 4
   Memory at f6afbf00 (64-bit, non-prefetchable) [size=256]
   I/O ports at 1100 [size=32]
   Kernel modules: i2c-i801

09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
   Subsystem: Dell Device 02cf
   Flags: bus master, fast devsel, latency 0, IRQ 2298
   I/O ports at de00 [size=256]
   Memory at f0010000 (64-bit, prefetchable) [size=4K]
   Memory at f0000000 (64-bit, prefetchable) [size=64K]
   [virtual] Expansion ROM at f0020000 [disabled] [size=128K]
   Capabilities: <access denied>
   Kernel driver in use: r8169
   Kernel modules: r8169

0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
   Subsystem: Dell Device 000c
   Flags: bus master, fast devsel, latency 0, IRQ 17
   Memory at f69fc000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: wl
   Kernel modules: wl
garysbasem3nt
Level 1
Level 1
 
Posts: 11
Joined: Tue Sep 22, 2009 9:58 pm

Re: No sound on my Dell 1440

Postby igorzwx on Tue Sep 29, 2009 4:44 pm

We will do this step by step.

You need two Mints 7 installed on the same box (10GB for each Mint).
These two Mints are for experimental purposes and it should be a fresh clean installation.

!!! Fresh clean installation !!!

1. In one Mint, you can try ALSA+ESound solution
viewtopic.php?f=48&t=32725

You may need to upgrade ALSA and/or fix it in some way.

ALSA Upgrade Script
http://ubuntuforums.org/showthread.php?p=6589810

HdaIntelSoundHowto - Community Ubuntu Documentation
https://help.ubuntu.com/community/HdaIntelSoundHowto


2. In another Mint, you can try OSS4 solution.

Compile OSS4 from Mercurial, following this howto
https://help.ubuntu.com/community/OpenSound

It is not difficult. Just copy and paste commands to Terminal.
Download OSS4 manual (pdf) from OSS4 web site.
They offer that manual together with deb (you do not need that deb, you have to compile it).

Do this and report the results here.

************************************************************

Howto for dual boot (and multiple boot):

Step 1: Preparation

1. Boot LiveCD (I tend to use Ubuntu 8.04 LiveCD for this purpose)
2. Run GParted
3. Free some space on the disk (10GB is enough)
it should not be formatted ("unallocated space") !!!
You may need to make swapoff, perhaps, before you can edit a logical partition.
4. reboot

Step 2: Installation

1. Boot Mint 7 LiveCD
2. Click on the icon "Install" (on Desktop)
3. Answer some questions (language, time zone, etc.)
4. Select option "install to largest continuous free space" (if you have such "unallocated space", that is, not formatted, no partitions)

Everything will be installed automatically

*****************************************************
How to run GParted

1. Boot Ubuntu LiveCD

2. System -> Administration -> Partition Editor

or on Terminal

gksu gparted

It will not ask you for password

I have not tried GParted with Mint LiveCD
I tend to use Ubuntu 8.04 LiveCD for this purpose.

HOWTO with pictures for GParted
Modify Your Partitions With GParted Without Losing Data
http://www.howtoforge.com/partitioning_with_gparted
igorzwx
Level 5
Level 5
 
Posts: 599
Joined: Sat Sep 05, 2009 3:13 pm

Re: No sound on my Dell 1440

Postby garysbasem3nt on Tue Sep 29, 2009 10:46 pm

Thank you - I don't have the time to rock this all out today (class and work eats up too much time) - but I will within the next couple days. I'll post the results. Thanks again for your help.
garysbasem3nt
Level 1
Level 1
 
Posts: 11
Joined: Tue Sep 22, 2009 9:58 pm


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 9 guests