Sound system in Mint8?

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Sound system in Mint8?

Postby Bejje on Fri Nov 27, 2009 3:13 pm

I recently tried Ubuntu 9.10 after using both Linux Mint and ubuntu for some years on and off. The problem with Ubuntu 9.10 is that SPDIF or IEC958 doesn't work anymore, but has always worked fine in earlier versions. I have gotten a whole bunch of suggestions on how to solve the problem, but none has worked. Just to be clear, the soundcard is detected and loaded and IEC958 is activated, but still no sound.

With the old soundsystem that Ubuntu used there was never any problem, but now they have some new thing that I have never seen before and it just simply wont work.
So my question is, will Linux Mint 8 use the same sound system as Ubuntu 9.10? I hope not, cause then I can't use Ubuntu's nor Mint's latest release.
Bejje
Level 1
Level 1
 
Posts: 13
Joined: Fri Nov 27, 2009 3:05 pm

Linux Mint is funded by ads and donations.
 

Re: Sound system in Mint8?

Postby Uncle Spellbinder on Fri Nov 27, 2009 5:30 pm

The days of pure alsa are gone. Mint 8/Ubuntu 9.10 are using Pulse Audio. There are some "howto's" in the Ubuntu Forums on how to return to pure alsa, but I've not tried them.
Computer Specs: HP Pavilion - Intel Core i5 - 3.10GHz - 8 GB memory - nVidia GeForce GT 520 1 GB
User avatar
Uncle Spellbinder
Level 2
Level 2
 
Posts: 87
Joined: Thu Nov 26, 2009 10:47 am

Re: Sound system in Mint8?

Postby AlanMAC1982 on Sun Nov 29, 2009 1:54 pm

I'm having the same issue. Funny thing is, in Ubuntu 9.10, the spdif works, but in Mint 8, it doesn't. Same computer, same settings. PCM turns on when I turn the surround sound on, but no sound comes out. It's like it's muted, but I've checked everything. It does this with both coax and optical.
AlanMAC1982
Level 1
Level 1
 
Posts: 5
Joined: Wed Dec 10, 2008 3:18 pm

Re: Sound system in Mint8?

Postby Mike65 on Mon Nov 30, 2009 4:08 am

I could setup the sound form the spdif, but then there is no sound from the headphones. Then i could hear voice from the headphone, but then the spdif was mute. And now i cant get sound from none of them... hard

mint-menu > configuration > sound > hardver and on the bottom of the tab: analog stereo duplex
Have sound right now. I hope it will stay like this when i reboot.
No it dont has digital output again...

I think i solved my problem.
1.viewtopic.php?f=49&t=23139
Then every reboot i have only digital(spdif) or analog(headphones) sound. Flash videos didnt has sound trough spdif, audacious sounds choppy.
2. removed pulseaudio package with his dependencies. Reboot. Now everithing works fine.

So much problem with audio since pulsaudio come out to the default sound server to some distros. I dont know why they force it. At least why dont the developers made it more useable?
User avatar
Mike65
Level 3
Level 3
 
Posts: 116
Joined: Wed May 27, 2009 7:34 am

Re: Sound system in Mint8?

Postby AlanMAC1982 on Sun Dec 06, 2009 2:44 pm

I still can't get the optical spdif working, so I went to analog and was able to get sound, but when I'm playing through anything, I have to go into sound preferences and then to applications tab and find which app I'm using. I'll use VLC for an example (this happens to anything though), I have to drag the sound bar all the way to the right to get any sound at all, but when I let go, the sound bar works it's way back to the left. Seems like this is a pretty big flaw, for me atleast.
AlanMAC1982
Level 1
Level 1
 
Posts: 5
Joined: Wed Dec 10, 2008 3:18 pm

Re: Sound system in Mint8?

Postby AlanMAC1982 on Tue Dec 15, 2009 1:35 pm

Guys, got it working!

Installed the XFCE4 Mixer.....

http://www.4front-tech.com/forum/viewto ... f=3&t=3372
AlanMAC1982
Level 1
Level 1
 
Posts: 5
Joined: Wed Dec 10, 2008 3:18 pm

Re: Sound system in Mint8?

Postby Bejje on Tue Dec 15, 2009 3:08 pm

AlanMAC1982 wrote:Guys, got it working!

Installed the XFCE4 Mixer.....

http://www.4front-tech.com/forum/viewto ... f=3&t=3372


wow, really hope this works. Will try it out later, but right now I'm using Mint 7 again since the sound works there.
Bejje
Level 1
Level 1
 
Posts: 13
Joined: Fri Nov 27, 2009 3:05 pm

Re: Sound system in Mint8?

Postby lannatwin on Sun Dec 20, 2009 5:28 am

Bejje wrote:
AlanMAC1982 wrote:Guys, got it working!

Installed the XFCE4 Mixer.....

http://www.4front-tech.com/forum/viewto ... f=3&t=3372


wow, really hope this works. Will try it out later, but right now I'm using Mint 7 again since the sound works there.


Well, did it work or not??
User avatar
lannatwin
Level 2
Level 2
 
Posts: 52
Joined: Sat Jun 20, 2009 9:14 pm
Location: Thailand

Re: Sound system in Mint8?

Postby Bejje on Sun Dec 20, 2009 12:32 pm

lannatwin wrote:Well, did it work or not??


Yes it did work :)
Bejje
Level 1
Level 1
 
Posts: 13
Joined: Fri Nov 27, 2009 3:05 pm

Re: Sound system in Mint8?

Postby lannatwin on Sun Dec 20, 2009 9:20 pm

Bejje wrote:
lannatwin wrote:Well, did it work or not??


Yes it did work :)



Working here as well. One issue I am having is playing DTS encoded video files. No sound unless I go into the mixer and move the IEC958 level control.
User avatar
lannatwin
Level 2
Level 2
 
Posts: 52
Joined: Sat Jun 20, 2009 9:14 pm
Location: Thailand

Re: Sound system in Mint8?

Postby AlanMAC1982 on Wed Dec 30, 2009 8:04 pm

Glad it worked for you! I've noticed a few issues, but atleast it works!
AlanMAC1982
Level 1
Level 1
 
Posts: 5
Joined: Wed Dec 10, 2008 3:18 pm

Re: Sound system in Mint8?

Postby NewLinux on Thu Dec 31, 2009 6:10 am

Please help... I have really enjoy Mint 7 and now 8... But I would really like to hear sounds... I am using the HDMI cable to my monitor speakers and the pavucontrol is muted...I can not for the life of me unmute that volume...

any help would be great...

Thanks
NewLinux
Level 1
Level 1
 
Posts: 2
Joined: Mon Oct 12, 2009 2:54 pm

Re: Sound system in Mint8?

Postby farna on Sat Jan 09, 2010 8:59 pm

In order to get sound over the HDMI cable you must have the SPDIF output jumpered from your motherboard or sound card to the sound card connection on the video card.
HTPC: Mint 11, Athlon II x4 (2.6 GHz), GeForce 9400, 4GB
Shop PC: XP Pro, Athlon 64 X2 (2.19 GHz), GeForce 7300GS, 2GB
Wife's PC: Win 7, Athlon II x3 (2.7GHz), GeForce 8200, 4GB
DTP-PC: Mint 12, Phenom II x4 (3.0GHz), GeForce 9600GT, 8GB
farna
Level 3
Level 3
 
Posts: 100
Joined: Sun Oct 25, 2009 6:01 pm
Location: Batesburg-Leesville, South Carolina (USA)

Re: Sound system in Mint8?

Postby autumncorvus on Sat Feb 20, 2010 11:01 am

farna wrote:In order to get sound over the HDMI cable you must have the SPDIF output jumpered from your motherboard or sound card to the sound card connection on the video card.


I don't understand this last comment. I'm also having trouble getting my monitor speakers to work, by either regular audio output or HDMI. The sound system seemed to work fine with my headphones but not with my monitor speakers, though the monitor's a high quality Samsung and brand new so should work fine. What does it mean to jumper the SPDIF output to the motherboard/sound card. Is SPDIF even relevant for monitors by other than Sony or Philips? Is my best option to just uninstall pulseaudio and go with alsa (in which case what's the proper setting for HDMI - I couldn't get the pulseaudio to work over any setting) or should I try the XCFE4 option?

My system's a SN78SH7 Shuttle box with a 3x AMD Phenom(tm) 8400 Triple-Core Processor, GeForce 8200/PCI/SSE2, HDA-Intel - HDA NVidia audio adaptor, and the monitor's a new Samsung SyncMaster 2494HM (a sweet model BTW).

I won't be able to respond for a couple days but would really appreciate help and will post back with results ASAP.

Thanks. :)
autumncorvus
Level 1
Level 1
 
Posts: 5
Joined: Sat Feb 20, 2010 9:27 am

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 3 guests