[SOLVED] Creative X-Fi just one Channel useable

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

[SOLVED] Creative X-Fi just one Channel useable

Postby mintuser on Fri Feb 19, 2010 1:05 pm

Hi !

Version: Linux Mint 8 KDE 32 Bit
I use a Creative X-Fi and it seems to be recognized properly, but the sound comes just through 2 Channels. The Problem is that every Channel (Front , Rear, Center-Sub) is listed as a single Output. (take a look at the screenshot)
How can i set it up to use all three channels ?

Last edited by mintuser on Sat Feb 20, 2010 3:12 pm, edited 1 time in total.

Linux Mint is funded by ads and donations.

Re: Creative X-Fi just one Channel useable

Postby remoulder on Fri Feb 19, 2010 6:02 pm

[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
Level 17
Level 17
Posts: 7662
Joined: Fri May 09, 2008 1:14 pm

Re: Creative X-Fi just one Channel useable

Postby mintuser on Sat Feb 20, 2010 3:11 pm

here's what to do:

Install all the pulseaudio stuff. "padevchooser" is very important.

edit /etc/pulse/daemon.conf
uncomment this line: default-sample-channels = 2 and change the 2 to 6 (for 5.1)
go to KDE Preferences -> Multimedia -> put Pulseaudio to the top
start padevchooser, go to Configuration and change the profile to your need.

some screenshots:
if padevchooser has lack of icons, take a look at this
You also have to uncomment this line:
enable-lfe-remixing = yes
otherwise the Subwoofer gets disabled, when you skip a track at amarok or something like that.

when everything is fine, you can disable the automatic startup of padevchooser, it's not needed anymore. (But you can manipulate the output-volume of every program with it, so its your choice)

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 6 guests