USB sound volume not working properly semi solved

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

USB sound volume not working properly semi solved

Postby yhtomitwebb on Sun Feb 03, 2008 8:17 am

Hi
I have linuxmint 4.
I am using a logitech usb headset and the volume adjustment is not working properly.
The problem is that the left and right volume will not lock together and the left volume keeps jumping back to 0.
I am willing to provide any information that can help to fix this.
yhtomitwebb
Level 1
Level 1
 
Posts: 27
Joined: Sun Feb 03, 2008 7:43 am

Linux Mint is funded by ads and donations.
 

Re: USB sound volume not working properly

Postby Husse on Sun Feb 03, 2008 2:20 pm

Which volume control do you use - I thought the USB unit had its own
Sound "system" and edition is also good to know
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: USB sound volume not working properly

Postby yhtomitwebb on Sun Feb 03, 2008 9:38 pm

The volume control app is: gnome-volume-control 2.20.1
When I want to use the USB headset I have to select "USB AUDIO" in the sound prefferences, nothing else works.
yhtomitwebb
Level 1
Level 1
 
Posts: 27
Joined: Sun Feb 03, 2008 7:43 am

Re: USB sound volume not working properly

Postby Husse on Mon Feb 04, 2008 1:05 pm

I have to select "USB AUDIO"

That is as expected. Please check all settings for sound you can find...
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: USB sound volume not working properly

Postby yhtomitwebb on Mon Feb 04, 2008 7:56 pm

Please check all settings for sound you can find

I am not sure what you mean here. I have looked for any settings that I might have missed and can't find anything.
Nor can I think of any setting that might change whether or not the left and right volume controls stick together properly.
Sorry if this sounds rude, especially as I am a newbie and have no real idea.
Thanks for the help.
yhtomitwebb
Level 1
Level 1
 
Posts: 27
Joined: Sun Feb 03, 2008 7:43 am

Re: USB sound volume not working properly

Postby yhtomitwebb on Tue Feb 05, 2008 4:42 am

I have now found that the channel (dono if that is the right name) that gnome-volume-control has set to the default for use from the panel is the microphone.
I have had this same problem under openSUSE 10.3 and was hoping that by switching ot linux mint I had got away from it.
It seems that one of linux's bigest problems is sound, for me anyway.
Is this a known problem or is it just me?
Should I be filing a bug report?
yhtomitwebb
Level 1
Level 1
 
Posts: 27
Joined: Sun Feb 03, 2008 7:43 am

Re: USB sound volume not working properly

Postby Husse on Tue Feb 05, 2008 7:54 am

Sound is a problem yes....
Have you found the solution, or just the cause of your problem
I asked you to check all settings because people frequently miss some setting :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: USB sound volume not working properly

Postby yhtomitwebb on Tue Feb 05, 2008 7:57 am

I have not found the cause nor the solution, I have only found the problem itself.
I may have missed a setting somewhere but, I have looked time and time again.
thanks.
yhtomitwebb
Level 1
Level 1
 
Posts: 27
Joined: Sun Feb 03, 2008 7:43 am

Re: USB sound volume not working properly

Postby Husse on Thu Feb 07, 2008 8:15 am

OK I have very little time for support this week so I'll bump this for myself and see if I find something later on
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: USB sound volume not working properly

Postby yhtomitwebb on Thu Feb 07, 2008 8:23 am

OK thank you.
I will see if I can work anything more out myself.
yhtomitwebb
Level 1
Level 1
 
Posts: 27
Joined: Sun Feb 03, 2008 7:43 am

Re: USB sound volume not working properly

Postby yhtomitwebb on Fri Feb 08, 2008 3:43 am

You were right I had missed a setting!

Previously I did not know how to select which channel (i.e. mic or speaker etc) that the volume directly on the panel controlled.
Now that I know that, I can set it to the speaker (by speaker I mean the output of the headset) rather than the mic (which I must have accidentally put it on) and then when when I adjust the volume the left and right channel stick together.
it is still all jumpy but it works and it is usable.
This is not a fix, this is a workaround that makes it usable.

Thanks for your time anyway!

Timothy.
yhtomitwebb
Level 1
Level 1
 
Posts: 27
Joined: Sun Feb 03, 2008 7:43 am

Re: USB sound volume not working properly semi solved

Postby Husse on Sat Feb 09, 2008 9:39 am

I'll leave it at that
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: JosephM and 8 guests