XServer and Sound not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

XServer and Sound not working

Postby Robinjives on Sun Mar 02, 2008 6:11 pm

Hi,
First of all, here is my system configuration:
AMD Turion X2 @1.6GHz, 1GB RAM, NVidia GeForce Go 6150 video chipset (integrated), NVidia Chipset, Nvidia High Definition Audio and Conexant Audio (it shows both types of audio in the Volume Applet so don't know which is correct), Dual booted with WinXP.

I am at wits end, the sound on my system stopped working, it used to work earlier and still works on XP. I think that it stopped working after a couples of updates with MintUpdate in the last couple of days (I had added some new repositories). When I play Audio files, Amarok does not give any error, instead the file is playing, however I cannot hear anything. There is no Mute set anywhere as far as I can see and the Volume is set to Max everywhere.
I used to get this problem occasionally before but a restart used to fix it, this time a restart is not working either.

While trying to fix my sound I ended up busting my Graphics as well. When I boot Mint I am presented with the terminal after the load bar finishes loading. I can enter the GUI by typing 'startx'. But x-server won't start on its own anymore.

Please help me on solving my Sound and X-server problem.

Thanks in Advance.
Robinjives
Level 1
Level 1
 
Posts: 30
Joined: Tue Jan 15, 2008 11:29 am

Linux Mint is funded by ads and donations.
 

Re: XServer and Sound not working

Postby Husse on Sun Mar 02, 2008 7:37 pm

What did you do?
Sound and the X server are not related....
Do you get any error message or does it just refuse to start?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: XServer and Sound not working

Postby Robinjives on Sun Mar 02, 2008 8:04 pm

Husse wrote:What did you do?
Sound and the X server are not related....
Do you get any error message or does it just refuse to start?


I was trying to fix my sound, so I reinstalled the ALSA Mixer, not that it worked. When I did the reboot I pressed the esc key while the linux progress bar was going on. Next thing I know I am presented with the terminal instead of the GUI.

I am not getting any error message, at least not for sound. For GUI when I press Ctrl+Alt+F8 it shows "Running local boot scripts (/etc/rc.local)", that is also where I get stuck if I do not run startx from the terminal.
Robinjives
Level 1
Level 1
 
Posts: 30
Joined: Tue Jan 15, 2008 11:29 am

Re: XServer and Sound not working

Postby Husse on Mon Mar 03, 2008 7:08 am

Oh, I read you like you could not start X at all.
The places to look are /boot/grub/menu.lst and /etc/X11/xorg.conf in the first place
If you are uncertain if they are OK you can post them
I'm running out of time so I'll have to leave it at that
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: XServer and Sound not working

Postby Robinjives on Mon Mar 03, 2008 6:57 pm

Edit by husse I removed the duplicate post//
Husse wrote:Oh, I read you like you could not start X at all.
The places to look are /boot/grub/menu.lst and /etc/X11/xorg.conf in the first place
If you are uncertain if they are OK you can post them
I'm running out of time so I'll have to leave it at that


Hi Husse,
Here are the entries from menu.lst and xorg.conf:
menu.lst:

Code: Select all
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
default      0

gfxmenu=/etc/grub/message.mint

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      10

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/sda8 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,7)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## ## End Default Options ##

title      Linux Mint, kernel 2.6.22-14-generic
root      (hd0,7)
kernel      /boot/vmlinuz-2.6.22-14-generic root=/dev/sda8 ro quiet splash
initrd      /boot/initrd.img-2.6.22-14-generic
boot

title      Linux Mint, kernel 2.6.22-14-generic (recovery mode)
root      (hd0,7)
kernel      /boot/vmlinuz-2.6.22-14-generic root=/dev/sda8 ro single
initrd      /boot/initrd.img-2.6.22-14-generic
boot

title      Linux Mint, kernel memtest86+
root      (hd0,7)
kernel      /boot/memtest86+.bin
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title      Microsoft Windows XP Professional
root      (hd0,0)
savedefault
makeactive
chainloader   +1



xorg.conf:

Code: Select all
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"   "/dev/input/mice"
   Option      "Protocol"   "ImPS/2"
   Option      "ZAxisMapping"   "4 5"
EndSection

Section "InputDevice"
   Identifier   "Synaptics Touchpad"
   Driver      "synaptics"
   Option      "SendCoreEvents"   "true"
   Option      "Device"   "/dev/psaux"
   Option      "Protocol"   "auto-dev"
   Option      "HorizEdgeScroll"   "0"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "stylus"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "eraser"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "cursor"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "nVidia Corporation C51 [Geforce 6150 Go]"
   Driver      "nvidia"
   Busid      "PCI:0:5:0"
   Option      "AddARGBVisuals"   "True"
   Option      "AddARGBGLXVisuals"   "True"
   Option      "NoLogo"   "True"
EndSection

Section "Monitor"
   Identifier   "Standardbildschirm"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "nVidia Corporation C51 [Geforce 6150 Go]"
   Monitor      "Standardbildschirm"
   Defaultdepth   24
   SubSection "Display"
      Modes      "1280x800"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen "Default Screen"
   Inputdevice   "Generic Keyboard"
   Inputdevice   "Configured Mouse"
   
   # Uncomment if you have a wacom tablet
   #   InputDevice     "stylus"   "SendCoreEvents"
   #   InputDevice     "cursor"   "SendCoreEvents"
   #   InputDevice     "eraser"   "SendCoreEvents"
   Inputdevice   "Synaptics Touchpad"
EndSection
Section "Module"
   Load      "glx"
EndSection


Thanks a lot for your effort.
Robinjives
Level 1
Level 1
 
Posts: 30
Joined: Tue Jan 15, 2008 11:29 am

Re: XServer and Sound not working

Postby MagnusB on Tue Mar 04, 2008 6:56 am

menu.lst looks ok, xorg.conf looks ok as well. You might have to check if the correct modules are loaded:
Code: Select all
lsmod | grep nv

Code: Select all
lsmod | grep ^snd

You could also change Driver "nvidia" to Driver "nv" or "vesa" I don't remember the correct drivers for nVidia HD audio, but I think it is just rebranded Intel chipset, if I am not mistaken...
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: XServer and Sound not working

Postby Robinjives on Tue Mar 04, 2008 6:34 pm

Hi,
Here is the output from lsmod | grep nv:
Code: Select all
nvidia               6221648  36
agpgart                35016  1 nvidia
i2c_core               26112  2 nvidia,i2c_nforce2
sata_nv                20612  7
libata                125168  2 ata_generic,sata_nv


The output from lsmod | grep snd is as follows:
Code: Select all
snd_hda_intel         263712  1
snd_pcm_oss            44672  0
snd_mixer_oss          17664  1 snd_pcm_oss
snd_pcm                80388  2 snd_hda_intel,snd_pcm_oss
snd_seq_dummy           4740  0
snd_seq_oss            33152  0
snd_seq_midi            9600  0
snd_rawmidi            25728  1 snd_seq_midi
snd_seq_midi_event      8448  2 snd_seq_oss,snd_seq_midi
snd_seq                53232  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              24324  2 snd_pcm,snd_seq
snd_seq_device          9228  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    54660  11 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               8800  1 snd
snd_page_alloc         11400  2 snd_hda_intel,snd_pcm


How do I change the driver, is it just a change in an entry somewhere or something else?
Robinjives
Level 1
Level 1
 
Posts: 30
Joined: Tue Jan 15, 2008 11:29 am

Re: XServer and Sound not working

Postby MagnusB on Tue Mar 04, 2008 6:49 pm

You have the right modules loaded, looks like it though. I am guessing we have the same audio card:
lspci wrote:Audio device: nVidia Corporation MCP65 High Definition Audio (rev a1)

lsmod | grep snd wrote:snd_seq_oss 29440 0
snd_seq_midi_event 6528 1 snd_seq_oss
snd_seq 47056 4 snd_seq_oss,snd_seq_midi_event
snd_seq_device 6924 2 snd_seq_oss,snd_seq
snd_hda_intel 289952 1
snd_hwdep 7300 1 snd_hda_intel
snd_pcm_oss 37024 0
snd_pcm 68996 2 snd_hda_intel,snd_pcm_oss
snd_timer 19204 2 snd_seq,snd_pcm
snd_page_alloc 8072 2 snd_hda_intel,snd_pcm
snd_mixer_oss 14464 1 snd_pcm_oss
snd 44772 11 snd_seq_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_hwdep,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
soundcore 6368 1 snd

Last one is from Arch though, might be some different names in Mint.
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: XServer and Sound not working

Postby Robinjives on Tue Mar 04, 2008 7:38 pm

Hi,
My audio device is :
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

There seems to be a difference in the model number.
Any suggestion on what I should do?
Robinjives
Level 1
Level 1
 
Posts: 30
Joined: Tue Jan 15, 2008 11:29 am

Re: XServer and Sound not working

Postby MagnusB on Wed Mar 05, 2008 10:23 am

I was thinking another angle, if it locks at rc.local, I think that is what loads modules and daemons. Can you start failsafe Mint? If so, what happens if you try to start alsamixer:
Code: Select all
alsamixer
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: XServer and Sound not working

Postby Robinjives on Wed Mar 05, 2008 7:16 pm

MagnusB wrote:I was thinking another angle, if it locks at rc.local, I think that is what loads modules and daemons. Can you start failsafe Mint? If so, what happens if you try to start alsamixer:
Code: Select all
alsamixer


Hi,
Even in failsafe mode it locks at rc.local, but I am able to start alsamixer no problem (after getting another terminal with CTRL+ALT+F2). I still have to manually start the x-server with 'startx'.
On a brighter note my sound started working again without doing anything. Anyone got an explanation for that since that also means that it can stop working like before?
Robinjives
Level 1
Level 1
 
Posts: 30
Joined: Tue Jan 15, 2008 11:29 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 12 guests