Can't connect IBM T61- Huawei EC321 PCMCIA for CDMA network

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Can't connect IBM T61- Huawei EC321 PCMCIA for CDMA network

Postby coolrat45 on Wed Mar 05, 2008 10:01 pm

Hi!

I just got an IBM T61 and a Huawei EC321 PCMCIA CDMA network data card so that I can connect to the internet.
I'm running a dual boot system with XP.
My Linux is Linux MINT KDE Community edition.

The problem: it doesn't work.
I have no idea why.

Many links on the internet discuss this card and say it usually works 'out of the box'. Just plug it in and it works.
http://spo0nman.blogspot.com/2006/08/hu ... linux.html
http://osdir.com/ml/user-groups.linux.b ... 00011.html

But my experience has not been good. Im not even sure how to open the connection.
I tried configuring KPPP, but it will never connect.

I configured it like this:

ACCOUNTS tab
Dial Tab:
Connection Name: Huawei
Phone number: #777
Authentication: PAP/CHAP
Callback type: none

MODEMS tab
Modem name: Huawei
Modem device: /dev/tty/USB0
Hardware: Hardware (CRTSCTS)
Line termination: CR
Connection speed: 921600
Modem timeout: 60 sec

The Log-in Script Debug window displays:
ATZ OK
ATM1L1
OK
ATDT#777
CONNECT 230400


I wait a few minutes then an error message (and that annoying GONG-sound) announces: "Time expired for the KPPP device to come up"

When I increased the modem connection speed to 140 sec, I got this error:

The PPPD Daemon died unexpectedly
Exit status 16
See 'map PPPD' for an explanation of the error


Can someone PLEASE help me to get this card working?
I'm sure there is a very easy set of TERMINAL commands that will fix all this. I suspect that the instructions at http://spo0nman.blogspot.com/2006/08/hu ... linux.html
are quite good.. I just don't know how to follow them. Not clear enough for me- I'm too new to this. I tried following those instructions, but it constantly failed. Perhaps because I'm using KDE and those instructions were designed for GNOME system? :?

I'd greatly appreciate help on this! :D
coolrat45
 

Linux Mint is funded by ads and donations.
 

Re: Can't connect IBM T61- Huawei EC321 PCMCIA for CDMA network

Postby Husse on Sat Mar 08, 2008 4:51 pm

Maybe the info in the link you followed was to old... it was from 2006
I've found a topic that may help you
http://ubuntuforums.org/showthread.php?t=208749
In post #9 he writes
If it is Huawei EC321 you don't need any driver. Just follow the instructions on this thread.

This guy (kagashe) has written extensively about this subject in the Ubuntu forums
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 16 guests