[Solved] Mint 13 Cinnamon using wrong sound output device

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

[Solved] Mint 13 Cinnamon using wrong sound output device

Postby Rua on Thu May 24, 2012 8:49 am

My graphics card has its own HDMI output device for sound and for some reason Mint insists on using that. When I go to the Pulseaudio volume control I see that it is set as fallback device. I can set my regular 'built in audio' as fallback and then the sound works fine. But when I restart, it just defaults back to the HDMI sound again. Strangely the startup chime does sound, but no programs after that get sound until I fix it. Does anyone know how I can change this so it always uses my built in sound by default?
Last edited by Rua on Thu May 31, 2012 7:17 am, edited 1 time in total.
Rua
Level 3
Level 3
 
Posts: 158
Joined: Sat Sep 17, 2011 11:09 am
Location: Netherlands

Linux Mint is funded by ads and donations.
 

Re: Mint 13 Cinnamon using wrong sound output device

Postby Rua on Sat May 26, 2012 7:44 am

Can anyone help me with this? It's getting rather frustrating for me...
Rua
Level 3
Level 3
 
Posts: 158
Joined: Sat Sep 17, 2011 11:09 am
Location: Netherlands

Re: Mint 13 Cinnamon using wrong sound output device

Postby stratus_ss on Sat May 26, 2012 8:54 am

Can you post some screens of your "Sound" application so that we can see what settings work and what the defaults are.

Additionally we can force it, but that should be a last resort.
There is a file you can create /etc/asound.conf which will always be respected by the system. I use this for systems where I want SPDIF to be the output source
stratus_ss
Level 4
Level 4
 
Posts: 270
Joined: Fri May 25, 2012 5:22 pm

Re: Mint 13 Cinnamon using wrong sound output device

Postby Rua on Sat May 26, 2012 4:31 pm

I'm not sure what sound application you mean. There is both the pulseaudio volume control and the sound settings that appears when I click on the speaker icon in the taskbar. I did notice that when I click on the speaker and then 'output device' it shows two options:

- Built-in audio analog stereo
- Juniper HDMI Audio [Radeon HD 5700 series] Digital Stereo (HDMI)

After the computer starts up, the second one is marked off and selected, so it uses that as the output device. If I click on the first option to select that, all the sound is fine, but it doesn't remember what I selected after restarting, it just goes back to the HDMI audio again.
Rua
Level 3
Level 3
 
Posts: 158
Joined: Sat Sep 17, 2011 11:09 am
Location: Netherlands

Re: Mint 13 Cinnamon using wrong sound output device

Postby bkovacs on Mon May 28, 2012 9:00 am

Same here!. I need to make "Built in Analog Stereo" as my default. But everytime I reboot it goes back to GF104 sound device. Ubuntu 12.04 doesn't have this problem. Is there an application that allows me to set default card with pulse audio, that just works. Or is this a kernel issue.
After I open sound settings in taskbar.
Output Devices
Built in Analog Stereo
*GF104 High Definition Audio Controller Digital Stero (HDMI)

Reboot and get everytime. Just this sound device, before opening sound devices. Even after using paucontrol.
*GF104 High Definition Audio Controller Digital Stero (HDMI)

Any ideas on how to fix this Clem?.
bkovacs
Level 1
Level 1
 
Posts: 29
Joined: Thu Sep 22, 2011 1:47 pm

Re: Mint 13 Cinnamon using wrong sound output device

Postby stratus_ss on Mon May 28, 2012 9:27 am

so for example if you create /etc/asound.conf with the following:

Code: Select all
pcm.!default {
type plug
slave {
pcm "spdif"
format S16_LE
}
}


It will default to the spdif, if you substitute "hdmi" it will default to hdmi, though I have never used this method for analoge, I assume it would work, though I am not 100% off the top of my head what you would put in as the pcm
stratus_ss
Level 4
Level 4
 
Posts: 270
Joined: Fri May 25, 2012 5:22 pm

Re: Mint 13 Cinnamon using wrong sound output device

Postby augusto_mint on Wed May 30, 2012 2:32 pm

I had the same problem and I solved it by disabling the HDMI device in the Hardware tab. Since I didn't need to use the HDMI that was ok. Not sure it's your case...

Image
augusto_mint
Level 1
Level 1
 
Posts: 1
Joined: Wed May 30, 2012 2:07 pm

Re: Mint 13 Cinnamon using wrong sound output device

Postby bkovacs on Wed May 30, 2012 6:19 pm

augusto_mint wrote:I had the same problem and I solved it by disabling the HDMI device in the Hardware tab. Since I didn't need to use the HDMI that was ok. Not sure it's your case...

Image


That did it augusto. Thanks!. Correct device works on reboot now!.
bkovacs
Level 1
Level 1
 
Posts: 29
Joined: Thu Sep 22, 2011 1:47 pm

Re: Mint 13 Cinnamon using wrong sound output device

Postby Rua on Wed May 30, 2012 6:28 pm

It works for me now too, thank you!
Rua
Level 3
Level 3
 
Posts: 158
Joined: Sat Sep 17, 2011 11:09 am
Location: Netherlands

Re: Mint 13 Cinnamon using wrong sound output device

Postby HappyLinux on Thu May 31, 2012 5:30 am

I was just browsing the forums and accidentally came across this thread.

I have been having a similar problem in that my sound settings like to switch from my built-in sound on the motherboard to GF106 controller of my graphics card at random times. For example, I could be watching/listening to something, whether it be a video off my HDD or a youtube video, or even just a simple mp3 file, part way through the sound vanishes. A quick look at my output devices shows that it's switch to the GF106.

Hopefully, with the help of this thread, the problem will be solved.
Dual-Boot Mint 17 64bit with Win8.1 64bit Update 1 at least
Core i5-4430 3GHz Quad-Core
8GB RAM
GeForce GTX 650 2GB
OnBoard Audio
HappyLinux
Level 3
Level 3
 
Posts: 198
Joined: Wed May 30, 2012 3:48 am
Location: Earth

Re: Mint 13 Cinnamon using wrong sound output device

Postby bimsebasse on Thu May 31, 2012 5:36 am

For what's it worth this happened to me regularly in Mint 12 and still does in Mint 13, though much less often - gotten so used to selecting the proper output device in sound settings when the OS for some reason decided to mix things up a little. Always wonder how many users are stranded with no sound and no idea what goes wrong and how to fix it when this happens to them, it can't be pretty numbers.

EDIT: gonna try augusto's off solution :D
Thank you for this thread. That’s all I can say. You most definitely have made this forum into something special. You clearly know what you are doing, you’ve covered so many bases. Thanks!
User avatar
bimsebasse
Level 7
Level 7
 
Posts: 1709
Joined: Fri Nov 11, 2011 10:21 am
Location: Scandinavia

Re: [Solved] Mint 13 Cinnamon using wrong sound output devic

Postby rzpkvs on Thu May 31, 2012 8:07 pm

@ augusto_mint

i had the same prob thanks for sharing. i'm good to go
rzpkvs
Level 1
Level 1
 
Posts: 3
Joined: Fri Jan 20, 2012 6:44 pm

Re: [Solved] Mint 13 Cinnamon using wrong sound output devic

Postby Berkah on Thu Jun 14, 2012 10:13 pm

Thanks - workes for me, too! (LM 13 Mate & NVidia G520M)
User avatar
Berkah
Level 2
Level 2
 
Posts: 68
Joined: Thu Dec 10, 2009 6:04 am

Re: [Solved] Mint 13 Cinnamon using wrong sound output devic

Postby HappyLinux on Fri Jun 15, 2012 3:16 pm

It's been a while since I last posted in this thread. I tried the above solution, and I haven't had a single problem yet. So the problem is solved for me.
Dual-Boot Mint 17 64bit with Win8.1 64bit Update 1 at least
Core i5-4430 3GHz Quad-Core
8GB RAM
GeForce GTX 650 2GB
OnBoard Audio
HappyLinux
Level 3
Level 3
 
Posts: 198
Joined: Wed May 30, 2012 3:48 am
Location: Earth

Re: [Solved] Mint 13 Cinnamon using wrong sound output devic

Postby chuck_taylor on Mon Jun 25, 2012 3:13 am

Thanks much. Works here as well LM 13 cinnamon + nvidia gtx 560
chuck_taylor
Level 1
Level 1
 
Posts: 1
Joined: Mon Jun 25, 2012 3:09 am

Re: [Solved] Mint 13 Cinnamon using wrong sound output devic

Postby baltorouberol on Sat Jul 28, 2012 5:31 am

Thanks, did the trick for me too!

LM 12 MATE + nVidia GT218 [NVS 3100M]
baltorouberol
Level 1
Level 1
 
Posts: 2
Joined: Sat Jul 28, 2012 5:20 am

Re: [Solved] Mint 13 Cinnamon using wrong sound output devic

Postby clickclick on Sat Aug 18, 2012 3:34 pm

I am curious, did anybody try using the HDMI from the card for audio? Because I basically have the inverse problem. I want to use the HDMI from the card (GTX 570), but when it is selected for output in settings, I get nothing. Anyone have any ideas?
clickclick
Level 1
Level 1
 
Posts: 7
Joined: Sat Aug 18, 2012 3:16 pm

Re: [Solved] Mint 13 Cinnamon using wrong sound output devic

Postby Total_Blue on Fri Aug 24, 2012 4:12 am

clickclick wrote:I am curious, did anybody try using the HDMI from the card for audio? Because I basically have the inverse problem. I want to use the HDMI from the card (GTX 570), but when it is selected for output in settings, I get nothing. Anyone have any ideas?


HI Clickclick, if the original Poster has marked the thread as Solved, it would be better to start a new thread to have more of a chance of getting help.

That being said, if you have an AMD (ATI) Radeon with HDMI, I had a similar issue with my Laptop and got the HDMI sound working by following the advice at http://askubuntu.com/questions/67113/fast-video-playback-with-no-sound.
Total_Blue
Level 2
Level 2
 
Posts: 50
Joined: Wed Sep 07, 2011 5:01 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 22 guests