Toshiba sound issue (strange) HELP Please solved

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Toshiba sound issue (strange) HELP Please solved

Postby spas87 on Tue Mar 18, 2008 4:01 pm

I'm using laptop Toshiba satellite a100-756 psaa9e but Ive got problems with the sound its like on 20% compared to volume of sound in windows
vista/xp which I have used and the microphone does not work at all as well any suggestions for driver change or anything like this to fix that

I'm using Linux mint 4 Main Edition Gnome and i have it installed and updated and in the Restricted Drivers i got ATI accelerated graphic driver and Intel(R) Pro/Wirles 3945 Network connection for Linux

Thanks in advance

if you need any more info from any kind will be pleased to provide
Last edited by spas87 on Tue Apr 01, 2008 1:28 pm, edited 1 time in total.
Image
spas87
Level 2
Level 2
 
Posts: 73
Joined: Tue Mar 18, 2008 10:21 am

Linux Mint is funded by ads and donations.
 

Re: Toshiba sound driver issue (probably) HELP

Postby Husse on Wed Mar 19, 2008 7:37 am

Provided you've got the (infamous) hda intel chip try this
Edit the "/etc/modprobe.d/alsa-base" file adding at the end
Code: Select all
options snd-hda-intel index=0 model=toshiba

You may have to specify the toshiba model
Search for
Code: Select all
options snd-hda-intel index=0 model=toshiba

and your model
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Toshiba sound driver issue (probably) HELP

Postby spas87 on Thu Mar 20, 2008 4:28 pm

Code: Select all
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388


that is what is writing when i try to save the changes in the file sory but Im newbie in using linux and writing any comand lines if you know how please give me full descriptions sorry if sounds stupid :-)
You do not have the necessary permissions to save the file. Please, check that you typed the location correctly and try again.


that is all the content in the file which you told me cant find this type of thing please have look and sujest something thanks in advance man
Image
spas87
Level 2
Level 2
 
Posts: 73
Joined: Tue Mar 18, 2008 10:21 am

Re: Toshiba sound driver issue (probably) HELP

Postby Husse on Fri Mar 21, 2008 11:55 am

When you do things outside your /home you need to be root and for this you have the mighty sudo.
Code: Select all
gksudo gedit /etc/modprobe.d/alsa-base

for KDE
Code: Select all
kdesu kate /etc/modprobe.d/alsa-base
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Toshiba sound driver issue (probably) HELP

Postby jdgiotta on Thu Mar 27, 2008 1:25 pm

This worked for my A105
http://ubuntuforums.org/showthread.php?t=416207

Toshiba sound is a big topic apparently.
High-five to those who read this.
psn:jdgiotta
jdgiotta
Level 1
Level 1
 
Posts: 37
Joined: Sat Mar 22, 2008 4:04 pm
Location: Virginia, US

Re: Toshiba sound driver issue (probably) HELP

Postby spas87 on Tue Apr 01, 2008 1:26 pm

Thanks I've tried bout solutions but non of them seems to work
"intriguing" part is that i got sound wen i turn it to max but its realy quiet hardly to hear is that mean that the drivers are fine and its something else but don't know what can be.
If you have any other suggestions which you think may help will be realy good because I really like linux Mint but that laptop piss me of : :twisted:

:lol: :lol: :lol:
Image
spas87
Level 2
Level 2
 
Posts: 73
Joined: Tue Mar 18, 2008 10:21 am

Re: Toshiba sound issue (strange) HELP Please

Postby spas87 on Tue Apr 01, 2008 2:49 pm

I've Just found that its got a bit improvement it sounds a bit louder when I try on OSS Open Sound System but its still really quiet :mrgreen:
Image
spas87
Level 2
Level 2
 
Posts: 73
Joined: Tue Mar 18, 2008 10:21 am

Re: Toshiba sound issue (strange) HELP Please

Postby spas87 on Tue Apr 01, 2008 4:43 pm

I've found solution evryone whit low sound to try this
Edit the "/etc/modprobe.d/alsa-base" file adding at the end
Code: Select all
options snd-hda-intel model=3stack

for more info and the forum which I've got the solution is
https://answers.launchpad.net/ubuntu/+s ... stion/7175
Image
spas87
Level 2
Level 2
 
Posts: 73
Joined: Tue Mar 18, 2008 10:21 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 8 guests