Sound issues w/intel HD audio controller

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Sound issues w/intel HD audio controller

Postby homunculus on Sun Mar 30, 2008 7:22 pm

I know this is a hashed and rehashed topic but...I have a Compaq C751NR and it has one of the infamous Intel 82801H audio chips. My problem is the 'my headphones work but my speakers don't turn off' issue. I've looked around and a lot of the cures apply to previous revisions of this chip and the 82801G. I'm just wondering if anyone has come across a thread that has a fix for this that's worked for this chip. It's seems a lot of these threads are about fixing complete lack of sound and I haven't seen any real fixes for the speakers not turning off. Any help would be greatly appreciated.
homunculus
Level 1
Level 1
 
Posts: 7
Joined: Sun Mar 23, 2008 7:49 am
Location: US

Linux Mint is funded by ads and donations.
 

Re: Sound issues w/intel HD audio controller

Postby Husse on Tue Apr 01, 2008 1:03 pm

I think there is a Compaq counterpart to this fix for Toshiba
Edit the "/etc/modprobe.d/alsa-base" file adding at the end
Code: Select all
options snd-hda-intel index=0 model=toshiba

I think you could use
Code: Select all
options snd-hda-intel index=0 model=compaq

This is taken from memory, so I may be wrong, but it is used for several different models and brands
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Sound issues w/intel HD audio controller

Postby Gilly on Sat Apr 05, 2008 10:00 am

I have exactly the same issue as you, except I have a Samsung R70 laptop. I tried the above fix (replacing "Toshiba" with "samsung") but to no avail. Anyone found a fix to this?
Gilly
 

Re: Sound issues w/intel HD audio controller

Postby Gilly on Thu Apr 10, 2008 1:28 pm

I didn't manage to find a solution, but I did find a cheap external sound card in the Speedlink SL-8850. I just plugged it into the USB slot, went into Control Centre > Sound, and changed the various drop down menu options to "USB Audio". My laptop speakers have been silenced =].
Gilly
 


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 8 guests