Camera showing on the USB bus, but not on the desktop

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Camera showing on the USB bus, but not on the desktop

Postby mingle on Wed Sep 26, 2012 5:36 am

Hi,

I tried connecting my oldish Canon IXUS 400 camera to my LM13 Xfce system, but it didn't seem to be recognised.

I tried seeing if it was visible on the USB bus with the "lsusb" command and it seems to be there (see below),
but it's not showing up on the desktop or in the file-manager.

Does anyone have any idea how I can access the camera?

Cheers,

Mike.

-----
mintuser@ThinkCentre-A57 ~ $ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 046d:0825 Logitech, Inc. Webcam C270
Bus 002 Device 002: ID 413c:1003 Dell Computer Corp. Keyboard Hub
Bus 003 Device 002: ID 04b3:310d IBM Corp.
Bus 002 Device 003: ID 413c:2010 Dell Computer Corp. Keyboard
Bus 006 Device 004: ID 04a9:30c0 Canon, Inc. Digital IXUS 30 (PTP mode) / PowerShot SD200 (PTP mode)
mintuser@ThinkCentre-A57 ~ $
-----
User avatar
mingle
Level 1
Level 1
 
Posts: 27
Joined: Thu May 24, 2012 9:58 pm

Linux Mint is funded by ads and donations.
 

Re: Camera showing on the USB bus, but not on the desktop

Postby AlbertP on Wed Sep 26, 2012 6:35 am

The USB connection of the camera appears to be in "PTP mode". You can perhaps get gtkam from the Software Manager to use the camera, or set it to USB Mass Storage mode. Maybe you have a cardreader in which the camera's memory card can be put.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6515
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Camera showing on the USB bus, but not on the desktop

Postby NOB on Sun Sep 30, 2012 4:40 am

Hi

it's the same over here (Mint 13 Xfce) with a different Canon camera.
It works well with Ubuntu 12.04.1 as tested with my friends computer.
So, Mint must handle the cameras in a different way or the udev configuration files
and udev itself is again brain-dead.

The other problem with the Nokia CS-10, CS-15 and CS-17 etc. pp. UMTS stick do show
in Ubuntu 12.04 as well.
Fortunately, much more people are using Ubuntu 12.04, so the work-around mentioned in the forums there
did work with Mint 13 Xfce.

I wonder whether users of other Mint 13 versions (KDE, Mate, ...) experience the same problem.

I simply can't get my camera to work.
Installation of gphoto2 shows that the camera is recognized but that's about it.

Added:
Just wanted to mention, that "lsusb" just outputs "Canon Digital Camera" nothing about PTP mode or something like that.

Cheers

Norbert.
NOB
Level 1
Level 1
 
Posts: 19
Joined: Sun Sep 30, 2012 4:31 am

[SOLVED] Camera showing on the USB bus, but not on the deskt

Postby NOB on Wed Nov 14, 2012 4:49 pm

Hi

I finally managed to get my Canon Powershot camera recognized !

For short:

* Install gigolo

* Enable handling of removable media with thunar (Tab "camera") specifying /usr/bin/gigolo as program to open

Have fun

If I manage to upload a tutorial, I have one prepared with
screenshots.

HTH

Norbert.
NOB
Level 1
Level 1
 
Posts: 19
Joined: Sun Sep 30, 2012 4:31 am


Return to Hardware Support

Who is online

Users browsing this forum: Pierre and 14 guests