USB Headset mic low volume on Linux Mint 12

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

USB Headset mic low volume on Linux Mint 12

Postby mintmemory on Wed Oct 03, 2012 2:34 pm

I've been trying anything to see if I can fix this, but... I use a HP USB headset, and the mic is only picking up a very faint level of sound. It was working up to yesterday before I ran the update manager. Something in the updates caused a change, I don't know what, and now my mic is useless for stuff like Skype.

Code: Select all
$ head -n 1 /proc/asound/card*/codec#*
Codec: Realtek ALC889


Code: Select all
$ cat /proc/modules
joydev 17693 0 - Live 0x0000000000000000
wacom 37975 0 - Live 0x0000000000000000
nls_iso8859_1 12713 0 - Live 0x0000000000000000
nls_cp437 16991 0 - Live 0x0000000000000000
vfat 17585 0 - Live 0x0000000000000000
fat 61475 1 vfat, Live 0x0000000000000000
bnep 18436 2 - Live 0x0000000000000000
rfcomm 47946 0 - Live 0x0000000000000000
bluetooth 166150 10 bnep,rfcomm, Live 0x0000000000000000
binfmt_misc 17540 1 - Live 0x0000000000000000
snd_hda_codec_realtek 330815 1 - Live 0x0000000000000000
lm63 14398 0 - Live 0x0000000000000000
snd_usb_audio 118122 2 - Live 0x0000000000000000
snd_hda_intel 33390 2 - Live 0x0000000000000000
snd_hda_codec 104968 2 snd_hda_codec_realtek,snd_hda_intel, Live 0x0000000000000000
radeon 1016612 2 - Live 0x0000000000000000
snd_pcm 96714 3 snd_usb_audio,snd_hda_intel,snd_hda_codec, Live 0x0000000000000000
snd_hwdep 13668 2 snd_usb_audio,snd_hda_codec, Live 0x0000000000000000
psmouse 73882 0 - Live 0x0000000000000000
usb_storage 57900 0 - Live 0x0000000000000000
uas 18181 0 - Live 0x0000000000000000
snd_usbmidi_lib 25371 1 snd_usb_audio, Live 0x0000000000000000
snd_seq_midi 13324 0 - Live 0x0000000000000000
snd_rawmidi 30547 2 snd_usbmidi_lib,snd_seq_midi, Live 0x0000000000000000
serio_raw 13166 0 - Live 0x0000000000000000
snd_seq_midi_event 14899 1 snd_seq_midi, Live 0x0000000000000000
snd_seq 61896 2 snd_seq_midi,snd_seq_midi_event, Live 0x0000000000000000
mei 41480 0 - Live 0x0000000000000000 (C)
ttm 76805 1 radeon, Live 0x0000000000000000
drm_kms_helper 42558 1 radeon, Live 0x0000000000000000
drm 236290 4 radeon,ttm,drm_kms_helper, Live 0x0000000000000000
snd_timer 29991 2 snd_pcm,snd_seq, Live 0x0000000000000000
snd_seq_device 14540 3 snd_seq_midi,snd_rawmidi,snd_seq, Live 0x0000000000000000
snd 68266 19 snd_hda_codec_realtek,snd_usb_audio,snd_hda_intel,snd_hda_codec,snd_pcm,snd_hwdep,snd_usbmidi_lib,snd_rawmidi,snd_seq,snd_timer,snd_seq_device, Live 0x0000000000000000
soundcore 12680 1 snd, Live 0x0000000000000000
snd_page_alloc 18529 2 snd_hda_intel,snd_pcm, Live 0x0000000000000000
i2c_algo_bit 13423 1 radeon, Live 0x0000000000000000
ppdev 17113 0 - Live 0x0000000000000000
parport_pc 36962 1 - Live 0x0000000000000000
lp 17799 0 - Live 0x0000000000000000
parport 46562 3 ppdev,parport_pc,lp, Live 0x0000000000000000
usbhid 47198 0 - Live 0x0000000000000000
hid 95463 1 usbhid, Live 0x0000000000000000
pata_jmicron 12747 0 - Live 0x0000000000000000
r8169 52788 0 - Live 0x0000000000000000


Code: Select all
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC889 Digital [ALC889 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Headset [HP Digital Stereo Headset], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


I've tried everything I can think of at this point. Actual playback works fine. I've gone through the Alsamixer and made sure everything is unmuted and turned up to full. The mic boost does have an effect, but it's tiny.

Is there anything else I can check, any more diagnostics I can run?
mintmemory
Level 1
Level 1
 
Posts: 9
Joined: Mon Jul 09, 2012 2:54 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: Google [Bot], groover and 23 guests