Trackpad mouse stops working (ish), psmouse not responsive

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Trackpad mouse stops working (ish), psmouse not responsive

Postby dirawz on Thu Oct 04, 2012 5:34 pm

I'm on a Macbook 13" 2009 running Linux Mint 13 Cinnamon (64bit). I've noticed that when I open my laptop after shutting it (going into suspend), the mouse on my trackpad stops working normally. I can only move it while holding down to click, and it clicks on whatever I'm hovering over once I release the click, sort of like it's constantly dragging.

I think it has something to do with psmouse - I tried performing "sudo rmmod psmouse" when it was stuck, but got this in return: "module psmouse does not exist in proc/modules." When the mouse is working, I can "sudo rmmod psmouse" (which doesn't do anything, but doesn't return an error) and "sudo modprobe psmouse" without errors. The problem is solved by me logging out and back in, which is kind of a pain without use of the keyboard.

I've also tried to reenable the trackpad with gpointing-device-settings, but it doesn't help because the trackpad isn't actually disabled.

Can anyone help?
Level 1
Level 1
Posts: 1
Joined: Wed Oct 03, 2012 11:57 am

Linux Mint is funded by ads and donations.

Return to Hardware Support

Who is online

Users browsing this forum: Google [Bot], lxkraken and 10 guests