SOLVED (sort of): USB disk user rights

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

SOLVED (sort of): USB disk user rights

Postby lanrun on Thu Apr 24, 2008 7:48 am

I have a USB disk that I recently formatted in Daryna main to the ext3 filesystem. Whenever I plug it in, Daryna automounts it and its icon appears on the Gnome desktop (with the name disk). However, only root has permission to write to it. Obviously, this isn't very useful to me. How can I make it so that I have full access to USB disks which are automatically mounted?
Last edited by lanrun on Fri Apr 25, 2008 8:23 am, edited 1 time in total.
lanrun
Level 3
Level 3
 
Posts: 158
Joined: Tue Oct 23, 2007 7:31 am
Location: Lillehammer - Norway

Linux Mint is funded by ads and donations.
 

Re: USB disk user rights

Postby Husse on Thu Apr 24, 2008 4:06 pm

This confuses me - I thought you'd get permissions...
One way is to have the disk in fstab mounted with a line like this
Code: Select all
/dev/sdb1   /media/usb auto noauto,owner,kuzu 0 0

I don't know what kuzu is but it seems to be something to use for USB disks
You also have to find out which "/dev" the USB disk is - use gparted
You also have to make a folder for the mount point
Code: Select all
sudo mkdir /media/usb
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: USB disk user rights

Postby lanrun on Fri Apr 25, 2008 8:22 am

Husse wrote:This confuses me - I thought you'd get permissions...
One way is to have the disk in fstab mounted with a line like this
Code: Select all
/dev/sdb1   /media/usb auto noauto,owner,kuzu 0 0

I don't know what kuzu is but it seems to be something to use for USB disks
You also have to find out which "/dev" the USB disk is - use gparted
You also have to make a folder for the mount point
Code: Select all
sudo mkdir /media/usb


I don't know why it is only root that gets write permissions and other get only read permissions.

What I tried was changing the owner of the USB disk to myusername with the chown command in the terminal, sudo chown -hR myusername /media/disk.
That worked.
The USB disk automounts whenever I plug it in, that is according to settings in the control centre.
lanrun
Level 3
Level 3
 
Posts: 158
Joined: Tue Oct 23, 2007 7:31 am
Location: Lillehammer - Norway


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 19 guests