T.I. 5 in 1 Card Reader not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

T.I. 5 in 1 Card Reader not working

Postby Zen Mod on Mon Apr 28, 2008 12:50 am

Found this to be a problem. Found several workarounds but none of them helped on my Acer Extensa 5220. It seems to be present when I type $ lspci I get the following report:

00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
04:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)
0f:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
0f:06.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
0f:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
0f:06.3 Generic system peripheral [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller

The bold line appears to be the thing I have to fix, but I can't seem to be able or skillful enough to make it work. I have several xD cards for my Fuji S5600 (32M, 128M & 1G) all different make, none of them recognized by the system when inserted. Tried as one suggested to leave it inside, restart, eject, insert, hit reload in the file browser, nada, nix, nothing. I'd be glad to replace my Fuji and xD for a different type (rather than replace Linux) but the situation is same with SD cards as well...
Everything has an end, sausages, however, have two...Image
Zen Mod
Level 1
Level 1
 
Posts: 23
Joined: Sat Mar 29, 2008 5:08 pm
Location: Maria-Theresiopolis

Linux Mint is funded by ads and donations.
 

Re: T.I. 5 in 1 Card Reader not working

Postby Husse on Mon Apr 28, 2008 3:00 pm

You might try installing "pcscd" with synaptic.
It's a helper app but I know too little about it
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 12 guests