Laptop internal speaker not working but headphones working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Laptop internal speaker not working but headphones working

Postby DS_ED on Wed Jan 02, 2013 3:49 am

Hi guys,

I have been facing the issue of not having audio on my laptop's internal speakers, but when I connected a headphone or an external speaker to the audio out port I could get audio.

My laptop is an Acer 5830 TG.
OS : Linux Mint 14 Cinnamon (64 bit)

I have been trying to find solutions for a while now without results.

Solutions I tried :

#1 :
Adding "options snd-hda-intel model=generic" the line with the model as acer or mobile, rebooted but no audio.
But I did notice a blip sound on my internal speakers where the login music was supposed to play when I rebooted.

#2 :
Opening up the alsa mixer, checked if any of the audio devices had been muted. Saw that the "Internal" was at 0; raised the volume but to no effect.

#3 (Worked) :
According to the suggestions of the last post on this.

Installed module-assisstant :
Code: Select all
sudo apt-get install module-assistant

Ran module-assisstant :
Code: Select all

Selected "SELECT" option in the GUI that comes up.
Checked 'alsa' in the package list.
Selected 'search'.
Selected 'build'.

Halfway through the process of building it failed.
Selected the 'STOP' option.

Opened up the alsamixer again noticed the 'Speaker' control was muted. Unmuted it and increased the volume. Audio working again!

I don't know what made this possible; best guess is that the alsa package was built right this time.

Also no noticeable changes before and after in the '/etc/modprobe.d/alsa-base.conf'.

If someone with the know of what happened could please enlighten me, it would be great. Thanks.

Did a fresh install to find out what was happening and just unmuted and muted "S/PDIF" control in alsamixer and relogged, and audio is back up again! What's happening?
(By the way, the old tests were on Cinnamon this was on XFCE)

Tried getting the microphone to work for Skype and played around with the capture options in alsamixer to no effect. After a shutdown audio stopped working again. As far as I see there are no changes in the settings. Headphones still working when connected. Automatic switching to the headphones also working. Once I disconnect the headphones no audio from the speakers. But the volume settings show me that it is switching to the volume level that was set for the speaker.

This is very erratic behaviour and I'm unable to pin why this is happening. Could someone help me out please?
Level 1
Level 1
Posts: 6
Joined: Wed Jan 02, 2013 3:08 am

Linux Mint is funded by ads and donations.

Return to Hardware Support

Who is online

Users browsing this forum: Google [Bot] and 15 guests