Floppy drives at bootup [As solved as possible]

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Floppy drives at bootup [As solved as possible]

Postby SilverNexus on Thu Jan 03, 2013 8:49 pm

So far I have used Linux Mint for about 12 days, and have one major complaint.
Every time I boot up my computer and log in, the operating system tries to mount a floppy disk, despite there being no floppy in the floppy drive. I don't want to wear out the drive, as it works well, but I'm afraid that this happening repeatedly will eventually and unnecessarily do so.

With that said, is there a way to get the operating system to not try to automatically mount the contents of the floppy drive? Every post I've seen about this applies to someone who does not have a floppy drive, and I do have a floppy drive, and thus do not want to merely disable it.
I am using Linux Mint 14.1 with the MATE desktop environment. It is 32-bit and runs on a 2GHz AMD Sempron 3000+ Processor with 2GB RAM, a CD drive, CD/DVD drive, a card reader taken from a newer computer and cut to fit in a floppy slot in the case, and a 3 1/2" floppy drive.
Last edited by SilverNexus on Sat Jan 05, 2013 7:07 pm, edited 1 time in total.
They say that a three-year old can use Windows 8. I say that's a bit of a regression. When I was three, I could use DOS.

A computer without Windows is like a fish without a bicycle.
SilverNexus
Level 3
Level 3
 
Posts: 106
Joined: Thu Jan 03, 2013 1:46 pm
Location: Somewhere between reality and my own mind's fantasy.

Linux Mint is funded by ads and donations.
 

Re: Floppy drives at bootup

Postby mank_in on Fri Jan 04, 2013 6:57 am

I cannot give the exact solution to cure your problem. I am start using LM when i am not using floppy anymore.
You can experiment floppy option in etc/fstab
Code: Select all
sudo pluma /etc/fstab


default floppy option in ubuntu is (green color is the option )
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

this is the literature :
http://edc.tversu.ru/elib/inf/0041/DDU0219.html
http://www.linfo.org/etc_fstab.html
http://www.tuxfiles.org/linuxhelp/fstab.html

Maybe the correct option is : viewtopic.php?f=148&t=76974&p=448971

Remember after change fstab file , you need execute :
Code: Select all
sudo update-initramfs -u
sudo update-grub

and reboot
Good luck :)
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Floppy drives at bootup

Postby SilverNexus on Fri Jan 04, 2013 10:43 am

Based on what the articles recommended, I added sync to the floppy drive options and removed utf8 for lack of mention.
Yet, despite noauto already being set, the computer still tries to mount the floppy drive at bootup.

I'm trying the removal of the exec option, and will see what that does.

EDIT: The error message it gives when it can't mount the nonexistant floppy disk seems to indicate that it may be trying to directly mount the floppy drive, not using the -a flag and thus bypassing the noauto option. I just have no idea where I'd have to go to check/fix that.
They say that a three-year old can use Windows 8. I say that's a bit of a regression. When I was three, I could use DOS.

A computer without Windows is like a fish without a bicycle.
SilverNexus
Level 3
Level 3
 
Posts: 106
Joined: Thu Jan 03, 2013 1:46 pm
Location: Somewhere between reality and my own mind's fantasy.

Re: Floppy drives at bootup

Postby mank_in on Fri Jan 04, 2013 11:02 am

After search around the web, i think this problem not just ubuntu bug but upstream bug ( udisk )
until udisk is update by ubuntu developer, you can temporally disable Floppy in BIOS : https://bugs.launchpad.net/ubuntu/+sour ... ug/1054414
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Floppy drives at bootup

Postby SilverNexus on Fri Jan 04, 2013 11:45 am

Good to know. I think I had found that page before but hadn't bothered to read to the end.
I might have continued to mess with fstab until I drove myself crazy, but since its a bug, I just have to wait.
Hopefully, they fix it soon. I want my floppy drive to work right again.
They say that a three-year old can use Windows 8. I say that's a bit of a regression. When I was three, I could use DOS.

A computer without Windows is like a fish without a bicycle.
SilverNexus
Level 3
Level 3
 
Posts: 106
Joined: Thu Jan 03, 2013 1:46 pm
Location: Somewhere between reality and my own mind's fantasy.

Re: Floppy drives at bootup [As solved as possible]

Postby fgg2001 on Fri Mar 15, 2013 1:23 pm

Hello,
All the threads on this subject don't make any sense. We don't want to disable the floppy, just eliminate the automatic mount that produces the error message when there is no floppy in the drive.

This problem only happens with Linux Mint MATE and not with CINNAMON.(both at level 14.1)
With CINNAMON you actually need to issue the "udisks --mount /dev/fd0" to mount the floppy, it does not try to do it automatically when I login, apparently the mount for the floppy is issued automatically in the MATE version of linux.
Perhaps somebody can figure out how it was fixed in CINNAMON and get the same solution for MATE.
So far I have not found any valid answer or solution in all the threads about this subject.
F.G.
fgg2001
Level 1
Level 1
 
Posts: 10
Joined: Sat Mar 09, 2013 10:17 pm

Re: Floppy drives at bootup [As solved as possible]

Postby fgg2001 on Fri Mar 15, 2013 2:50 pm

Hi all,
Finally I found the right answer to this problem in Linux Mint MATE. This was from a Linux user of ubuntu.
To eliminate the error that happens after every reboot or login, uncheck the preference option of media_automount using mateconf-editor.

mateconf-editor: /apps/caja/preferences/media_automount

This worked fine for me without disabling the floppy that I can still mount if I need to. :D

This also explains why the problem was only occurring with Linux MATE and not with CINNAMON which evidently does not try this automount.
Thanks, F.G.
fgg2001
Level 1
Level 1
 
Posts: 10
Joined: Sat Mar 09, 2013 10:17 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: ImConfused and 8 guests