X fails to start on new install, computer locks up

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

X fails to start on new install, computer locks up

Postby ioctlvoid on Thu Jan 10, 2013 12:35 pm

X fails to start on a new install of Linux Mint 14, 32-bit, XFCE.

The laptop has an Intel 915GM graphics adapter, I get the following error from dmesg:

Code: Select all
[Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.


I also get the following error from X:

Code: Select all
(EE) intel(0): failed to get resources: Invalid argument
(EE) Screen(s) found, but none have a usable configuration.


I tried to specify this parameter as a boot argument to GRUB, it didn't do anything, I still get the same error from dmesg and from X.

I generated my own xorg.conf with X -configure and specify the "vesa" driver. This gets me into X. However, I'm only able to use the system for a short period of time before it locks up completely. No error, no kernel panic message, even the mouse freezes. This doesn't seem to happen in console mode, except when I close the lid on the computer and open it up again.

ACPI issue and/or i915 issue? What the heck is this?

The same computer was previously running Slackware 13.37 with no problems at all before this.
ioctlvoid
Level 1
Level 1
 
Posts: 28
Joined: Tue Jan 08, 2013 9:23 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 18 guests