No HDMI audio output on Intel 7 Series/C210 Series Chipset

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

No HDMI audio output on Intel 7 Series/C210 Series Chipset

Postby anupsab on Fri Jan 11, 2013 12:33 am

Hi!
I am using Mint 14 64 bit on i5 processor. I am unable to get audio output on my 32" TV although the video & display options work very well.

lspci -nn | grep Audio
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)

I have tried editing the /etc/modprobe.d/alsa-base.config file by adding at the bottom
"options snd-hda-intel model=auto enable=1 index=0" as suggested on a youtube video (http://www.youtube.com/watch?v=a-2wxd1d0Tg) which was for Mint 9.
This gave me options on selection of Hardware options on System Settings--Sound--Hardware but none of the HDMI output options work.
Can anyone provide a solution please?
anupsab
Level 1
Level 1
 
Posts: 2
Joined: Fri Jan 11, 2013 12:17 am

Linux Mint is funded by ads and donations.
 

Re: No HDMI audio output on Intel 7 Series/C210 Series Chips

Postby kc1di on Fri Jan 11, 2013 7:15 am

Hello anupsab and welcome to Mint,

you can try this.
Go to the little speaker in the panel left click it then click on sound settings. and Hardware tab then there is a dropdown menu at the bottom under that you should find several options
one of which is HDMI output.
Good Luck
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1472
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: No HDMI audio output on Intel 7 Series/C210 Series Chips

Postby anupsab on Fri Jan 11, 2013 11:46 pm

Thanks for the reply!
I tried that- in fact I get quite a few options which are labelled HDMI but i do not get audio output.
anupsab
Level 1
Level 1
 
Posts: 2
Joined: Fri Jan 11, 2013 12:17 am

Re: No HDMI audio output on Intel 7 Series/C210 Series Chips

Postby kc1di on Sat Jan 12, 2013 6:34 am

anupsab wrote:Thanks for the reply!
I tried that- in fact I get quite a few options which are labelled HDMI but i do not get audio output.

make sure Alsa is installed.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1472
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: No HDMI audio output on Intel 7 Series/C210 Series Chips

Postby Aterocana on Sat Jan 12, 2013 7:41 am

Exactly the same problem with the same hardware. I run LMDE (with Cinnamon) and I can't heard audio from the TV (that's linked with HDMI to the PC), meanwhile everything is ok with Windows7.
Alsamixer is installed and every device is unmuted. Any advice?
Thank you.
Aterocana
Level 1
Level 1
 
Posts: 2
Joined: Sat Jan 12, 2013 7:35 am

Re: No HDMI audio output on Intel 7 Series/C210 Series Chips

Postby kc1di on Sat Jan 12, 2013 8:05 am

A search of the internet shows that this family of audio cards is very problematic in linux. Thus I'm out of Ideas but perhaps someone has found a solution and will
come forward- Sorry :(
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1472
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: No HDMI audio output on Intel 7 Series/C210 Series Chips

Postby Aterocana on Sat Jan 12, 2013 8:38 am

I see, I didn't find anything either. Thank you anyway.
Aterocana
Level 1
Level 1
 
Posts: 2
Joined: Sat Jan 12, 2013 7:35 am

Re: No HDMI audio output on Intel 7 Series/C210 Series Chips

Postby Xipher_Zero on Tue May 21, 2013 10:01 pm

This audio controller requires that the proper module is loaded and a newer build of ALSA installed for normal audio and HDMI audio to work.

Correcting No Audio:

Edit /etc/modules and add the snd module so that the file looks like this:
Code: Select all
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
# Parameters can be specified after the module name.

snd
loop
lp
rtc

After a reboot the correct kernel module will be loaded and you should have audio.

Correcting No HDMI Audio:
Next you will need to install a daily build of ALSA. This can be obtained here: https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+packages You only need to install the oem-audio-hda-daily-dkms_0.201304261252~raring1_all.deb package.

This will correct no audio and no HDMI audio on most variants of this audio controller.
Xipher_Zero
Level 1
Level 1
 
Posts: 8
Joined: Fri Mar 07, 2008 12:52 pm
Location: Reno, Nevada (USA)

Re: No HDMI audio output on Intel 7 Series/C210 Series Chips

Postby Haui on Fri Dec 27, 2013 1:41 pm

Hi,
thank you for your advices!
I do have the exact same audio chip and tried all of this here and much more.
For example I also tried: http://community.linuxmint.com/tutorial/view/1051

I use the alsa-daily ppa on my Linux Mint 15 64-bit machine.
It is a HP Folio 9470 Ultrabook with an Intel core i7 processor.

Very, very annoying is that everything worked perfectly before I updated my machine yesterday :-(.

But I can't get audio via my hdmi cable to work again :-(.
Even my build in microphone doesn't work anymore :-(.

I need a working soundsystem.
Especially the microphone.

Any further advice, ideas whatever?
Haui
Level 1
Level 1
 
Posts: 1
Joined: Fri Dec 27, 2013 1:30 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 6 guests