Wifi driver/screen resolution conflict on netbook

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Wifi driver/screen resolution conflict on netbook

Postby msjankovich on Sat Jan 12, 2013 4:47 am

Hello everybody, this is my first message on this forum. I have a problem with my wireless driver/screen resolution on my HP2133 netbook. I searched for this problem on the net but couldn't find a solution.
I installed b43-fwcutter driver and enabled wireless, but on the next reboot screen resolution was distorted. Native resolution should be 1280x768. If I disable wireless, resolution goes back to normal after reboot. But if I reboot with wireless enabled, next time it's wrong.
I tried to solve this problem by generating Xorg.conf file and adding Options "PanelSize" "1280x768" in Device section but it didn't work.
This happens on HP2133 netbook with Mint 13 Xfce. On lspci my network controller is Broadcom BCM4311 802.11a/b/g (rev 02).
msjankovich
Level 1
Level 1
 
Posts: 3
Joined: Sat Jan 12, 2013 4:29 am

Linux Mint is funded by ads and donations.
 

Re: Wifi driver/screen resolution conflict on netbook

Postby msjankovich on Sat Jan 12, 2013 2:09 pm

I solved it after I found a similar solution on debian forum. I created /etc/X11/xorg.conf file:

Section "Device"
Identifier "Video Openchrome"
Driver "openchrome"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Monitor"
Identifier "Monitor LCD"
VertRefresh 50.00-100.00 # X11 discovery claim
HorizSync 30.00-113.00 # X11 discovery claim
DisplaySize 193 116 # Approximate
UseModes "HP-2133 LCD Modes"
Option "PreferredMode" "1280x768-60.0"
Option "DPMS"
EndSection

Section "Modes" # See also "HP-2133 Known Modes" at file end for others.
Identifier "HP-2133 LCD Modes"
# Default mode "1024x600": 49.0 MHz, 37.3 kHz, 60.0 Hz
Modeline "1280x768-60.0" 48.96 1280 1064 1168 1312 768 601 604 622 -hsync +vsync
# Default mode "1024x512": 41.3 MHz, 31.9 kHz, 60.0 Hz
Modeline "1024x512-60.0" 41.30 1024 1056 1160 1296 512 513 516 531 -hsync +vsync
# Default mode "720x480": 26.7 MHz, 29.8 kHz, 60.0 Hz
Modeline "720x480-60.0" 26.70 720 736 808 896 480 481 484 497 -hsync +vsync
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Monitor LCD"
SubSection "Display"
Modes "1280x768"
Virtual 1280 768
Depth 24
EndSubSection
Device "Video Openchrome"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection

I'm not sure if all lines are nessesary. I deleted most lines from original code for debian system. With this code it seems to work, so I'm not going to "fix" it farther.
msjankovich
Level 1
Level 1
 
Posts: 3
Joined: Sat Jan 12, 2013 4:29 am


Return to Hardware Support

Who is online

Users browsing this forum: Google [Bot], pdc_2 and 11 guests