HDPARM won't set Automatic Acoustic Management (AAM) value

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

HDPARM won't set Automatic Acoustic Management (AAM) value

Postby w.edelberg on Wed Jan 30, 2013 2:49 pm

Hello,

What I am trying to do: I have a dual-boot system with Linux Mint 14 "Nadia" and Windows 7. It runs fine under Windows 7, but there is a great deal of intermittent hard drive noise (fluttering sound) when running Linux Mint 14. From what I've read online, this might be fixable by using hdparm to reset the Automatic Acoustic Management (AAM) value: "sudo hdparm -M 128 /dev/sdc".

The problem I'm running into: Okay, first I am using "sudo hdparm -I /dev/sdc" to see what the current AAM setting is for /dev/sdc. I get back a lot of information, but this looks like the relevant part:
Advanced power management level: 254
Recommended acoustic management value: 208, current value: 0

Now, when I try to reset the AAM value, this is what I get:
walter@jupiter-linux ~ $ sudo hdparm -M 128 /dev/sdc

/dev/sdc:
setting acoustic management to 128
HDIO_DRIVE_CMD:ACOUSTIC failed: Input/output error
acoustic = not supported

I get similar error messages when I try to set the value to 0, 208, or 254. I should mention that the drive in question is a Seagate Barracuda Black 2TB, Model Number ST2000DM001-9YN164. (At first I thought that the problem might be that this particular hard drive doesn't support acoustic management. But if that is so, why do I get back 208 as the recommended value, when I use "sudo hdparm -I /dev/sdc"?)

Thanks for any help anyone can provide.

-- Walter
w.edelberg
Level 1
Level 1
 
Posts: 3
Joined: Tue Aug 07, 2012 11:17 am

Linux Mint is funded by ads and donations.
 

Re: HDPARM won't set Automatic Acoustic Management (AAM) val

Postby eanfrid on Wed Jan 30, 2013 3:10 pm

Seagate drives really don't support acoustic management, since many years.
Main desktop: Debian GNU/Linux Wheezy 64bit - MATE 1.8.1
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox
User avatar
eanfrid
Level 7
Level 7
 
Posts: 1871
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: HDPARM won't set Automatic Acoustic Management (AAM) val

Postby w.edelberg on Wed Jan 30, 2013 3:22 pm

Thanks eanfrid. That saves me from the wild goose chase I was on, trying to get AAM to work on my Seagates. I see on Wikipedia that in 2011 Western Digital joined Seagate in not supporting AAM. The sound of the drive is pretty annoying. I wonder whether I could lessen it either by rolling back from Mint 14 to Mint 13, or by reformatting the drives using ext2 or ext3. Right now they are ext4. Any thoughts on that?
w.edelberg
Level 1
Level 1
 
Posts: 3
Joined: Tue Aug 07, 2012 11:17 am

Re: HDPARM won't set Automatic Acoustic Management (AAM) val

Postby eanfrid on Wed Jan 30, 2013 3:35 pm

Changing the file-system or the kernel will have no consequence. It is purely a hardware matter. I have 2 of these drives in a RAID1 2GB ext4 array since about 1 year and I don't feel that they make so much noise.
Main desktop: Debian GNU/Linux Wheezy 64bit - MATE 1.8.1
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox
User avatar
eanfrid
Level 7
Level 7
 
Posts: 1871
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: HDPARM won't set Automatic Acoustic Management (AAM) val

Postby Mute Ant on Tue Mar 18, 2014 12:42 am

Without an automatic acoustic management option, you can still reduce a lot of operational noise by 'short-stroking', confining the frenzied OS activity to a small-ish 10GiB partition and the rest as an ignore-mostly storage partition. The small partition can be at the top-end of the drive, so a live-cd with gparted would be sufficient to rebuild the drive.
''Pigs fly in the ayre with their tayles forward.'' [shorte dictionarie for yonge begynners]
Mute Ant
Level 6
Level 6
 
Posts: 1102
Joined: Tue Sep 03, 2013 7:45 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 26 guests