Fan of Nvidia 8800 GT is at top speed in GNU/linux 13 & 14

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Fan of Nvidia 8800 GT is at top speed in GNU/linux 13 & 14

Postby kibatz on Thu Jan 31, 2013 7:18 am

greetings,

I am using GNU/linux Mint Version 10 for 4 years now and i am extremaly happy to have found a very stable GNU/Linux distribution. Not a crash in years i can almost say! everything is working perfectly! And i have twinview (clone) on my tv with the nvidia driver 173.

But this version is gettign old, especialy now with GNU/Linux Mint brigging cinnamon on the scene, + the new version of thunderbird, firefox and banshee becoming efficient.

So, i've installed GNU/Linux Mint 14, everything was going alright until i've installed the Nvidia driver (the recommended and tested version), it s the 300 i think or the 314 i dont remember, in any case i tried all the nvidia driver proposed by GNU/Linux Mint 14 with fresh install and i had the flollowing problem with al of them: the fan of my nvidia 8800 GT is at top speed when GNU/Linux Mint 14 start and makin huge noise (same problem with GNU/Linux Mint 13).

What i have noted is that the temperatur sensor is not detected by those driver, in the the nvidia settings windows i dont have an information in the related windows: i have a "0". So i think that s why the fan is a top speed.

So i tried to install the driver version 173 proposed by nvidia on his website, as i had no problem with it in when using GNU/Linux Mint 10.

First a have a sript error when installing the driver, but the rest o the installation was ok. iv checked that i have the graphics acceleration and nvidia settings, i have it. And now the fan have a normal speed and i have information from the termal sensor in nvidia settings related windows.

But my xorg.conf file does'nt work anymore, i dont have twinview (clone) on my tv with it, it freeze. I dont like to make uggly install of driver like that with script error.

To the point:

The thing is that i like to use the last driver proposed and tested by GNU/Linux Mint, can you tell me how i can solve this problem of that fan of my 8800 GT going top speed making huge noise? do i have to set some parametter in de kernel?

Do you have any idea abotu that problem?

Thank you for your help
kibatz
Level 1
Level 1
 
Posts: 11
Joined: Thu Jan 31, 2013 6:46 am

Linux Mint is funded by ads and donations.
 

Re: Fan of Nvidia 8800 GT is at top speed in GNU/linux 13 &

Postby kibatz on Thu Jan 31, 2013 5:25 pm

I have finaly found a solution.

there is a huge tread about this problem, and it s a problem from a long time.

the solution is nv clock + a command line in /etc/mdm/default like that the fan speed parameter will start with the system, note that if you change that parameter with a console when in the operating system, it will not be applyed immediataly, it need s a restart

The sneaky stuff is that the nvclock from the Mint distrib does nt work, you need to download the last version in the website, in my case it was the NVClock 0.8 (Beta4)

instruction of installation:

(1) open a console where you have unzipped the files and:
a) ./configure --disable-gtk --disable-qt --disable-nvcontrol
b) make
c) make install

(2) Open /etc/mdm/Init/Default

and add this line at top of the file:
/usr/local/bin/nvclock -f -F 45

the last value is the speed of the gpu fan in %.
Source of this instruction

reboot and your are done! :D
kibatz
Level 1
Level 1
 
Posts: 11
Joined: Thu Jan 31, 2013 6:46 am

Re: Fan of Nvidia 8800 GT is at top speed in GNU/linux 13 &

Postby kibatz on Sat Feb 09, 2013 6:49 am

i have found a better solution to autorun de command line "/usr/local/bin/nvclock -f -F 35".

instead of putting this line in "/etc/mdm/Init/Default" i have put it in "/etc/rc.local"

i had to do this because i have just buy the NEC EA273wm and the screen was not powering up on the login screen. i dont know why but it s because this command line in "/etc/mdm/Init/Default" start befor the login screen and thus my Nec screen does nt power up.

The special thing is that this screen have so physical button, but "touch sensitive button", so it s like i can not hardstart it, so i was forced to unplug the power supply and re plug it for my screen to start at the login screen.

So i have put this command line in "/etc/rc.local", with sleep mode to 5:

sleep 5
/usr/local/bin/nvclock -f -F 35

Then cmhoded it, if you dont do that it will not start:

"sudo chmod 755 /etc/rc.local"

restart the computer and now my screen power up at the login screen.

i hope this help some one!
kibatz
Level 1
Level 1
 
Posts: 11
Joined: Thu Jan 31, 2013 6:46 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 20 guests