Cant find usb bluetooth adaptar Blueman

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Cant find usb bluetooth adaptar Blueman

Postby Manuel Ferreira on Tue Feb 12, 2013 5:46 am

Hello
I could not connect my bluetooth usb adapter in Minr 14 mate. I've followed several forums and tryed several soluccions, but none worked.
Below are the commands and outputs

Descritpion

I'm using Blueman 1.23

Blueman manager from console:

lueman-manager
Loading configuration plugins
Using gconf config backend
_________
Load (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:68)
['PulseAudioProfile', 'Services']
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.Services.Services'>
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.PulseAudioProfile.PulseAudioProfile'>
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
1
blueman-manager version 1.23 starting
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
2
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
3
_________
on_bluez_name_owner_changed (/usr/bin/blueman-manager:110)
org.bluez owner changed to :1.3
Using gconf config backend
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
None
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
No such adapter
_________lueman-manager
Loading configuration plugins
Using gconf config backend
_________
Load (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:68)
['PulseAudioProfile', 'Services']
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.Services.Services'>
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.PulseAudioProfile.PulseAudioProfile'>
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
1
blueman-manager version 1.23 starting
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
2
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
3
_________
on_bluez_name_owner_changed (/usr/bin/blueman-manager:110)
org.bluez owner changed to :1.3
Using gconf config backend
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
None
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blulueman-manager
Loading configuration plugins
Using gconf config backend
_________
Load (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:68)
['PulseAudioProfile', 'Services']
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.Services.Services'>
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.PulseAudioProfile.PulseAudioProfile'>
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
1
blueman-manager version 1.23 starting
_________
pa_context_event (/usr/lib/python2.7/dist-packalueman-manager
Loading configuration plugins
Using gconf config backend
_________
Load (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:68)
['PulseAudioProfile', 'Services']
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.Services.Services'>
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.PulseAudioProfile.PulseAudioProfile'>
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
1
blueman-manager version 1.23 starting
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
2
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
3
_________
on_bluez_name_owner_changed (/usr/bin/blueman-manager:110)
org.bluez owner changed to :1.3
Using gconf config backend
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
None
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
No such adapter
_________lueman-manager
Loading configuration plugins
Using gconf config backendlueman-manager
Loading configuration plugins
Using gconf config backend
_________
Load (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:68)
['PulseAudioProfile', 'Services']
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.Services.Services'>
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.PulseAudioProfile.PulseAudioProfile'>
_________
pa_context_event (/usr/lib/python2.7/dist-packalueman-manager
Loading configuration plugins
Using gconf config backend
_________
Load (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:68)
['PulseAudioProfile', 'Services']
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.Services.Services'>
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.PulseAudioProfile.PulseAudioProfile'>
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
1
blueman-manager version 1.23 starting
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
2
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
3
_________
on_bluez_name_owner_changed (/usr/bin/blueman-manager:110)
org.bluez owner changed to :1.3
Using gconf config backend
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
None
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
No such adapter
_________
on_adapter_changed (/usr/lib/python2.7/dist-packages/blueman/gui/manager/ManagerToolbar.py:89)
toolbar adapter None
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
4
_________
on_pa_ready (/usr/lib/python2.7/dist-packages/blueman/plugins/manager/PulseAudioProfile.py:45)
connected
_________
<lambda> (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:318)
1
ges/blueman/main/PulseAudioUtils.py:306)
1
blueman-manager version 1.23 starting
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
2
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
3
_________
on_bluez_name_owner_changed (/usr/bin/blueman-manager:110)
org.bluez owner changed to :1.3
Using gconf config backend
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
None
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
No such adapter
_________
on_adapter_changed (/usr/lib/python2.7/dist-packages/blueman/gui/manager/ManagerToolbar.py:89)
toolbar adapter None
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
4
_________
on_pa_ready (/usr/lib/python2.7/dist-packages/blueman/plugins/manager/PulseAudioProfile.py:45)
connected
_________
<lambda> (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:318)
1

_________
Load (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:68)
['PulseAudioProfile', 'Services']
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.Services.Services'>
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.PulseAudioProfile.PulseAudioProfile'>
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
1
blueman-manager version 1.23 starting
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
2
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
3
_________
on_bluez_name_owner_changed (/usr/bin/blueman-manager:110)
org.bluez owner changed to :1.3
Using gconf config backend
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
None
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
No such adapter
_________
on_adapter_changed (/usr/lib/python2.7/dist-packages/blueman/gui/manager/ManagerToolbar.py:89)
toolbar adapter None
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
4
_________
on_pa_ready (/usr/lib/python2.7/dist-packages/blueman/plugins/manager/PulseAudioProfile.py:45)
connected
_________
<lambda> (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:318)
1

on_adapter_changed (/usr/lib/python2.7/dist-packages/blueman/gui/manager/ManagerToolbar.py:89)
toolbar adapter None
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
4
_________
on_pa_ready (/usr/lib/python2.7/dist-packages/blueman/plugins/manager/PulseAudioProfile.py:45)
connected
_________
<lambda> (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:318)
1
ges/blueman/main/PulseAudioUtils.py:306)
2
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
3
_________
on_bluez_name_owner_changed (/usr/bin/blueman-manager:110)
org.bluez owner changed to :1.3
Using gconf config backend
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
None
_________lueman-manager
Loading configuration plugins
Using gconf config backend
_________
Load (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:68)
['PulseAudioProfile', 'Services']
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.Services.Services'>
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:142)
loading <class 'blueman.plugins.manager.PulseAudioProfile.PulseAudioProfile'>
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
1
blueman-manager version 1.23 starting
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
2
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
3
_________
on_bluez_name_owner_changed (/usr/bin/blueman-manager:110)
org.bluez owner changed to :1.3
Using gconf config backend
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
None
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
No such adapter
_________
on_adapter_changed (/usr/lib/python2.7/dist-packages/blueman/gui/manager/ManagerToolbar.py:89)
toolbar adapter None
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
4
_________
on_pa_ready (/usr/lib/python2.7/dist-packages/blueman/plugins/manager/PulseAudioProfile.py:45)
connected
_________
<lambda> (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:318)
1

SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
No such adapter
_________
on_adapter_changed (/usr/lib/python2.7/dist-packages/blueman/gui/manager/ManagerToolbar.py:89)
toolbar adapter None
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
4
_________
on_pa_ready (/usr/lib/python2.7/dist-packages/blueman/plugins/manager/PulseAudioProfile.py:45)
connected
_________
<lambda> (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:318)
1
eman/gui/DeviceList.py:301)
No such adapter
_________
on_adapter_changed (/usr/lib/python2.7/dist-packages/blueman/gui/manager/ManagerToolbar.py:89)
toolbar adapter None
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
4
_________
on_pa_ready (/usr/lib/python2.7/dist-packages/blueman/plugins/manager/PulseAudioProfile.py:45)
connected
_________
<lambda> (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:318)
1

on_adapter_changed (/usr/lib/python2.7/dist-packages/blueman/gui/manager/ManagerToolbar.py:89)
toolbar adapter None
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
4
_________
on_pa_ready (/usr/lib/python2.7/dist-packages/blueman/plugins/manager/PulseAudioProfile.py:45)
connected
_________
<lambda> (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:318)
1

LSUSB:[u]

Bus 003 Device 002: ID 0c45:613c Microdia PC Camera (SN9C120)
Bus 005 Device 002: ID 1310:0001 Roper Class 1 Bluetooth Dongle
Bus 007 Device 002: ID 2188:0ae1
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

[u]hciconfig

hci0: Type: BR/EDR Bus: USB
BD Address: 00:0B:0D:09:44:70 ACL MTU: 120:20 SCO MTU: 0:0
DOWN
RX bytes:724 acl:0 sco:0 events:26 errors:0
TX bytes:114 acl:0 sco:0 commands:26 errors:0

HCITOOL SCAN

Device is not available: No such device

hciconfig hci0 up

Can't init device hci0: Connection timed out (110)

__________________

I dont know whath to do?
I'm, new on MINT and this adapter worked on windows

Could you help me please :D
Manuel Ferreira
Level 1
Level 1
 
Posts: 2
Joined: Tue Feb 12, 2013 5:24 am

Linux Mint is funded by ads and donations.
 

Re: Cant find usb bluetooth adaptar Blueman

Postby jungle_boy on Tue Feb 12, 2013 10:43 am

Bluetooth don't works in MATE.

Only works fine in KDE.
LM17.1 Mate (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1225
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: Cant find usb bluetooth adaptar Blueman

Postby Manuel Ferreira on Tue Feb 12, 2013 4:11 pm

Thanks for the answer
the question can seem "stupid" but Cinnamon is based on KDE or it doesn't work to.
Manuel Ferreira
Level 1
Level 1
 
Posts: 2
Joined: Tue Feb 12, 2013 5:24 am

Re: Cant find usb bluetooth adaptar Blueman

Postby jungle_boy on Tue Feb 12, 2013 11:24 pm

I tried MATE, cinnamon, xfce and KDE.

Bluetooh works fine only in KDE, others not.
LM17.1 Mate (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1225
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: Cant find usb bluetooth adaptar Blueman

Postby MaGneto on Wed Feb 13, 2013 6:33 am

Hi
i'm kinda new to linux and i have a problem with my Acer s3 Bluetooth which is not working.
the model of my Bluetooth is AR3012 and i found in some forume that i need to patch the kernel and i found this in one of websites
---
drivers/bluetooth/ath3k.c | 2 ++
drivers/bluetooth/btusb.c | 1 +
2 files changed, 3 insertions(+), 0 deletions(-)

diff --git a/drivers/bluetooth/ath3k.c b/drivers/bluetooth/ath3k.c
index 106beb1..b94aae6 100644
--- a/drivers/bluetooth/ath3k.c
+++ b/drivers/bluetooth/ath3k.c
@@ -70,6 +70,7 @@ static struct usb_device_id ath3k_table[] = {

/* Atheros AR3012 with sflash firmware*/
{ USB_DEVICE(0x0CF3, 0x3004) },
+ { USB_DEVICE(0x13d3, 0x3375) },

/* Atheros AR5BBU12 with sflash firmware */
{ USB_DEVICE(0x0489, 0xE02C) },
@@ -86,6 +87,7 @@ static struct usb_device_id ath3k_blist_tbl[] = {

/* Atheros AR3012 with sflash firmware*/
{ USB_DEVICE(0x0cf3, 0x3004), .driver_info = BTUSB_ATH3012 },
+ { USB_DEVICE(0x13d3, 0x3375), .driver_info = BTUSB_ATH3012 },

{ } /* Terminating entry */
};
diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
index f9b7260..a64f15a 100644
--- a/drivers/bluetooth/btusb.c
+++ b/drivers/bluetooth/btusb.c
@@ -122,6 +122,7 @@ static struct usb_device_id blacklist_table[] = {

/* Atheros 3012 with sflash firmware */
{ USB_DEVICE(0x0cf3, 0x3004), .driver_info = BTUSB_ATH3012 },
+ { USB_DEVICE(0x13d3, 0x3375), .driver_info = BTUSB_ATH3012 },

/* Atheros AR5BBU12 with sflash firmware */
{ USB_DEVICE(0x0489, 0xe02c), .driver_info = BTUSB_IGNORE },
--
1.7.2.5



and i have no idea how to use this or how to patch the kernel can someone please help me .
thank you.
MaGneto
Level 1
Level 1
 
Posts: 3
Joined: Thu Jan 31, 2013 12:09 am

Re: Cant find usb bluetooth adaptar Blueman

Postby jungle_boy on Wed Feb 13, 2013 7:21 am

MaGneto wrote:Hi
the model of my Bluetooth is AR3012 and i found in some forume that i need to patch the kernel and i found this in one of websites


Put here the link to forum or website where you found it.

What linux mint are you installed?

LM11, 12, 13, 14, with mate. cinnamon, kde, xfce, lxde, fluxbox, or lmde?
LM17.1 Mate (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1225
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: Cant find usb bluetooth adaptar Blueman

Postby MaGneto on Wed Feb 13, 2013 8:17 am

Ok i'm using mint 14 with kernel 3.7.5 with cinnamon desktop
And here's the link
http://lkml.indiana.edu/hypermail/linux/kernel/1112.0/01199.html
MaGneto
Level 1
Level 1
 
Posts: 3
Joined: Thu Jan 31, 2013 12:09 am

Re: Cant find usb bluetooth adaptar Blueman

Postby jungle_boy on Wed Feb 13, 2013 9:39 pm

Sorry, I didn't understand too how patch it.
LM17.1 Mate (PC and Notebook) with AMD Catalyst
HP Pavilion g4-1316br, AMD Quad Core, 1,5 GHz, Radeon 6520G/7450M,
Image
Linuxcounter Registered User #506065 (2008)
User avatar
jungle_boy
Level 6
Level 6
 
Posts: 1225
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest, Brazil

Re: Cant find usb bluetooth adaptar Blueman

Postby MaGneto on Thu Feb 14, 2013 6:26 pm

Ok it seems that i need to make those changes in ath3k.c and btusb.c then compile the kernel and install it.
Can someone explain to me how to compile the 3.7.5 kernel? Thank you.
MaGneto
Level 1
Level 1
 
Posts: 3
Joined: Thu Jan 31, 2013 12:09 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: zuzuba and 23 guests