Fan running every 10th second

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Fan running every 10th second

Postby hirudoid on Tue Feb 12, 2013 6:06 am

Hello,
Is there a solution to silence the fan on my laptop?
it does not run all the time. It keeps a pause for 15 seconds and then it runs for 15 seconds again. It goes on and on.
Otherwise I love Linux Mint, but this is ruining my computing and driving me back into windows.
I have tried different distributions and the same problem with all of them, except with Pinguy 12.04.
I am bevildered.
I have Asus K50AB.

Hirudoid. :evil: :shock:
hirudoid
Level 1
Level 1
 
Posts: 1
Joined: Tue Feb 12, 2013 5:57 am

Linux Mint is funded by ads and donations.
 

Re: Fan running every 10th second

Postby rachael on Sat Feb 16, 2013 12:58 pm

Hello,

I don't know if this is your problem but I have just fixed a similar problem on my Samsung 700Z7C running Mint 14. I went to a terminal and using 'top' saw that a thread called kworker was taking 75-80% of the cpu and the fans were going crazy! So, a lot of googling later and I found the problem for me was a rogue interrupt relating to ACPI.

See this thread here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/887793?comments=all

The solution for me was to disable the offending interrupt with the following run as root:

Code: Select all
echo disable > /sys/firmware/acpi/interrupts/gpe13


If this is your issue it's likely that its a different interrupt causing the problem as you are on different hardware so you'll need to do a little digging to work out which one. The thread linked above shows how to do this and also how to make this fix work automatically at startup and from resume.

Hope this helps,

Rachael
rachael
Level 1
Level 1
 
Posts: 1
Joined: Sat Feb 16, 2013 8:37 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 12 guests