Sys. FREEZE, CPU 100%, WIFI broken disconnecting power!

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Sys. FREEZE, CPU 100%, WIFI broken disconnecting power!

Postby asbesto on Fri Feb 15, 2013 6:44 am

Hi there,

just installed this fantastic distro! (mint 14 nadia)

But here on my MSI U100 netbook I have some BIG problems:

when disconnecting AC power sometimes:

- WIFI goes mad and stop working, or
- System FREEZE, or
- KERNEL PANIC, or
- CPU goes to 100% due to ksoftirqd and kworker processes.
- Sometimes the system came out frozen or with wifi mangled after a suspend (closing my netbook screen)

It seem like a lot of kernel problems! :shock:

Any info on those issues?

Some informations now:
wifi board:
02:00.0 Network controller: Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe

process at 100% cpu:

3 root 20 0 0 0 0 R 64.7 0.0 0:54.41 ksoftirqd/0
14233 root 20 0 0 0 0 R 34.8 0.0 0:14.03 kworker/0:2

Errors in wifi board after disconnecting power:
phy0 -> rt2x00pci_regbusy_read: Error - Indirect register access failed: offset=0x0000101c, value=0xffffffff
73 de IW9HGS - Gabriele "Asbesto" Zaverio
http://museum.freaknet.org/en
User avatar
asbesto
Level 2
Level 2
 
Posts: 56
Joined: Fri Feb 15, 2013 6:30 am
Location: Palazzolo Acreide, ITALY

Linux Mint is funded by ads and donations.
 

Re: Sys. FREEZE, CPU 100%, WIFI broken disconnecting power!

Postby asbesto on Sat Feb 16, 2013 6:24 am

...anyone here?
73 de IW9HGS - Gabriele "Asbesto" Zaverio
http://museum.freaknet.org/en
User avatar
asbesto
Level 2
Level 2
 
Posts: 56
Joined: Fri Feb 15, 2013 6:30 am
Location: Palazzolo Acreide, ITALY

Re: Sys. FREEZE, CPU 100%, WIFI broken disconnecting power!

Postby asbesto on Sat Feb 16, 2013 8:03 am

I found a fix.

Part of this bug is described here:

https://bugs.launchpad.net/ubuntu/+sour ... bug/689004

In comment 6 there's the fix. I will summarize here:

Wolfgang Kufner (wolfgangkufner) wrote on 2011-01-06: #9
[...]
let's try PCIe bus power saving:
sudo touch /etc/pm/power.d/pcie_aspm
You now should have an empty file named pcie_aspm without the executable bit set in /etc/pm/power.d.
Check with:
ls -lh /etc/pm/power.d/
You should see this file:
-rw-r--r-- 1 root root 0 2010-12-31 18:53 pcie_aspm
Shut down. Boot. Try suspending again.


This seem to have fixed the wifi issue to me.

I have no kernel panic issue for now...
73 de IW9HGS - Gabriele "Asbesto" Zaverio
http://museum.freaknet.org/en
User avatar
asbesto
Level 2
Level 2
 
Posts: 56
Joined: Fri Feb 15, 2013 6:30 am
Location: Palazzolo Acreide, ITALY

Re: Sys. FREEZE, CPU 100%, WIFI broken disconnecting power!

Postby viking777 on Sat Feb 16, 2013 8:50 am

Interesting asbesto. I must say that the idea of solving computer problems by creating empty files seems akin to voodoo to me - you didn't have to sacrifice a chicken as well did you :lol: .

I had a look at that file on my computer and it has code in it. Not much, but some. Why you don't have the same file with the same code I have no idea and why an empty replacement would do just as well is equally baffling.

That is why you never got any replies (before now).

Still if the solution works who am I to question it? Well done for finding it.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am


Return to Hardware Support

Who is online

Users browsing this forum: Google Adsense [Bot], systemBuilder and 14 guests