Installation of Radeon HD5800

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Installation of Radeon HD5800

Postby sirlaughalot on Fri Feb 15, 2013 2:00 pm

Dear community,

at first I'd like to apologize but I'm a total newbie.. I installed Linux Mint on my laptop. Actually, everthing's going its way, unless my graphic card. I have an ATI Radeon HD5800. If I connect the laptop with my screen nothing's happening. The screen stays black. I tried to install the official driver from the ATI website but afterwards I couldn't start the computer properly. So can anybody tell me what I have to do do get my graphic card working?

Here's a thing I read I should post with my request:

System: Host: jan-Aspire-7745G Kernel: 3.5.0-17-generic x86_64 (64 bit, gcc: 4.7.2)
Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine: System: Acer product: Aspire 7745G
Mobo: Acer model: JV71-CP Bios: Phoenix version: V1.08 date: 08/11/2010
CPU: Dual core Intel Core i5 CPU M 480 (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10641.2
Clock Speeds: 1: 1199.00 MHz 2: 1199.00 MHz 3: 1199.00 MHz 4: 2667.00 MHz
Graphics: Card-1: Intel Core Processor Integrated Graphics Controller bus-ID: 00:02.0
Card-2: Advanced Micro Devices [AMD] nee ATI Broadway PRO [Mobility Radeon HD 5800 Series] bus-ID: 01:00.0
X.Org: 1.13.0 drivers: ati,radeon (unloaded: fbdev,vesa) FAILED: intel Resolution: 1600x900@60.3hz
GLX Renderer: Mesa DRI Intel Ironlake Mobile GLX Version: 2.1 Mesa 9.0 Direct Rendering: Yes
Audio: Card-1: Intel 5 Series/3400 Series Chipset High Definition Audio driver: snd_hda_intel bus-ID: 00:1b.0
Card-2: Advanced Micro Devices [AMD] nee ATI Juniper HDMI Audio [Radeon HD 5700 Series] driver: snd_hda_intel bus-ID: 01:00.1
Sound: Advanced Linux Sound Architecture ver: 1.0.25
Network: Card-1: Broadcom BCM43225 802.11b/g/n driver: bcma-pci-bridge bus-ID: 09:00.0
IF: wlan0 state: up mac: <filter>
Card-2: Atheros AR8151 v1.0 Gigabit Ethernet driver: atl1c ver: 1.0.1.0-NAPI port: 3000 bus-ID: 02:00.0
IF: eth0 state: down mac: <filter>
Drives: HDD Total Size: 500.1GB (33.4% used) 1: id: /dev/sda model: Hitachi_HTS54505 size: 500.1GB
Partition: ID: / size: 455G used: 156G (36%) fs: ext4 ID: swap-1 size: 3.95GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 66.0C mobo: N/A gpu: 72.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 150 Uptime: 7 min Memory: 537.3/3627.4MB Runlevel: 2 Gcc sys: 4.7.2 Client: Shell inxi: 1.8.4



Thanks a lot in advance!!

Cheers, jan
sirlaughalot
Level 1
Level 1
 
Posts: 3
Joined: Fri Feb 15, 2013 1:51 pm

Linux Mint is funded by ads and donations.
 

Re: Installation of Radeon HD5800

Postby AlbertP on Fri Feb 15, 2013 2:04 pm

Ok, this is Intel/ATI hybrid graphics. Please post the output of these commands:
Code: Select all
sudo ls -l /sys/kernel/debug/vgaswitcheroo/switch
xrandr
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6503
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Installation of Radeon HD5800

Postby sirlaughalot on Fri Feb 15, 2013 2:29 pm

Thank you for your quick answer.

It's this:
sudo ls -l /sys/kernel/debug/vgaswitcheroo/switch
-rw-r--r-- 1 root root 0 Feb 15 18:48 /sys/kernel/debug/vgaswitcheroo/switch

and this:

xrandr
Screen 0: minimum 320 x 200, current 1600 x 900, maximum 8192 x 8192
LVDS1 connected 1600x900+0+0 (normal left inverted right x axis y axis) 382mm x 214mm
1600x900 60.3*+
1440x900 59.9
1360x768 59.8 60.0
1152x864 60.0
1024x768 60.0
800x600 60.3 56.2
640x480 59.9
VGA1 disconnected (normal left inverted right x axis y axis)
sirlaughalot
Level 1
Level 1
 
Posts: 3
Joined: Fri Feb 15, 2013 1:51 pm

Re: Installation of Radeon HD5800

Postby AlbertP on Sat Feb 16, 2013 8:46 am

You can use your VGA port with Linux, but not the HDMI I'm afraid because this is a hybrid Intel/ATI configuration that the AMD drivers do not support anymore. AMD drivers indeed don't work here. You can power down the AMD GPU because you can't use it anyway:
Code: Select all
gksudo gedit /etc/rc.local

In that text file please put this line before the "exit 0":
Code: Select all
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6503
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Installation of Radeon HD5800

Postby sirlaughalot on Sat Feb 16, 2013 1:34 pm

That sounds like bad news, thanks anyway. So I can throw my laptop into rubbish if I want to use Mint AND HDMI?
sirlaughalot
Level 1
Level 1
 
Posts: 3
Joined: Fri Feb 15, 2013 1:51 pm

Re: Installation of Radeon HD5800

Postby AlbertP on Sat Feb 16, 2013 2:21 pm

For now, the answer is yes. But there is certainly progress being made regarding hybrid graphics support on Linux. Maybe it will be possible in future to use HDMI and the laptop screen at the same time even though they are connected to different GPUs.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6503
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 26 guests