Can't disable default sound card by blacklisting modules

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Can't disable default sound card by blacklisting modules

Postby kikinovak on Sat May 17, 2008 4:17 pm

Hi,

On my main desktop PC I have two soundcards:

Code: Select all
kikinovak@bertha ~ $ lspci | grep -i multimedia
02:03.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
02:09.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 06)


The C-Media is an onboard card, and there's no way to disable it in the BIOS. What I did on the previous installs (this machine ran Slackware and Arch before) was simply blacklist the relevant kernel modules to disable the card. More precisely:

Code: Select all
kikinovak@bertha ~ $ lsmod | grep '^snd'
snd_ens1371            27168  2
snd_ac97_codec        101028  1 snd_ens1371
snd_cmipci             38528  3
snd_pcm_oss            42144  0
snd_opl3_lib           12928  1 snd_cmipci
snd_hwdep              10500  1 snd_opl3_lib
snd_mpu401_uart         9728  1 snd_cmipci
snd_mixer_oss          17920  1 snd_pcm_oss
snd_pcm                78596  4 snd_ens1371,snd_ac97_codec,snd_cmipci,snd_pcm_oss
snd_seq_dummy           4868  0
snd_seq_oss            35584  0
snd_seq_midi            9376  0
snd_rawmidi            25760  3 snd_ens1371,snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event      8320  2 snd_seq_oss,snd_seq_midi
snd_seq                54224  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              24836  3 snd_opl3_lib,snd_pcm,snd_seq
snd_seq_device          9612  6 snd_opl3_lib,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    56996  25 snd_ens1371,snd_ac97_codec,snd_cmipci,snd_pcm_oss,snd_opl3_lib,snd_hwdep,snd_mpu401_uart,snd_mixer_oss,snd_pcm,snd_seq_dummy,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
snd_page_alloc         11400  1 snd_pcm


From here I spotted the relevant modules and checked with modinfo. All in all, there are three modules to blacklist, so I added these lines at the end of /etc/modprobe.d/blacklist:

Code: Select all
# C-Media: 1ère carte son --> désactiver
snd_cmipci
snd_opl3_lib
snd_mpu401_uart


I rebooted the computer, and to my surprise, the modules are still loaded... and thus, alsamixer will show it as the default card.

Any suggestions?
kikinovak
Level 1
Level 1
 
Posts: 12
Joined: Thu May 15, 2008 11:03 am

Linux Mint is funded by ads and donations.
 

Re: Can't disable default sound card by blacklisting modules

Postby kikinovak on Sat May 17, 2008 4:19 pm

I'll answer that myself... looks like I forgot to begin each line with 'blacklist' :lol:
kikinovak
Level 1
Level 1
 
Posts: 12
Joined: Thu May 15, 2008 11:03 am


Return to Hardware Support

Who is online

Users browsing this forum: halt and 18 guests