How to install Nvidia GeForce 210M driver on Mint 14 Nadia

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

How to install Nvidia GeForce 210M driver on Mint 14 Nadia

Postby thebluesky on Mon Feb 25, 2013 6:30 pm

I am quite new to linux but I managed to install Mint 14 onto my external driver and I am very happy to be on this forum. :D

My question is I would like to install my graphic card's driver on mint.So I downloaded the driver from Nvidia's official page.But I couldnt install it.
When I tried to run the driver mint says
" could not open the file ....." and in small letters " gedit has not been able to detect the character encoding.Please check that you are not trying to open a binary file.Select a character encoding from the menu and try again."

the driver's name ends ".run" is it normal?should I do sth


when I ran " Software Source" on mint, it says " Nvidia GT 218 (GEFORCE G210M) This device is using an alternative driver " and there are five options listed under this sentece and " using x.org x server ............" was thicked..should I change it


when I look at "details " on mint it says " Gallium 0.4 on NVA8 " on "graphic" section.

what should I do..? My graphic card is Nvidia GeForce 210M 512 MB..and I run Mint 14 Nadia 64 bit Cinnamon .the driver I downloaded is 310.32.run

thanks a lot :D
thebluesky
Level 1
Level 1
 
Posts: 21
Joined: Fri Nov 09, 2012 6:09 pm

Linux Mint is funded by ads and donations.
 

Re: How to install Nvidia GeForce 210M driver on Mint 14 Nad

Postby roblm on Wed Mar 20, 2013 1:40 pm

I updated this information on 3-23-13. I have the GeForce 210 video card installed on my computer and am using the proprietary Nvidia driver and it has worked fine so far. It should be the first one listed under System Settings > Software Sources > Additional Drivers, the "Nvidia binary Xorg driver_from nvidia-current". I would not recommend trying to manually install drivers unless necessary because it can be a little tricky sometimes.
To install this driver you can check the circle next to it in the "Additional Drivers" window. Or you can open the Synaptic Package Manager and type "Nvidia" in the search window. Check the box next to "nvidia-current" and select "Mark for Installation" and click apply in the menu and the installation will be handled automatically.
If you have an AMD processor like I do, then you may see one or more new messages during startup. One is "microcode: failed to load file amd-ucode/microcode_amd.bin". To remove this open the Synaptic Package Manager and in the search window type "amd". Check the box next to "amd64-microcode" and select "Mark for Installation".
Another message that I saw was "kvm disabled by bios". To remove this I went into the BIOS and under Advanced > CPU Configuration there was an option for "Secure Virtual Machine Mode". After setting this to "enabled", the message was removed.
If you have problems reading the messages at startup, then use the "dmesg" command in Terminal. You will see the log produced as the Linux kernel gets loaded. Look near the lower section of the log for the new messages.
User avatar
roblm
Level 5
Level 5
 
Posts: 617
Joined: Sun Feb 24, 2013 2:41 pm

Re: How to install Nvidia GeForce 210M driver on Mint 14 Nad

Postby Smaggy on Mon Oct 14, 2013 7:00 pm

I'm glad I found your post. I was having trouble with XBMC locking up the PC whenever I paused a movie for more than a couple of minutes and I think your post will help. Thanks!
Smaggy
Level 1
Level 1
 
Posts: 33
Joined: Fri Jan 21, 2011 10:30 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 7 guests