No internet and I don't think there's any drivers.

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

No internet and I don't think there's any drivers.

Postby Ponch0 on Fri Mar 01, 2013 12:50 am

I attempted to create a dual-boot system, instead I succeeded at destroying Win8 (I tried recovering but couldn't). I have a bunch of partitions now, but Linux mint - mate 64 bit seems to have correctly installed on the biggest partition. Although I did not create a swap area drive because I've read somewhere that for GPT hard drives I did not have to.

I don't mind having Mint as my only OS but it seems that I have bits and pieces of Win 8 all over the drive. I noticed a networking folder and in it I have "Windows Network" which I cannot access, coincidentally it's the drivers I'm missing. I'm not sure what I should do at this point. Should I try to install the driver or completely erase the disk (I'm not really a computer guy), I tried the first option but couldn't even figure out how to locate the drivers or can't even begin to figure out how to install them.

It's a brand new computer and this is what I get by attempting to be a hero. :(

I typed in "lspci" into terminal and this is a read out.

"00:00.0 Host bridge: intel Corporation 3r Gen Core processor DRAM Controller (rev 09)
00:02.; VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14. USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 USB Controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Rot Port 1 (rev c4)
00:1c.1 PCI:bridge Intel Corporation 7 Series/C210 (rest same as above line)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1(rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 Sata controller: intel corporation 7 series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
1:00.0 Ethernet controller: Atheros Communication Inc. AR8161 Gigabit Ethernet (rev 10)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8723"

Whew, I typed up, apologies for any typos. Also, under administration I found an option for "Windows Wireless Drivers 'ndiswrapper driver installation tool'"

I have a Toshiba S855-S5378
Intel i7
8 gig ram

Is this fixable, (I would rather have Linux Mint) could someone help me, I'll provide any more info if needed Please or if this is a lost cause, I would really appreciate it. Thank you so much.
Ponch0
Level 1
Level 1
 
Posts: 13
Joined: Fri Mar 01, 2013 12:11 am

Linux Mint is funded by ads and donations.
 

Re: No internet and I don't think there's any drivers.

Postby caf4926 on Fri Mar 01, 2013 12:59 am

Please let us see

Code: Select all
lspci -nnk | grep -iA2 net
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1784
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: No internet and I don't think there's any drivers.

Postby Ponch0 on Fri Mar 01, 2013 1:11 am

"1:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8161 Gigabit Ethernet [1969:1091] (rev 10)
Subsystem: Toshiba America info Systems Device [1179:ffle]
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:8723]
Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:0723]"

I'm not sure if relevant, but any word that has "Net" in it is highlighted in red.

Thank you
Ponch0
Level 1
Level 1
 
Posts: 13
Joined: Fri Mar 01, 2013 12:11 am

Re: No internet and I don't think there's any drivers.

Postby caf4926 on Fri Mar 01, 2013 1:19 am

Do you not have windows backed up? Recovery disk?
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1784
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: No internet and I don't think there's any drivers.

Postby Ponch0 on Fri Mar 01, 2013 1:23 am

I have 3 recovery disks and when I chose Toshiba restore to factory default, it would just run each disk, tell me to insert next disk and I did that for about 2 hours without getting anywhere. I must have switched the disks during the "restore" about 50 times, I assumed after that, that it isn't working.
Ponch0
Level 1
Level 1
 
Posts: 13
Joined: Fri Mar 01, 2013 12:11 am

Re: No internet and I don't think there's any drivers.

Postby caf4926 on Fri Mar 01, 2013 1:27 am

At the moment I'm more concerned that you have lost windows...
Do you have anything important in windows, that you would prefer to recover? Do you have an external HD to copy it to if required?
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1784
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: No internet and I don't think there's any drivers.

Postby Ponch0 on Fri Mar 01, 2013 1:31 am

Everything I had there I can easily recover on Linux, I don't care if I lost Windows, in fact I would rather use Linux if I could get it up and running correctly.
Ponch0
Level 1
Level 1
 
Posts: 13
Joined: Fri Mar 01, 2013 12:11 am

Re: No internet and I don't think there's any drivers.

Postby caf4926 on Fri Mar 01, 2013 1:35 am

Ponch0 wrote:Everything I had there I can easily recover on Linux, I don't care if I lost Windows, in fact I would rather use Linux if I could get it up and running correctly.


From the output you posted it doesn't look like either wireless or wired are working.
Can you confirm if that is the case for both? Wired and Wireless.

FYI: It is extremely unusual for wired connections not to work.
If you boot to the Live Session (as you did before you installed) is the wired connection not working there either?
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1784
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: No internet and I don't think there's any drivers.

Postby Ponch0 on Fri Mar 01, 2013 1:41 am

That is correct, neither is working and I just checked again. I'm using my gf's computer hoping I could find a solution.
Ponch0
Level 1
Level 1
 
Posts: 13
Joined: Fri Mar 01, 2013 12:11 am

Re: No internet and I don't think there's any drivers.

Postby caf4926 on Fri Mar 01, 2013 1:56 am

Ponch0 wrote:That is correct, neither is working and I just checked again. I'm using my gf's computer hoping I could find a solution.


OK, so that's not so good.
Can we just confirm, you are using Mint 14 Mate?

To have neither wired or wireless working means you need to
Recover windows - which doesn't sound very possible. You may have to contact your machine vendor.
or try a different Linux distro (one which might work, as it ships with some proprietary drivers, is PCLinuxOS)

If you could though in the mean time, use your other PC to download Parted Magic
Boot from it and run the partition editor and show us a screeshot of your partitions
http://partedmagic.com/doku.php?id=down ... TBDR4c4KcE
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1784
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: No internet and I don't think there's any drivers.

Postby caf4926 on Fri Mar 01, 2013 1:58 am

caf4926 wrote:
Ponch0 wrote:That is correct, neither is working and I just checked again. I'm using my gf's computer hoping I could find a solution.


OK, so that's not so good.
Can we just confirm, you are using Mint 14 Mate?

To have neither wired or wireless working means you need to
Recover windows - which doesn't sound very possible. You may have to contact your machine vendor.
or try a different Linux distro (one which might work, as it ships with some proprietary drivers, is PCLinuxOS)

If you could though in the mean time, use your other PC to download Parted Magic
Boot from it and run the partition editor and show us a screeshot of your partitions
http://partedmagic.com/doku.php?id=down ... TBDR4c4KcE



Just to be clear
Obviously I mean boot Parted Magic on the machine you 'jeffed up'
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1784
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: No internet and I don't think there's any drivers.

Postby Ponch0 on Fri Mar 01, 2013 2:12 am

I was able to find this post and I'm going to try it, if it doesn't work I'll get working on your reply. Check it out and tell me if i'm looking at this right and it's actually the same issue, if oyu wouldn't mind.

viewtopic.php?f=150&p=693265
Ponch0
Level 1
Level 1
 
Posts: 13
Joined: Fri Mar 01, 2013 12:11 am

Re: No internet and I don't think there's any drivers.

Postby caf4926 on Fri Mar 01, 2013 2:19 am

Ponch0 wrote:I was able to find this post and I'm going to try it, if it doesn't work I'll get working on your reply. Check it out and tell me if i'm looking at this right and it's actually the same issue, if oyu wouldn't mind.

viewtopic.php?f=150&p=693265


I'm not sure how far you will get
As I'm not sure all the build requires will be installed

If you were using a distro like openSUSE (DVD version) it includes all the build essentials such as : the kernel headers, make, gcc..... etc..
It's still requires you install those, but you can do so because they are on the DVD
Then you still have the challenge of making the build
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1784
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: No internet and I don't think there's any drivers.

Postby Ponch0 on Fri Mar 01, 2013 2:21 am

Ok, I was able to find and download the modules but when I clicked to install it I got this message, "Same version is available in a software channel, You are recommendd to install the software from the channel instead."

How can I install something from the software channel?
Ponch0
Level 1
Level 1
 
Posts: 13
Joined: Fri Mar 01, 2013 12:11 am

Re: No internet and I don't think there's any drivers.

Postby caf4926 on Fri Mar 01, 2013 2:24 am

See this comment
viewtopic.php?f=150&p=693265#p690134

I'm going offline for a bit - sorry

You might want to consider. Installing again so that you have a nice tidy HD
Just choose the option: Erase disk and install Mint
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1784
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: No internet and I don't think there's any drivers.

Postby Ponch0 on Fri Mar 01, 2013 2:52 am

Ok, thanks for your help anyway.
Ponch0
Level 1
Level 1
 
Posts: 13
Joined: Fri Mar 01, 2013 12:11 am

Re: No internet and I don't think there's any drivers.

Postby caf4926 on Fri Mar 01, 2013 3:04 am

Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1784
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: No internet and I don't think there's any drivers.

Postby Ponch0 on Fri Mar 01, 2013 3:09 am

Ok, I "think" I know what may be the issue, I'm booting the computer in CSM boot which than changes the settings for "LAN". When I change the Boot Mode to UEFI boot, Lan settings than change again, however windows tries to boot up and gives me an error message. If anyone is familiar with the issue please feel free to share :)..

Thank you.
Ponch0
Level 1
Level 1
 
Posts: 13
Joined: Fri Mar 01, 2013 12:11 am

Re: No internet and I don't think there's any drivers.

Postby Ponch0 on Fri Mar 01, 2013 3:12 am

caf4926, I appreciate the links I was able to find the correct version However it isn't letting me to install the package because it's available in Software channel (no internet). I've googled for a solution around this but so far I haven't found anything that has worked.
Ponch0
Level 1
Level 1
 
Posts: 13
Joined: Fri Mar 01, 2013 12:11 am

Re: No internet and I don't think there's any drivers.

Postby caf4926 on Fri Mar 01, 2013 3:19 am

Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1784
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Linux Mint is funded by ads and donations.
 
Next

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 12 guests