Logitech HD C510 Webcam

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Logitech HD C510 Webcam

Postby egotist on Sat Mar 02, 2013 8:43 am

Hi all,

I have a problem getting my webcam to work. Video works on neither cheese nor skype. However, the microphone works fine once configured. This is on linux-mint 14 Nadia, almost-fresh install. According to most posts and comments I've seen on the web, this is one of those models that should "just work".

lsusb shows this:
Code: Select all
Bus 002 Device 002: ID 046d:081d Logitech, Inc. HD Webcam C510


I run gstreamer-properties, and try to to test the video

Code: Select all
Error starting streaming on device '/dev/video0'. [gstv4l2object.c(2230): gst_v4l2_object_start_streaming (): /GstPipeline:pipeline1/GstV4l2Src:v4l2src2:
system error: Input/output error]


Cheese crashes when trying to record video after logging the following:
Code: Select all
libv4l2: error turning on stream: Input/output error

(cheese:3346): cheese-WARNING **: Internal data flow error.

Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started

(cheese:3346): cheese-WARNING **: Jack server not found


(cheese:3346): cheese-WARNING **: Could not initialize supporting library.


Any idea what might be wrong?
egotist
Level 1
Level 1
 
Posts: 5
Joined: Sat Mar 02, 2013 8:33 am

Linux Mint is funded by ads and donations.
 

Re: Logitech HD C510 Webcam

Postby homerscousin on Mon Mar 04, 2013 6:14 pm

I have a C310. I installed guvcview, or something like that, and it worked first time, no configuring. The webcam is still new to me, I since upgraded my kernel and KDE to 4.10. I have to reinstall guvcview, so at the moment it isn't available, but it did work.
i5 3570k, ASRock z77 Extreme 4, 8 Gb Ripjaws 1600, Antec 430w psu, HVR 1600 tv tuner, custom case- marble top, oak face. Carver & DCM Time Window sound system. Mint 14 KDE.
homerscousin
Level 5
Level 5
 
Posts: 541
Joined: Fri May 25, 2012 2:43 pm
Location: Somewhere on planet Earth (mostly)

Re: Logitech HD C510 Webcam

Postby eanfrid on Mon Mar 04, 2013 6:35 pm

Yep. Install guvcview, it should install the missing dependancies like V4L. I have this webcam and another C525 which worked instantly fine out-of-the-box. guvcview is one of the best tools to check if your video really works.
Main desktop: Debian GNU/Linux Wheezy 64bit w/custom 3.14 longterm kernel - MATE 1.8.1
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
True private storage on SpiderOak
User avatar
eanfrid
Level 7
Level 7
 
Posts: 1841
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Logitech HD C510 Webcam

Postby egotist on Tue Mar 05, 2013 3:41 am

Brilliant! It does indeed work with guvcview.

However, I still cannot get it to work with Skype, even with the

Code: Select all
LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype


trick. Any suggestions on what I can tweak? The message I get is that the so cannot be preloaded.
egotist
Level 1
Level 1
 
Posts: 5
Joined: Sat Mar 02, 2013 8:33 am

Re: Logitech HD C510 Webcam

Postby eanfrid on Tue Mar 05, 2013 3:53 am

Which version of Skype ? The tricks you are using tell me that you might have installed an outdated version.
Main desktop: Debian GNU/Linux Wheezy 64bit w/custom 3.14 longterm kernel - MATE 1.8.1
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
True private storage on SpiderOak
User avatar
eanfrid
Level 7
Level 7
 
Posts: 1841
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Logitech HD C510 Webcam

Postby egotist on Tue Mar 05, 2013 4:00 am

Probably so. I am on Skype 4.1.0.20. I only get a black screen. My entire Linux-Mint install is only a couple of days old, so everything should be fresh! Cheese still crashes out on it, but I'm not so concerned about that.
egotist
Level 1
Level 1
 
Posts: 5
Joined: Sat Mar 02, 2013 8:33 am

Re: Logitech HD C510 Webcam

Postby eanfrid on Tue Mar 05, 2013 4:24 am

Indeed you have the lastest version of Skype and the trick you try is useless. Did you download the "Ubuntu multiarch" version or installed from the Mint repo ?
Main desktop: Debian GNU/Linux Wheezy 64bit w/custom 3.14 longterm kernel - MATE 1.8.1
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
True private storage on SpiderOak
User avatar
eanfrid
Level 7
Level 7
 
Posts: 1841
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Logitech HD C510 Webcam

Postby egotist on Tue Mar 05, 2013 4:44 am

I got it straight off http://www.linuxmint.com/download.php, Cinnamon 64 bit.

Installed all the updates and:
Kupfer
Skype
Cheese, after skype didn't work
X11, GL, and GLU dev packages.
guvcview, on your advice

Tweaked fstab a little bit to suit my SSD.

That's about all I've done. Don't think any of that would have caused the problem. Do you?
egotist
Level 1
Level 1
 
Posts: 5
Joined: Sat Mar 02, 2013 8:33 am

Re: Logitech HD C510 Webcam

Postby eanfrid on Tue Mar 05, 2013 5:29 am

I don't think so either. Maybe is it related to your GPU and drivers. I only use AMD GPU and O/S drivers on my 64bit desktops. The webcams work fine either on Debian 7 with 3.8 kernel (and before on older kernels) or on LM13 with kernel 3.5 (~LM14 for that matter).
Main desktop: Debian GNU/Linux Wheezy 64bit w/custom 3.14 longterm kernel - MATE 1.8.1
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
True private storage on SpiderOak
User avatar
eanfrid
Level 7
Level 7
 
Posts: 1841
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Logitech HD C510 Webcam

Postby egotist on Tue Mar 05, 2013 5:49 am

Hmm, interesting thought. I have an Nvidia 660. Installed Steam, and that upgraded my mesa drivers, but no dice. Perhaps I'll have to regress to an earlier version of Skype if I can.
egotist
Level 1
Level 1
 
Posts: 5
Joined: Sat Mar 02, 2013 8:33 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: Google [Bot] and 8 guests