Hibernation does not work

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Hibernation does not work

Postby miggoycor on Wed Mar 13, 2013 4:31 am

When I press hibernate, the machine seems to respond and power down. However, when I resume, it turns on normally, as in it was booted, not hibernated. Nothing was saved and Mint started a new session. It did not even remember it went on hibernation. I made sure the amount of active RAM was less than the amount of the Swap Partition, but nothing was saved, apparently.

I have 2 gig ram and 2 gig swap.

I am using Linux Mint 14 Cinammon.
miggoycor
Level 1
Level 1
 
Posts: 28
Joined: Sat Feb 09, 2013 9:42 am
Location: Philippines

Linux Mint is funded by ads and donations.
 

Re: Hibernation does not work

Postby DataMan on Wed Mar 13, 2013 6:12 am

It's been a really long time since I had to deal with the suspend/hibernate issues. I put together a small paper a while back dealing with the topic in Mint Debian. I'm not certain if it applies to your situation. Suggest taking a look at the paper and see if the resume is set properly. If not the paper should address how to fix it.

http://www.boomerclan.info/techpaperslx.html

Hope this helps.

-DataMan
Linux'd since 2005 Linux ID 422356 Ubuntu ID 15015
User avatar
DataMan
Level 6
Level 6
 
Posts: 1223
Joined: Thu Dec 04, 2008 6:47 am
Location: Carmel, Indiana USA at /var/www

Re: Hibernation does not work

Postby SyncroMaverick on Mon Mar 25, 2013 6:38 am

It seems to me, that the resume-partition is not set on installation. You have to edit /etc/initramfs-tools/conf.d/resume

Code: Select all
RESUME=UUID=<swap_UUID>


where <swap_UUID> has to be the same as for the swap-partition in your /etc/fstab
After editing /etc/initramfs-tools/conf.d/resume you have to run

Code: Select all
sudo update-initramfs -u
SyncroMaverick
Level 1
Level 1
 
Posts: 1
Joined: Thu Mar 07, 2013 4:02 pm

Re: Hibernation does not work

Postby edusson on Sun Nov 09, 2014 12:38 pm

The step by SyncroMaverick is correct, but I was missing also telling grub that it needed to look for the swap partition. I found the solution here (just go there if the link works):
http://chriseiffel.com/everything-linux ... 4-mint-11/

Reposting here in case one day link goes away. Basically there are few problems that can create the issue. The link goes through several (check it out if this doesn't fix it) but this fix is addressing the problem where GRUB (the boot loader) doesn't know where to look for the swap partition, at boot time. All what I needed to do was:

sudo gedit /etc/default/grub

Look for the line that starts with. GRUB_CMDLINE_LINUX

Add the following:

GRUB_CMDLINE_LINUX=”resume=UUID=Your-SWAP-UUID other-option=value”

where in my case, my Your-swap-UUID was b71d9df1-1b6a-4320-9046-0ec62a49cea0

To find out what number is that you can do cat /etc/fstab
"You may or may nor have other options. Be careful that you type in the correct path or UUID for the drive here. If you don’t then when you try to resume you will have to boot in safe mode to fix the drive name and re-run the update-grub script."

Then save the file and update grub with the following command:

sudo update-grub

And then do, if you had not, the steps by SyncroMaverick (basically entering the swap UUID in another file too)

Good luck!
edusson
Level 1
Level 1
 
Posts: 2
Joined: Sat Nov 08, 2014 7:30 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 13 guests