Solution for Creative ZEN 2/4/8G Not Found

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Solution for Creative ZEN 2/4/8G Not Found

Postby Legend_bob on Tue Jun 03, 2008 3:23 pm

Problem: Your new Creative ZEN mp3 player shows up in lsusb -- hint, note the ID displayed for it -- but mtp-detect tells you no devices can be found.

Solution: Add a line to
Code: Select all
 /etc/udev/rules.d$/65-libmtp.rules
that defines your player. I just copied one of the newer Creative players and changed the ID to 4157 for my ZEN.

Then do

Code: Select all
sudo /etc/init.d/udev restart


to reload the rules, plug in your player and mtp-detect should now see it.

Now to figure out why Rhythmbox can't see it but Amarok can...
Legend_bob
Level 1
Level 1
 
Posts: 20
Joined: Mon Mar 17, 2008 5:39 pm

Linux Mint is funded by ads and donations.
 

Re: Solution for Creative ZEN 2/4/8G Not Found

Postby Husse on Wed Jun 04, 2008 8:03 am

Nice, I changed the subject a bit to reflect that it is a solution
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Solution for Creative ZEN 2/4/8G Not Found

Postby billb60 on Thu Jun 05, 2008 4:18 pm

Legend_bob wrote:Problem: Your new Creative ZEN mp3 player shows up in lsusb -- hint, note the ID displayed for it -- but mtp-detect tells you no devices can be found.

Solution: Add a line to
Code: Select all
 /etc/udev/rules.d$/65-libmtp.rules
that defines your player. I just copied one of the newer Creative players and changed the ID to 4157 for my ZEN.

Then do

Code: Select all
sudo /etc/init.d/udev restart


to reload the rules, plug in your player and mtp-detect should now see it.

Now to figure out why Rhythmbox can't see it but Amarok can...


I too couldn't get Rhythmbox to see player but Amarok could after editing in super user mode for MINT4. When I used MINT5, Rhythmbox sees player and I can move stuff back and forth no problem after turning on MTP plugin. I guess MINT 5 is using newer MTP libraries.
billb60
Level 1
Level 1
 
Posts: 7
Joined: Fri Mar 28, 2008 8:33 am

Re: Solution for Creative ZEN 2/4/8G Not Found

Postby atlef on Fri Jun 06, 2008 3:44 am

Have you tried gnomad2? Maybe it will solve your problem.

atlef.
User avatar
atlef
Level 4
Level 4
 
Posts: 306
Joined: Sun Nov 18, 2007 8:20 am
Location: Stavanger NORWAY


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 17 guests