Mouse wheel solved

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Mouse wheel solved

Postby falke on Mon Jun 09, 2008 6:21 am

I just installed Mint 5 and to my surprise does not the mouse wheel work. On the same computer do I also run Ubuntu 8.04 and there it works fine. Am I missing something?

I am running both these OS under VMWare Fusion on a MACBOOK with the mighty mouse.
falke
Level 1
Level 1
 
Posts: 14
Joined: Fri May 23, 2008 7:28 am

Linux Mint is funded by ads and donations.
 

Re: Mouse wheel

Postby Husse on Mon Jun 09, 2008 6:33 am

Of course the mouse wheel works in all Mint
The problem might be Wmware on Macbook but as you say Hardy works I'm confused
My mouse section looks like this
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Emulate3Buttons" "true"
EndSection

It's the Emulate3Buttons that is important - can be may alternatives //Late edit by Husse/ may should be many - somewhat easier to understand :) //
Look at the /etc/X11/xorg.conf in Hardy and compare it to the one in Elyssa
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Solved Re: Mouse wheel

Postby falke on Sun Aug 10, 2008 11:44 am

I just want to report that this issue has been solved. I found an article in Ubuntu Apple forum that referred to this page:

http://peterc.org/2008/64-how-to-enable ... usion.html

Naturally does it work for Linux Mint and the beta 2 of VMware fusion. In short... do the following:

1. Launch a Terminal (Applications menu -> Accessories -> Terminal).

2. Type: sudo gedit /etc/X11/xorg.conf

3. Scroll down (it’s not far, perhaps 20 - 30 lines) till you see a block that looks like this:

Section "InputDevice"
Identifier "Configured Mouse"
Driver "vmmouse"
[.. blah blah blah ..]
EndSection

4. Replace that whole section with this:

Section "InputDevice"
Identifier "Configured Mouse"
Driver "vmmouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
EndSection

5. Save the file

6. close all your apps and

7. hit Ctrl+Alt+Backspace. X restarts within a few seconds, and you’re back up and running. Scrolling should now be possible!
falke
Level 1
Level 1
 
Posts: 14
Joined: Fri May 23, 2008 7:28 am


Return to Hardware Support

Who is online

Users browsing this forum: HilltopsGM and 10 guests