epson cx4400 need help

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

epson cx4400 need help

Postby star span on Tue Jun 10, 2008 12:14 pm

If anyone can help it would be great. I just bought an Epson cx4450. I downloaded the drivers for it and added new printer and picked the correct driver for it in the pull down menu but the system still doesn't recognize i have the printer. could someone post a link or give detailed instructions on how to get the printer and scanner to work? I'm using Daryna KDE. patiently waiting for Elyssa KDE.
I'm lovin' this Mint thing :lol:

Thanx in advance for any and all help.
star span
 

Linux Mint is funded by ads and donations.
 

Re: epson cx4400 need help

Postby Natwest on Tue Jun 17, 2008 11:09 am

I have a very simple change to make my DX6000 scanner to work.
1st you will have to install sane.
Step 1:
in terminal run> lsusb (look for the line that contains, Buses xxx Device xxx: ID 04b8: xxxx Sieko Epson Corp
Note the Buses xxx, Device xxx. Important part is the xxxx this is your printer model (04b8 = Epson).
in terminal run>sudo gedit/etc/sane.d/epson.conf
Find: #usb 0x? 0x? (delete the hash) delete the 1st ? and replace with 04b8, the 2nd ? replace with the xxxx printer model
Look further down and delete the hash on lines,
#usb /dev/usbscanner0
#usb/dev/usb/scanner0
and save.

Step 2:
in terminal run>sudo gedit /etc/udev/rules.d/45-libsane.rules
Find the last entry for epson, this is mine after editing the CX-4800

Code: Select all
# Epson DX-6000
SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="082e", MODE="664", GROUP="scanner"


the 082e = DX6000
Change the XX0000 to you model and save.

Hope this helps
User avatar
Natwest
Level 1
Level 1
 
Posts: 15
Joined: Sun Sep 23, 2007 7:02 pm
Location: Dundee, Scotland

Re: epson cx4400 need help

Postby anthony2010 on Thu Jul 03, 2008 12:47 pm

Hi.

I have a dx4000 multifunction device. I had it working in ubuntu but want it in mint!!

Tried and failed with the following:
anthony@anthony-desktop ~ $ lusb
bash: lusb: command not found
anthony@anthony-desktop ~ $ lsusb
Bus 002 Device 006: ID 05e3:0702 Genesys Logic, Inc. USB 2.0 IDE Adapter
Bus 002 Device 005: ID 04b8:082f Seiko Epson Corp.
Bus 002 Device 004: ID 1241:1166 Belkin optical mouse w/ scrollwheel
Bus 002 Device 003: ID 2001:f103 D-Link Corp. [hex]
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 002: ID 06a3:8021 Saitek PLC
Bus 001 Device 001: ID 0000:0000
anthony@anthony-desktop ~ $ sudo gedit/etc/sane.d/epson.conf
sudo: gedit/etc/sane.d/epson.conf: command not found
anthony@anthony-desktop ~ $ sudo-gedit/etc/sane.d/epson.conf
bash: sudo-gedit/etc/sane.d/epson.conf: No such file or directory
anthony@anthony-desktop ~ $ sudo apt-get/etc/sane.d/epson.conf
sudo: apt-get/etc/sane.d/epson.conf: command not found
anthony@anthony-desktop ~ $ sudo /etc/sane.d/epson.conf
sudo: /etc/sane.d/epson.conf: command not found
anthony@anthony-desktop ~ $

As you can see I tried a few ideas out but to no avail. Do you have any suggestions as to how I can go forward?

Thanks in advance.

Anthony
anthony2010
Level 3
Level 3
 
Posts: 159
Joined: Tue Jul 01, 2008 7:31 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 16 guests