Swiss french keyboard - Elyssa

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Swiss french keyboard - Elyssa

Postby oliverjames on Wed Jun 11, 2008 5:13 pm

Elyssa working well. I would like to cure this annoying glitch,

With my Swiss french keyboard, set to Swiss-French- no dead keys, when I type ^ o together they are presented as ^o rather than ô. Same with ^etre rather than être, etc.

Can anyone help me solve this.

Ciao

Oliverjames
oliverjames
Level 3
Level 3
 
Posts: 194
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Linux Mint is funded by ads and donations.
 

Re: Swiss french keyboard - Elyssa

Postby Husse on Thu Jun 12, 2008 6:24 am

I think it has to do with the order you type it
^ is to be typed before o
I do apologize if this is obvious to you
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Swiss french keyboard - Elyssa

Postby oliverjames on Thu Jun 12, 2008 6:03 pm

Hey Husse, You're right, but in the correct order still no good. WinXP fine, Zenwalk fine, my preferred system Mint, not working. Thank goodness for spell checkers but it's a bit of a hassle.

Oliverjames
oliverjames
Level 3
Level 3
 
Posts: 194
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Re: Swiss french keyboard - Elyssa

Postby Husse on Sun Jun 15, 2008 4:31 pm

I can't test the french keyboard layout as I obviously (?) have a swedish keyboard with special keys for åöä
but if I type ^ and then o I get ô
This may help you
Code: Select all
sudo dpkg-reconfigure locales
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Swiss french keyboard - Elyssa

Postby oliverjames on Mon Jun 16, 2008 1:39 am

No luck there either, still getting ^o.
oliverjames
Level 3
Level 3
 
Posts: 194
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Re: Swiss french keyboard - Elyssa

Postby Husse on Fri Jun 27, 2008 6:09 am

I've asked for help but no luck so far
This is really tricky - I don't know what to search for - keyboard layout plus what?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Swiss french keyboard - Elyssa

Postby oliverjames on Fri Jun 27, 2008 7:53 am

oliverjames wrote:Elyssa working well. I would like to cure this annoying glitch,

With my Swiss french keyboard, set to Swiss-French- no dead keys, when I type ^ o together they are presented as ^o rather than ô. Same with ^etre rather than être, etc.

Can anyone help me solve this.

Ciao

Oliverjames



Husse, Problem solved. :oops: The clue is in my initial posting, see above, ignorant of the "no dead keys" meaning I chose this. Reading the Wiki Keyboard settings info I am now wiser and have selected Swiss-French - dead keys. Lo and behold, problem solved - my dead keys now work.

Am writing out "engage brain before getting out of bed" 500 times and offer profuse apologies! êêêôôô.

However I am not currently able to use Linux (see my post "Thunderbird unusable under Linux") as my incoming mail gets hijacked. This does not happen under WinXP and for peace of mind I'm using that OS until I can find out what's going on.

Oliverjames.
oliverjames
Level 3
Level 3
 
Posts: 194
Joined: Fri Aug 10, 2007 3:00 am
Location: Divonne-les-Bains, France

Re: Swiss french keyboard - Elyssa

Postby Husse on Fri Jun 27, 2008 8:36 am

A post I've not seen I think - will have a look
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 12 guests